WordPress.org

Ready to get started?Download WordPress

Forums

Cant view wordpress properly from other computers (6 posts)

  1. nelson-ray
    Member
    Posted 7 years ago #

    i think this is a simple setup problem, that I have had in the past but I have never been able to figure out. I am running Xampp on a local computer with a backup of my website installed and running. On the computer hosting Xampp & WordPress I can view the webpage fine by typing in http://localhost

    The problem is when I try to view that website from other computers on my lan. I type in http://ip-address and the website shows up with text/images/links but without any formatting. The background is white and everything is listed in a vertical fashion. Could someone offer an advice how to correct this?

    I am using this setup to test out my actual website and any potential changes needed. thanks

  2. Go to your WordPress dashboard, click "Options" then look on the "General" tab.

    You will see values labelled "WordPress address (URL):" and "Blog address (URL):". You probably have "localhost" in one or both of those. WordPress uses those addresses a lot, and as "localhost" means "the computer I'm on right now", it will only work from the computer you have WP installed on.

    Change "localhost" to the IP address of the computer, and it will work from other computers on your LAN.

  3. drmike
    Member
    Posted 7 years ago #

    First thing I would do would be to look at your browser's page source and see what the URL for the CSS file looks like. My guess is that you have your blog setup to use 'localhost' as your domain name. WordPress uses the domain name within output and it's added that to the URL for your CSS file. Since localhost is just a loopback, those other computers are looking at themselves for the CSS, not where your computer is.

    The thing is though wordpress I believe is not written to work with an IP address though internally (I know wordpress multiuser isn't. It will actually kick out with errors if you try.) so even editing the Dashboard -> options and removing localhost while replacing it with the IP address will probably not work.

    Best bet would be to either go ahead and upload it to your host and keep quiet about it (Maybe install it into a subdirectory of the final domain for the time being) or fake a domain name (myowntempdomain.com isn't being used), add it to your box where the blog is, and point the other boxes you use to that IP address within their hosts files.

    Hope this helps,
    -drmike

  4. nelson-ray
    Member
    Posted 7 years ago #

    Hey thanks for the help. I did try to change the localhost setting in Dashboard-->Options and it didn't seem to work for me. I follwed drmike's advice and just uploaded the directory into a subdirectory on my website. That works well and lets me tinker with the settings and test it on various browsers/platforms. I appreciate the help thanks again...cheers

  5. jabecker
    Member
    Posted 7 years ago #

    drmike, fyi I use xampp to test locally.

    In my browser, I type in http://ip-address/sub-directory/

    In my general options, I have WordPress Address and Blog Address both set to http://ip-address/sub-directory/

    Works like a charm!

  6. nelson-ray
    Member
    Posted 7 years ago #

    I can confirm that it does work. Stupid me typed in the wrong ip address the first time. In Dashboard --> Options I set it to the correct local lan ip address and it now works on my local computer as well as the other computers in my lan! Now I can see how the nasty IE 6 is going to bork my website :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags