WordPress.org

Ready to get started?Download WordPress

Forums

Can't use Windows Live Writer after upgrading to 2.6.1 (7 posts)

  1. DebMomOf3
    Member
    Posted 5 years ago #

    I recently upgraded my blog to WordPress 2.6.1 and have run into a couple of problems. One of them is that suddenly I'm finding that Windows Live Writer is unable to connect to my site remotely. I've made sure that remote access is allowed in my WP settings, but still get the following error when I try to refresh my theme (for example):

    An unexpected error has occurred while attempting to log in:

    Network Connection Error - Error attempting to connect to weblog at:

    http://www.momof3girls.net/xmlrpc.php

    Unable to connect to the remote server

    I've tried replacing the xmlrpc.php file several times but am still getting the same error. Can anyone help??

    Thanks!

    Deb (Mom of 3 Girls)
    [sig moderated]

  2. whooami
    Member
    Posted 5 years ago #

    just a thought, though it doesnt sound like what you would see, and you mention changing "remote access", but just to be clear -- have you insured that xmlrpc posting is enabled? It's been turned into an option -- look under settings\writing

    Also, this forum frowns on signatures, especially signatures that contain links.. Its in the rules.

  3. DebMomOf3
    Member
    Posted 5 years ago #

    No, I didn't change anything for remote access. It worked fine before the upgrade. And yes, xmlrpc posting is enabled. :)

    Sorry about the link - I just put it in there so people would know what my site was if it would help anyone come up with an answer.

    Any other thoughts?

  4. DocShadow
    Member
    Posted 5 years ago #

    Check to make sure your host server is using PHP 5 - it looks like some recent changes require it for remote posting.

    Most hosts allow you to use PHP 5, but they default to PHP 4. To force the server to use PHP 5 add these two lines to your .htaccess file:

    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

    This resolved my issue, I hope it might also be what is causing your problems.

  5. Hathserv
    Member
    Posted 5 years ago #

    Did you come up with a solution for this as I have the same error.

  6. fionab
    Member
    Posted 5 years ago #

    In my case it works on one machine not the other so I think it is a live writer error not a wordpress error.

  7. fionab
    Member
    Posted 5 years ago #

    Found the answer. Apparently live writer only looks at the proxy settings in ie. so if like me you use firefox check that the ie proxy settings are also correct.

Topic Closed

This topic has been closed to new replies.

About this Topic