WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Can't use "thumbnail, medium, large" for images anymore? (12 posts)

  1. Lakjin
    Member
    Posted 4 years ago #

    Hello,

    After moving my website to a new server, I am no longer able to set images to "thumbnail" "medium" or "large" when inserting them in my posts. Only "full size" is available. I can, however, reduce the size of images by a percentage after they have been inserted.

    Any idea what is up?

    Thanks.

  2. Lakjin
    Member
    Posted 4 years ago #

    *Bump*

    Anyone have any clue?

    Thanks.

  3. MichaelH
    Member
    Posted 4 years ago #

    Quoting dd32 from the trac ticket you created:

    Chances are, in this case, your new server is lacking GD support.

  4. Lakjin
    Member
    Posted 4 years ago #

    Quoting dd32 from the trac ticket you created:

    Chances are, in this case, your new server is lacking GD support.

    I realize that. But can anyone tell me how I can add GD support? dd32 says to contact my hosting provider, but is there a way for me to do it myself before I resort to that?

    Thanks.

  5. MichaelH
    Member
    Posted 4 years ago #

    Most hosting situations will require your host to do that:
    http://www.google.com/search?q=adding+GD+support

  6. Lakjin
    Member
    Posted 4 years ago #

    Thank you very much. You can delete this thread now - my host was kind enough to help me out.

  7. MichaelH
    Member
    Posted 4 years ago #

    Not deleting this thread but will mark as resolved. Thanks for the feedback.

  8. hmasterson
    Member
    Posted 3 years ago #

    Hi,

    I'm running into this same issue and have confirmed that 'GD' is enabled and recognized in phpinfo. Some images work fine but others result in not having the option to select thumbnail, medium, large -- only the full size. I'm not seeing any errors in my php_error_log or apache_error_log. My account's memory limit is 64MB, which seems like it should be plenty.

    A test image I was using is here: http://grin.hq.nasa.gov/IMAGES/LARGE/GPN-2000-000473.jpg When downloaded, it's a total of 2.8MB.

    Any suggestions here?

    Thank you!

  9. aparentdesign
    Member
    Posted 3 years ago #

    I am also having this trouble, but only with old images circa 2009. Newly uploaded images work fine with the thumbnail feature so I think it's not a GD issue. Also, the files are small (~700k and <500x800px).

    What else could be causing this? This is on a blog running WP 2.8.4 (can't update or will break theme).

    We did not change hosting during this time, but did change our url.

  10. lsparks
    Member
    Posted 3 years ago #

    I am also running into this same problem. I definitely have GD library installed, and it does not seem to matter what format the images are in. Definitely frustrating.

  11. fmomin
    Member
    Posted 3 years ago #

    I checked with my server, ran the phpinfo file and GD support is enabled. Like a couple of other people above, I STILL cannot select the other image sizes (thumbnail, medium, or large).

    If anyone else has figured out how to fix this, any advice would be appreciated. The site I'm building is my final project for a class, due next week, and I really need to get things working ASAP.

  12. Pothi
    Member
    Posted 3 years ago #

    There may be two issues.

    1. After installing GD, one must restart their http server.
    2. There is a chance that GD is not properly installed or configured. In this case, check if your GD lib is properly installed. You may use the script found in the following page...

    http://www.dagondesign.com/articles/checking-for-gd-support-on-your-server/

    Warning: If you do not understand the script, please do not run it. It applies to any script. Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags