WordPress.org

Ready to get started?Download WordPress

Forums

Thematic
Can't Use Thematic Child Theme (5 posts)

  1. tonib
    Member
    Posted 1 year ago #

    Hi,

    I'm trying to edit the child theme that comes w/Thematic 1.0.3.1. I copied the child theme and changed the name of the folder just like the instructions said. Then I copied the default.css file from the Thematic folder to the bottom of the style.css file for the child theme, and uploaded it using Filezilla. When I tried to activate the theme I got a messsage from WordPress that said "Are you sure you want to do this? Please try again"

    Any idea what I'm doing wrong?

    Thanks in advance,

    Toni

  2. Mohd Rafie
    Member
    Posted 1 year ago #

    Did you upload both the child theme and Thematic theme on the wp-content/themes?

  3. tonib
    Member
    Posted 1 year ago #

    Yes. I can see both themes on the WP Manage Themes page, but when I select the child theme I get the "are you sure you want to do this?" message. I just did the latest upgrade through WP, and made sure that style.css Template: setting is thematic. The Version still says 1.0 though. Could that be the problem?

  4. Gene
    Member
    Posted 1 year ago #

    Hi tonib,

    Moving a copy the thematicsamplechildtheme to wp-content/themes/ and activating it in the Admin > Appearance > Themes area of the WP Admin should work. It does for me.

    If you continue to have problems try ftp'ing a new fresh copy of the child theme. If you still see that error message, try zipping the childtheme and using the builtin WordPress theme uploader found at Admin > Appearance > Themes > Install Themes.

    There's no need to copy the contents of the default.css in tho the thematicsamplechildtheme's style.css since it is @imported in the file. You may have reasons for doing that but try activating the theme without making any edits to the style.css first.

    Also the version of the Thematic Sample Child theme is supposed to be 1.0

    ON a side note the sample child theme was just updated in Thematic 1.3.2 which has nott passed trhough theme review yet. There are some signifigant changes to how the custom header image is handled. If you want to experiment with it you can that version here:

    https://github.com/ThematicTheme/Thematic/tags

  5. Gene
    Member
    Posted 1 year ago #

    Thematic 1.0.3.2 has been released and the sample child theme was changes were included. Try it out and let me know if you are still experiencing the problem?

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic