WordPress.org

Ready to get started?Download WordPress

Forums

Can't use Insert/Edit Link in Visual Mode: tinyMCEPopup is not defined. (4 posts)

  1. Xtina
    Member
    Posted 5 years ago #

    I'm in Firefox 3 using WP.org 2.7.1.

    I log into WP as an admin-level user, and go to add a new post in Visual mode. When I highlight text and click Insert/Add Link (or hit Alt+Shift+A), the page is darkened and a popup box appears, but there's no title or content. I can close out of the box and resume editing.

    I go to Tools > Error Console, and I see these two messages:

    Error: tinyMCEPopup is not defined
    Source File: http://axisofevil.net/~xtina/blog/wp-includes/js/tinymce/utils/form_utils.js?ver=3211
    Line: 10

    Error: tinyMCEPopup is not defined
    Source File: http://axisofevil.net/~xtina/blog/wp-includes/js/tinymce/themes/advanced/js/link.js?ver=3211
    Line: 1

    The lines in those files, respectively:

    var themeBaseURL = tinyMCEPopup.editor.baseURI.toAbsolute('themes/' + tinyMCEPopup.getParam("theme"));

    tinyMCEPopup.requireLangPack();

    What am I missing?

  2. Xtina
    Member
    Posted 5 years ago #

    (Though I suppose you could just click on the links and see the files that way. I'm a bit pre-caffeinated.)

  3. Xtina
    Member
    Posted 4 years ago #

    I post for others' benefit:

    If you're using Firefox and have the AdBlock addon installed, whitelist the page you're on.  This resolved my issue.

  4. Khaled Hakim
    Member
    Posted 4 years ago #

    This is, in specific, a way I have found to solve a problem for the following error: 'tinyMCEPopup is undefined'

    But it may also be a successful solution for other problems faced with WYISWYG admin side editor.

    So, if you are finding yourself facing problems with your WordPress Admin-side WYISWYG editor, where say for instance when you click on a the "add link" button in the editor after highlighting text, the lightbox window loads with empty content, or the same empty lightbox appears when you try to change the color of text by clicking on the color picker and selecting more colors... then this is a viable solution for you.

    Download the following plug-in:
    http://wordpress.org/extend/plugins/tinymce-advanced/

    If you prefer to install plug-ins directly from within WordPress, then search for the Plug in named: TinyMCE Advanced | Version 3.2.7 | By Andrew Ozz

    > After installation is complete, Activate the plugin.
    > Go to the dashboard of your admin
    > On the left hand side, find the TinyMCE Advanced listed under "Settings" and Open it up.
    > You will see your existing WYSIWYG editor followed by two empty gray rows. Below these two empty rows is another container with a whole lof of new buttons you can add to your WYSISWG editor by clicking and dragging.
    > Add buttons by clicking and dragging from the bottom to the two empty gray rows. Even if you do not need to add buttons, add some for the heck of it, and to make sure that plug-in is activated / enforced to come into action - if that is the right phrasing.
    > Save settings.
    > Go to edit a post or a page. Highlight some text and try inserting link by clicking on the link icon in the WYSIWYG editor. Or try doing something that was "not working" before, such as editing color of text.

    > It should work now.

    Please let me know if this solution worked for you.

    Cheers.

Topic Closed

This topic has been closed to new replies.

About this Topic