WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Can't upload pictures or sound (8 posts)

  1. DrDClutter
    Member
    Posted 4 years ago #

    I can't upload pictures or sound and get this message every time, no matter which uploader I use: Unable to create directory D:\Hosting\2999633\html/wp-content/uploads/2010/04. Is its parent directory writable by the server?

    If I want to use a picture, I have to copy and paste from my blogger account to do so.

    Thanks!!

    I'm @ drdclutter.com

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    Change the permissions on the wp-content directory to 766. If you still have problems, try 767 or 777. Once your uploads are working, change the permissions on wp-content back to 755 again and check that everything still works OK.
    http://codex.wordpress.org/Changing_File_Permissions

  3. DrDClutter
    Member
    Posted 4 years ago #

    Esmi,

    Thanks for the information, but that's WAY to complex for me to attempt (I'm a total novice)-I wouldn't know where to begin. The warnigns alone scared me. I guess I'll just have to keep cutting and pasting.

    Thanks!!

  4. WPpremium
    Member
    Posted 4 years ago #

    If you have purchased a hosting service, you can contact your provider to take care of this.

  5. edurios
    Member
    Posted 4 years ago #

    I cant upload images/files to my post using the buttons: upload image -upload video or upload object.
    when i do a click over on of these buttons, they sent me a flash uploader: when the bar is filled, it gives me the option: "are you sure you want to do that?" (in spanish)/ and "try again".
    I only can upload images using the library option but it takes lot of time, because I have to check the url, then copy`/paste the url in the post using html.
    how can i make the flash uploader work?

  6. esmi
    Forum Moderator
    Posted 4 years ago #

    @edurios: Post a new topic.

  7. Shane G.
    Member
    Posted 4 years ago #

    Hi DrDClutter,

    Contact your web hosting service provider and update them to grant the 755 recursive permissions to wp-content folder. 777 permissions may lead to the hack of the part of your blog.

    Thanks,

    Shane G.

  8. DrDClutter
    Member
    Posted 4 years ago #

    Problem solved!! Thanks for all of the help.

Topic Closed

This topic has been closed to new replies.

About this Topic