WordPress.org

Ready to get started?Download WordPress

Forums

Can't upload photos (10 posts)

  1. recharger
    Member
    Posted 8 years ago #

    Hi,
    I am a WordPress neophyte. When I attempt to upload a photo from my hardrive, I get the following message:

    Unable to create directory /home/myloginname/public_html/wp-content/uploads/2006/04. Is its parent directory writable by the server?

    Is there a way to correct this?
    Must I go into my WordPress files via FTP?

  2. ladydelaluna
    Member
    Posted 8 years ago #

    sounds like an permissions error - try CHMODing the uploads directory to "755" so that it's writeable.

  3. moshu
    Member
    Posted 8 years ago #

    In the error message the keyword is parent directory. Meaning wp-content has to be writable.

  4. recharger
    Member
    Posted 8 years ago #

    Hi, Ladydelaluna wrote:

    sounds like an permissions error - try CHMODing the uploads directory to "755" so that it's writeable.

    Can you explain CHMOD please, and 755? Is that a file in the WordPress content? Where do I find it?
    I apologize for being such a dummy, but I'm new to this.
    Thansk.

  5. moshu
    Member
    Posted 8 years ago #

    Do you have a FTP client/software that you use to upload files? Or, do you have access to some kind of site admin panel (like cPanel or Plesk or something)?

  6. recharger
    Member
    Posted 8 years ago #

    I have FTP client software (Fetch). I have also been trying to find my cPanel, but I can't.
    Do you know where I'd go to find it?

  7. Zirotti
    Member
    Posted 8 years ago #

    I believe with Fetch, that if your right click on wp-content/uploads directory, you will have an option about 'Permissions' or 'CHMOD'. If so, change the permission to 755. i.e. read, write.

    Also, try this link to Fetch's FAQ. This should have some good info.

  8. recharger
    Member
    Posted 8 years ago #

    You wrote:

    "I believe with Fetch, that if your right click on wp-content/uploads directory, you will have an option about 'Permissions' or 'CHMOD'. If so, change the permission to 755. i.e. read, write."

    I went to Fetch, found the wp-content folder, but I didn't find anything there about uploads directory. Do you know what it might be called? I did find folders on plug-ins and themes. And one called "index php."

  9. moshu
    Member
    Posted 8 years ago #

    OK, I am saying the second time: You have to change the permissions on the wp-content directory - that's the parent mentioned in the error message. If the wp-content directory is writable (cmod) then WP will create the rest of the directories (uploads, year, months).

  10. recharger
    Member
    Posted 8 years ago #

    Thanks for replying again. Here is my problem. I go to my WP-Content directory, and I see no "uploads" file. I see other files--index.php, plugins, themes--but nothing that says "uploads."
    Do you know where I should look?
    Thank you

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags