WordPress.org

Ready to get started?Download WordPress

Forums

Can't upload media above 100kb (6 posts)

  1. mrp1nk
    Member
    Posted 1 year ago #

    I know it's been asked many times but still - here I am, unable to upload any media above 100kb into media library, I've already tried turning off plugins and switching to default theme, editing '.htaccess' files, 'wp-config', even 'install' in wp-admin. No results so far and I have no access to php.ini so are there any solutions (apart from contacting my host) that i could try ?

  2. Paul Phillips
    Member
    Posted 1 year ago #

    Hmm, 100kb is very small for a max upload limit. Could you try verifying it?

    $max_upload = (int)(ini_get('upload_max_filesize'));
    $max_post = (int)(ini_get('post_max_size'));
    $memory_limit = (int)(ini_get('memory_limit'));
    $upload_mb = min($max_upload, $max_post, $memory_limit);
    
    echo 'Limit set at: '.$upload_mb;
  3. mrp1nk
    Member
    Posted 1 year ago #

    Where should I run this ? (using cpanel)

  4. Paul Phillips
    Member
    Posted 1 year ago #

    Just create a new file called test.php and stick this in it.

    <?php // Shows Max upload size
    
    $max_upload = (int)(ini_get('upload_max_filesize'));
    $max_post = (int)(ini_get('post_max_size'));
    $memory_limit = (int)(ini_get('memory_limit'));
    $upload_mb = min($max_upload, $max_post, $memory_limit);
    
    echo 'Limit set at: '.$upload_mb;

    Then upload it to your host and navigate to it in your browser.

  5. Paul Phillips
    Member
    Posted 1 year ago #

    Second thoughts, if your host has enabled display of the php.ini settings in cPanel you should be able to find them there too!

  6. mrp1nk
    Member
    Posted 1 year ago #

    Using your php file I have result: Limit set at: 64 so that's weird cause still i get stuck on 100% while uploading bigger file...

Topic Closed

This topic has been closed to new replies.

About this Topic