WordPress.org

Ready to get started?Download WordPress

Forums

cant upload images on my local server (21 posts)

  1. sarsells
    Member
    Posted 3 years ago #

    Hi everyone :-)
    I have wordpress installed on my computer on a local XAMPP server. I have started working on a website, but am unable to upload any images. I have had a look at a live wordpress site I have, and then at the local server. On my local server I did not have an upoads folder for my media files. I aassumed this was the problem, so I created one. However, this hasmade no difference.
    Can someone PKEASEadvise?

    Many thanks

    Sarah

  2. What error are you receiving?

  3. Jason
    Member
    Posted 3 years ago #

    Have you given IUSR write permissions to that directory location?

  4. sarsells
    Member
    Posted 3 years ago #

    Thanks for the interest.
    The error is

    Unable to create directory /Applications/XAMPP/xamppfiles/htdocs/wordpress/wp-content/uploads/2010/08. Is its parent directory writable by the server?

    I have looked at the folders and they are readable and writeable by me.
    I am not sure what IUSR is? I had a look on the local server and a far as I can tell the permissions are set. Perhaps I am looking in the wrong place?
    The above error refers to an uploads folder. i have looked in the location specified and there was not one there. So, I created one. this has not made any difference.

  5. I have looked at the folders and they are readable and writeable by me.

    The above error refers to an uploads folder. i have looked in the location specified and there was not one there.

    Exactly what permissions did you grant the uploads folder? You may need read-write-delete permissions for everyone, not just your ID

  6. sarsells
    Member
    Posted 3 years ago #

    Well I am the only user for my site. shall I change the WP installation to read write for all users on my computer?

  7. WordPress doesn't run as you the same way it does .... Well right its a permissions thing usually. And alas, it sounds Ike you're on windows and that's out of my expertise. I don't know what the file permissions for XAMMP needs to be.

  8. sarsells
    Member
    Posted 3 years ago #

    Actually I am using Xampp on OSX.
    I tried changing the permissions for everyone on the wordpress folder locally and then when I tried adding an image to my blog, I got some sort of fatal error. So, I have changed the folder back now, and I am in the same position as before. I am unable to add images on my wordpress file.

  9. KristinaLynn
    Member
    Posted 3 years ago #

    I'm having the same issue. Didn't have a problem until I upgraded to 3.0.1. Now when I try to upload files from my computer I get “imagename.jpg” has failed to upload due to an error
    Unable to create directory /home/.jellies/kristinalynn/kristinalynnphoto.com/blog/wp-content/uploads/2010/08. Is its parent directory writable by the server?"

    Originally after the upgrade all the folders were set to these permissions:
    OWNER: read, write, execute
    Group: read, execute
    OTHER: read, execute

    I have gone through and tried setting all the folders: blog, wp-content, uploads, 2010 and 08 to read, write, execute for all three categories and I'm still getting the same message. A little irritating! Anything else I can try?

  10. Make the uploads folder (and any subfolders under that) this:
    OWNER: read, write, execute
    Group: read, write, execute
    OTHER: read, write, execute

    Yeah, I know. But just try it.

    FYI, DO NOT make the wp-content folder that, you only want to change the uploads folder and it's children.

  11. KristinaLynn
    Member
    Posted 3 years ago #

    Nope that didn't work. I changed EVERY folder under the uploads folder to read, write, execute and it still doesn't work :(

  12. sarsells
    Member
    Posted 3 years ago #

    I am having the same problem. I tried changing the permissions only on the upload folder and that did not work. Incidentally, I had to create the uploads folder myself, as it was not there when I installed wordpress 3.0.1
    PLEASE can someone help as I am unable to design my site without this working!

    Thanks so much :-)

  13. sarsells
    Member
    Posted 3 years ago #

    Hooray--- It is now working. I had not changed the permissions to all for the children of the uploads folder. that is now done, and I created a 09 folder....and Voila! KristinaLynn, i hope you can resolve this now?

  14. KristinaLynn
    Member
    Posted 3 years ago #

    Nope I'm still having problems. I've changed all my permissions like I should and still not working :( Getting a little annoyed.

  15. kirstin harrington
    Member
    Posted 3 years ago #

    I am having a problem with page margins. I am trying to upload images onto the first page, but they keep getting cut off on the right side

  16. meow_mix
    Member
    Posted 3 years ago #

    I did the same as KristinaLynn. Everything contained in "uploads" has been set to 777 and it is *still* telling me I don't have permission to upload. Shy of doing wp-content too (which Ipstenu says NOT to up above), I can't think of why else this wouldn't be working.

    Does it matter that I recently migrated my site from another host? (I've already changed the path to reflect where wordpress resides on my new host in the media settings.)

    Uploading to flickr and inputting their whole URL linkfest shebang is really grating so I'd like to get this working.

  17. meow_mix
    Member
    Posted 3 years ago #

    Also tried what someone else suggested and created the folder from my web host's file manager instead of FTP to circumvent ownership issues, and bupkes.

    Also tried myriad file path fixes including one by TrLocke in another thread (removing the slash from before "wordpress/wp-content"—there was no slash preceding that on my setup, so that isn't it either).

    This is driving me crazy!

  18. meow_mix
    Member
    Posted 3 years ago #

    Crap. Just found out I'm now on a Linux server. Am assuming this is the problem. Is there a reasonable fix for this or am I doomed to flickr hell forever?

    (This is for wordpress version 3.0.4 fwiw)

  19. meow_mix
    Member
    Posted 3 years ago #

    BOOM. My host was able to answer this for me. To help anyone else who repeatedly was unable to resolve this, stop CHMODing yourself into a coma. The guy I talked to said this:

    php file upload is usually set as apache:apache and then modified via the ftp user.

    Just set your domain to use PHP as FastCGI instead of Apache. That will run it as the ftp user and everything will be awesome, even with safe mode on.

    You can do this in Plesk by clicking on the domain then web hosting settings.

    The second I did this, I logged out of WP and then back in and uploaded an image no problem. HTH! :)

  20. maoski
    Member
    Posted 3 years ago #

    @meow_mix is your installation on a sub folder or the root folder of your webhost? oops looks like you have it working, congrats :)

  21. barsoum
    Member
    Posted 2 years ago #

    For what it's worth, xampp starts off the apache process as user nobody...so to get that user to be able to write to your upload folder, go into your wp-content folder and if there isn't an uploads directory mkdir it. Then run (replacing the YourUserName bit):

    sudo chown -R nobody:<YourUserName> uploads

    Uploads worked for me after that.

Topic Closed

This topic has been closed to new replies.

About this Topic