WordPress.org

Ready to get started?Download WordPress

Forums

Can't upload images after update to 3.4.1 (16 posts)

  1. proimagemedia
    Member
    Posted 1 year ago #

    Since doing the automatic update to 3.4.1, I cannot upload any images, in posts, pages, headers, or backgrounds. When I go to the media library, the image shows as a question mark, if I click on it, I can see the image, but it will not insert into WordPress. The thumbnail remains as a question mark. Please help - URGENTLY.

  2. David Gard
    Member
    Posted 1 year ago #

    Upload an image through the Media tab, but before you leave the page after upload, check that there is no error at the bottom of the page. It could be that WP doesn't have the necessary permission to upload the image, but it will still create the entry in the DB in some cases.

  3. thefr00n
    Member
    Posted 1 year ago #

    I'm having this problem too. It's weird. Completely fresh install of 3.4.1, no plugins, Twenty-Eleven theme (although this happens with other themes too).

    I can upload an image through the Media tab, but it won't show up, and won't insert. Bizarrely, I can can sorta view the image if I go into the media library, select it, and choose Edit Image. But no image will be Header, and no image will insert.

    This does not happen on versions prior to 3.4.1.

  4. Annemcx
    Member
    Posted 1 year ago #

    I'm having the same problem. I've tried both browser upload options on the post upload feature itself and from the media tab too. In every case the upload just keeps hanging or the picture has uploaded but only partially.

    I must have tried a hundred times already with various pictures, and have checked the media settings tab. I'm out of ideas and still no joy.

    It's becoming a massive time suck. All help would be appreciated. Thanks.

  5. esmi
    Forum Moderator
    Posted 1 year ago #

    Please post your own topic.

  6. proimagemedia
    Member
    Posted 1 year ago #

    Well after two full days of trying absolutely everything, having looked through similar topics, questions and replies on this forum and others, and no helpful answer from WordPress, I have had to remove my WordPress installation completely, and re-create the full site, backdating all the pages and posts :( What a waste of time!

  7. MissMarlboro
    Member
    Posted 1 year ago #

    Same problem here. I've tried every possible solution I found here in the forums, but nothing seems to work for me.
    Any other solution to try?

  8. rmsotiong
    Member
    Posted 1 year ago #

    Had the problem earlier, just solved it in my site a few minutes ago, hope this will also work for you.
    1. Go to Settings -> media
    2. On the "Store uploads in this folder" enter the default folder "wp-content/uploads"
    3. Save
    4. Try inserting an image on a post. (this worked for me)
    5. For testing sake, I removed the default folder I entered "Store uploads in this folder", then save.
    6. Tried it again on a post, it still works.

  9. froggie72
    Member
    Posted 1 year ago #

    I'm able to go to Gallery, install image, but can't close the box an return to page. It just won't close, no matter what I do. Although the edited page shows as grayed out, but I can't close the box. If I click back, I lose the image. I'm using the latest WP version.

    http://videowavemaker.com

  10. AleOrtiz
    Member
    Posted 1 year ago #

    I'm having the same problem. I upload the image, the image name just comes up on the Media list, no image. If I try to insert it into a post, I get the broken link icon, but no image. Please help. I tried editing the Store uploads in this folder in media setting, but did not work...I was able to upload just fine before the upgrade... Thanks!

  11. wih22
    Member
    Posted 1 year ago #

    I cannot upload any pictures into my media files - it says
    Unable to create directory D:\vhosts\howtoworkaroom.co.uk\httpdocs/wp-content/uploads. Is its parent directory writable by the server?

    I have unchecked the 'organise my files box' as described on other forum posts - but don't know how to fix this - can anyone help? Using V 3.4.1

  12. esmi
    Forum Moderator
    Posted 1 year ago #

    Try changing the permissions on the wp-content directory to 766. If you still have problems, try 767, 775 or 777. Once your uploads are working, change the permissions on wp-content back to 755 again and check that everything still works OK.
    http://codex.wordpress.org/Changing_File_Permissions

  13. wih22
    Member
    Posted 1 year ago #

    I am such a newbie on this - thanks for your prompt reply, but where exactly can I find the wp-content directory to be able to change it to 766?

  14. esmi
    Forum Moderator
    Posted 1 year ago #

    You would need to FTP into your site or use whatever file management application your host provides. The wp-content folder is inside the folder that you installed WordPress into.

  15. AleOrtiz
    Member
    Posted 1 year ago #

    Hi there, I tried changing all permisions as suggested. No changes at all, same problem uploading images...any other suggestion???

  16. esmi
    Forum Moderator
    Posted 1 year ago #

    @AleOrtiz: Please post your own topic.

Topic Closed

This topic has been closed to new replies.

About this Topic