WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Can't upload images (8 posts)

  1. mikeatvillage
    Member
    Posted 6 years ago #

    Hi,

    I'm getting this error "Failed to write file to disk." when I try to upload images from Admin/Write. /wp-content has permissions set to 777 as has /wp-content/uploads

    Any idea? I've tried a search without luck.

    Thanks

  2. MichaelH
    Member
    Posted 6 years ago #

    Wonder if you can upload images using FTP to that folder?

  3. mikeatvillage
    Member
    Posted 6 years ago #

    Yes, I've just uploaded an image to /wp-content/uploads using eLeetFTP without a problem. Also able to put files there using Dreamweaver.

    Do you know which of the wp files holds the name of the destination folder so I can check it's correct ?

    ATB

    Mike

  4. MichaelH
    Member
    Posted 6 years ago #

  5. mikeatvillage
    Member
    Posted 6 years ago #

    Thanks Michael,

    I've checked the setting there and it is the default /wp-content/uploads but I still can't upload anything.

    :-(

    Anything else I should check ?

    ATB

    Mike

  6. mikeatvillage
    Member
    Posted 6 years ago #

    Hi again,

    I posted my query on my host's support forum and this was a reply...

    "My first guess would be that WordPress is using the copy() function to upload images. Because the open_basedir redirect is in place for security reasons, the copy() function will fail and move_uploaded_file() should be used instead."

    Could this be the case ? If so, where can I edit this ?

  7. mikeatvillage
    Member
    Posted 6 years ago #

    Any ideas on this ? I've just searched my site for "copy" but the result comes up with thousands :-(

  8. mikeatvillage
    Member
    Posted 6 years ago #

    Ah ha... resolved :-) My host advised me...

    "Have you enabled the 'upload_tmp_dir' PHP setting in the PHP settings section of MyPanel?

    Creating a 'tmp' directory with the permissions set to 777, and then making the change in MyPanel should fix it."

Topic Closed

This topic has been closed to new replies.

About this Topic