WordPress.org

Ready to get started?Download WordPress

Forums

Can't Upload Files/Images (36 posts)

  1. humm
    Member
    Posted 8 years ago #

    Unable to create directory *********/blog/wp-content/uploads. Is its parent directory writable by the server?

    Later i created the folders it asked now i get error :

    Warning: move_uploaded_file(******/blog/wp-content/uploads/2006/01/82_page_bkg.gif): failed to open stream: Permission denied in ************/blog/wp-admin/admin-functions.php on line 1757

  2. humm
    Member
    Posted 8 years ago #

    help someone

  3. humm
    Member
    Posted 8 years ago #

    can someone reply me????

  4. spencerp
    Member
    Posted 8 years ago #

    Update: Removed my previous posted info and questions.

    One of the moderators will or should be around to help ya soon though. They good at that lol!! =)

    spencerp

  5. padoko
    Member
    Posted 8 years ago #

    Hi!

    When I want to upload an image or something first I get this answer:

    "Unable to create directory /***/wp-content/uploads/2006/01. Is /***/wp-content/uploads/2006 writable?"

    When I crate the directory .../uploads/2006/01 by myself, I'm able to upload images. But I think WP2 could do this automatically.

    Is there some help out there???

    Thanx!

  6. humm
    Member
    Posted 8 years ago #

    It seems, no one knows the solution!

    helllllllllo ?

  7. zota
    Member
    Posted 8 years ago #

    I'm having the same problem when I try to use the slick inline uploader.

    Also, my installation of WordPress 2 no longer has ANY options for file uploads -- Miscellaneous Options now only has "Track links" and "Use legacy" checkboxes.

    Also, even if the uploader did work as it wants to, I want to choose my upload directory. Is this hardcoded now?

    These are pretty serious issues, but after an hour of searching, I can't find documentation for the new "features." Am I going to have to downgrade back to 1.5?

  8. Arnan de Gans
    Member
    Posted 8 years ago #

    chmod your folder to 0777

  9. humm
    Member
    Posted 8 years ago #

    it doesn't work!

  10. humm
    Member
    Posted 8 years ago #

    Can someone help on this?

  11. mores
    Member
    Posted 8 years ago #

    problem with me was that i couldn't chmod the newly created 2006 folder since it seemed like my ftp user wasn't the owner.
    so i deleted it manually and chmod 777 it.

    then wp wanted to put a 01 directory in there.
    okay, same procedure again.
    i decided to create directories 01 up to 12, chmod777 to all of them, now it works.

    strange, though.

  12. humm
    Member
    Posted 8 years ago #

    hmm... lemme try!

  13. j0d
    Member
    Posted 8 years ago #

    wordpress automatically makes the directroy, you msut make sure that your wp-content dir is CHMODed to 777

  14. humm
    Member
    Posted 8 years ago #

    wp-content dir is CHMODed to 777 ??????

    are you kidding?????????????????? Isn't it risky to make that 777 ?

  15. Arnan de Gans
    Member
    Posted 8 years ago #

    dont make the wp-content folder 0777

    instead WP2.0 wants a uploads folder in the wp-content folder
    (wp-content/uploads/) make the uploads folder 0777 and you should be fine!

    This worked for me and this was what i meant with my earlier post. I assumed you knew i was talking about the uploads folder :)

  16. humm
    Member
    Posted 8 years ago #

    thanks friends, its working for me now! :D

  17. mmzeroexpcom
    Member
    Posted 8 years ago #

    I've triple checked all wp_content, wp_content/uploads
    2006 and 01 -12 folders. The upload function wasn't creating any of the folders. I created them myself and
    have made certain that every folder is chmoded to 777
    I'm still getting the error messages that it can't open the stream...
    any other ideas?

    thanks,

  18. mmzeroexpcom
    Member
    Posted 8 years ago #

    Ok, I did find a solution, so I hope this info will help someone.
    As I stated above, I had checked and triple checked the permissions on all applicable folders. Here was the issue, I happened to have also had Front Page Extensions enabled for the site. even when I removed them, the web hosting
    tech had to manually change ownership issues to recover ownership back to "normal". That did the trick.

    http://www.zeroexp.com/zeroexpwp

  19. kickass
    Member
    Posted 8 years ago #

    For the record, having folders a chmod 777 is a very insecure practice, and one that has been brought to the attention of the developers more than once. It is a much safer practice to simply upload images via ftp and link to them or use a plugin to do so. There are some fine ones out there.

  20. Bananafeller
    Member
    Posted 8 years ago #

    I have a problem to:
    When I want to upload a file there is always a message that tells:
    File is empty. Please upload something more substantial.
    But I can't load up anything!

  21. Arnan de Gans
    Member
    Posted 8 years ago #

    kickass:
    even a plugin needs read/write access rights. Probably another level of access will work, 755 or even 666 probably wil. but 777 guarantees a working sollution.

  22. alekone
    Member
    Posted 8 years ago #

    I have the same problem, and none of the above solutions works. my host is running php in safemode.

    this is the error I get
    Warning: move_uploaded_file(/home/virtual/site29/fst/var/www/html/avantgarden35.org/wp-content/uploads/2006/01/provola.gif): failed to open stream: Permission denied in /home/virtual/site29/fst/var/www/html/avantgarden35.org/wp-admin/admin-functions.php on line 1757

    Warning: move_uploaded_file(): Unable to move '/tmp/phpTYQ7rf' to '/home/virtual/site29/fst/var/www/html/mywebsite.org/wp-content/uploads/2006/01/provola.gif' in /home/virtual/site29/fst/var/www/html/mywebsite.org/wp-admin/admin-functions.php on line 1757
    The uploaded file could not be moved to .

    I manually created all the folders and chmoded everything 777 but nothing. 1.5 upload worked and the iimage browser plugin for the uploads worked.

  23. Nevioth
    Member
    Posted 8 years ago #

    i had exactly that same problem and changed the rights for '../wp-admin/admin-functions.php' to 755. It works now.

  24. ianmcn
    Member
    Posted 8 years ago #

    I also have this problem, I have changed all related folders to 777 just to make sure, but it still doesn't work.

    I don't have FP extensions installed, but I do get the feeling that this problem is caused by a conflict with something on my server as reading this thread makes it look like some people it works for straight away and others it doesn't work for at all.

    Any programmers have any ideas?

  25. ianmcn
    Member
    Posted 8 years ago #

    Just to give some background, I am using an Apache server with FP extentions turned off, but PHP safemode is turned on. This is not something I have control over, could it be an issue?

  26. HapaxLegomen
    Member
    Posted 8 years ago #

    One silly question : If I DON'T want to upload in the wp-content folder, but in another one, I can't anymore ???!!!
    It's rare when a 0.2 makes less think than a 1.5, isn't it ?

    My server is in safe mode and I can't anymore upload anything... Why a simple upgrade makes things so ugly ?!

  27. jcostom
    Member
    Posted 8 years ago #

    Hapax is right on!

    In 1.5, I could specify an upload directory, which is my preference. I just noticed that in 2.0 that option seems to have flown the coop.

    Here's my vote: Put the option back and don't break the previous functionality!

  28. spencerp
    Member
    Posted 8 years ago #

    Like I said numerous of times, why not just reupload the wp-admin/options-misc.php file from a previous version? The "old school" way of uploading will be re-added to your blog. It works with 2.0 as well. =)

    http://wordpress.org/support/topic/54113?replies=17#post-296735

    or that thread in general really.
    http://wordpress.org/support/topic/54113

    Cause there is plugins to use to, that might help as well. =) If you reuploaded the wp-admin/options-misc.php file to the wp-admin folder and then give any folder you choose a 777 chmod. It should be fine, just DON'T chmod the wp-content folder 777!

    spencerp

  29. ianmcn
    Member
    Posted 8 years ago #

    Thanks for the reply SpencerC, although I have no doubt your solution would work it seems crazy that you have to go back to some 1.5 functionality in order to upload things!

    I wouldn't mind so much if it was just for me, but I'm setting up wordpress for a client and I can hardly say "Don't use that nice looking image upload tool on the write page, go to the completely seperate upload page instead"!

    At the moment I'm leaning towards installing WP1.5 with wysiwordpress but I'm not delighted with that option.

  30. spencerp
    Member
    Posted 8 years ago #

    ianmcn, you could always just replace the wp-admin/options-misc.php file before hand, then the "client" wouldn't know the difference and it would "appear" as a normal package of WP to start with. =)

    I dunno, "they", the original WP makers shouldn't have taken out that option to begin with. Because everyone has used that WP option for HOW LONG NOW...and then all the sudden it's gone!

    That just throws ppl off totally. You get so used to something being there, then all the sudden it's gone.. Don't make any sense to me, but I guess they had their reasons behind it.. =) Just use or do what your "thoughts" and "heart" tells ya to do then I guess.. =)

    spencerp

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.