WordPress.org

Ready to get started?Download WordPress

Forums

Can't upload custom header plus error when trying to connect (12 posts)

  1. twriterext
    Member
    Posted 1 year ago #

    I am new to WordPress (although not new to html and css), and I must admit to finding WordPress a steep learning curve, although I am usually good with applications.

    At present, when I try to view my website (http://www.zsoundz.net), I get this message, even though I can see the site (there isn't, as yet, much there):

    "It seems we can’t find what you’re looking for. Perhaps searching can help."

    The message is the same whether I try to connect directly from the browser (Firefox v. 18.0.2 or from the WP Dashboard)

    Despite that message, I tried to upload an image as a header, and I got this message:

    Unable to create directory uploads/2013/06. Is its parent directory writable by the server?

    Clearly, I am missing something fundamental, and I hope someone on this forum can help. I tried the "Search the Support Forums," but I did not find anything that seemed relevant.

    Thank you.

  2. Jorge
    Member
    Posted 1 year ago #

    Your content shows up on a search and when I follow the page links. To fix your front pays issue, here's a link that may help:

    http://codex.wordpress.org/Creating_a_Static_Front_Page

    The upload issue may have to do with permissions. Here's more on that:

    http://codex.wordpress.org/Changing_File_Permissions

    Hope this helps.

  3. CrouchingBruin
    Member
    Posted 1 year ago #

    Yes, it sounds like you originally had your static page point to one page, you created a different page that you wanted to make your home page (page ID 5), you deleted the original page, and now WordPress can't find the original home page because you didn't change the setting.

    From your Dashboard, go to Settings > Reading, and you hopefully have A static page selected. Then in the drop-down list, make sure you have a valid page selected.

    In order to eliminate confusion, I would also change your permalinks, so instead of your pages looking something like this:
    http://zsoundz.net/?page_id=6
    They look like this:
    http://zsoundz.net/about
    Go to Settings > Permalink and choose something other than default.

  4. Jorge
    Member
    Posted 1 year ago #

    Updating your permalinks may also help figure out the upload error as WordPress would have to write to the server.

  5. twriterext
    Member
    Posted 1 year ago #

    I think I am still missing something fundamental here.

    I do not want the Home page (Title page?) to be a blog page. I want it to be like a standard website Home page, with links to the other pages.

    Now I deleted the added page I called Home, but added several new "Static" pages.

    I tried to upload a custom header, and again received this error message:

    "Unable to create directory uploads/2013/07. Is its parent directory writeable by the server?"

    Now regarding this statement:

    "From your Dashboard, go to Settings > Reading, and you hopefully have A static page selected. Then in the drop-down list, make sure you have a valid page selected."

    I am not sure what to do. The Title (?) Home (?) page does not appear in the drop down list.

    Regarding this statement:

    "In order to eliminate confusion, I would also change your permalinks, so instead of your pages looking something like this:
    http://zsoundz.net/?page_id=6
    They look like this:
    http://zsoundz.net/about
    Go to Settings > Permalink and choose something other than default."

    Again, I am not sure what choice to select. I am inclined to chose "Custom Structure http://zsoundz.net", but I really don't understand what this does. Does a choice here affect all "Pages"?

    I have been using the Blue Host YouTube videos and the Word press support web pages, but I must still be missing something (or several somethings) that is (are) basic to understanding how to create a website using Word Press.

    I appreciate any help you can offer.

  6. Jorge
    Member
    Posted 1 year ago #

    I do not want the Home page (Title page?) to be a blog page. I want it to be like a standard website Home page, with links to the other pages.

    Setup a home page
    http://codex.wordpress.org/Creating_a_Static_Front_Page

    I tried to upload a custom header, and again received this error message:

    "Unable to create directory uploads/2013/07. Is its parent directory writeable by the server?"

    I'm searching on Blue Host Helpdesk, have you tried this: WordPress Error: Unable to create directory??

    Again, I am not sure what choice to select. I am inclined to chose "Custom Structure http://zsoundz.net", but I really don't understand what this does. Does a choice here affect all "Pages"?

    Yes. You'll get your domain.com/about URL structure. However, if WordPress cannot write to the server, you'll have to manually upload an .htaccess to the Website root directory. Included in the link is the how-to if you need to upload the .htaccess file manually. For more info, go here:

    http://codex.wordpress.org/Using_Permalinks

    https://my.bluehost.com/cgi/help/htaccess

  7. CrouchingBruin
    Member
    Posted 1 year ago #

    Now I deleted the added page I called Home, but added several new "Static" pages.
    ...
    "From your Dashboard, go to Settings > Reading, and you hopefully have A static page selected. Then in the drop-down list, make sure you have a valid page selected."

    I am not sure what to do. The Title (?) Home (?) page does not appear in the drop down list.

    OK, if you have created several static pages, then they should all appear in the drop down list. And since you say you deleted the page called Home, then of course it's not going to show up in the list. You then pick one of the other pages to be your "home" page, or re-create a page called Home. It doesn't necessarily need to have the title of Home, but it might make it easier if it did have the title of Home. So to summarize, if you want a static page to be your home page, then you have to create (and Publish) it first, then select it using the drop-down list in the Settings > Reading section.

    Again, I am not sure what choice to select. I am inclined to chose "Custom Structure http://zsoundz.net", but I really don't understand what this does. Does a choice here affect all "Pages"?

    Yes, it affects the permalink (the address) of all pages. Which do you think looks better for a page address, this:
    http://zsoundz.net/?page_id=19
    or this:
    http://zsoundz.net/about-djsos
    As far as what to use for Custom Structure, you can see a list of structure tags here. For example, if you use /%postname% as part of the Custom Structure, then the post or page title will be part of the permalink.

  8. twriterext
    Member
    Posted 1 year ago #

    I found a helpful video (http://www.youtube.com/watch?v=sPR_I00comE) and set up a Home page approximately the way I want it. I deleted the other pages to try and simplify the additional set up.

    I still cannot upload a custom header, or, for that matter, a background.

    I tried changing Permalinks to Custom Structure, but the change will not save.

    This:

    I'm searching on Blue Host Helpdesk, have you tried this: WordPress Error: Unable to create directory??

    references Miscellaneous settings, but that setting does not exist (WP v. 3.5.1)

    I looked at http://codex.wordpress.org/Changing_File_Permissions, but it is not clear to me from that web page how to access the permissions, nor how to change them.

    I tried connecting to my WP website via ftp, using FireFTP, but so far I have not been able to connect.

    I viewed:

    https://my.bluehost.com/cgi/help/htaccess#Creating%20A%20.htaccess%20File

    but this isn't helpful because (I think) I can't get ftp access to zsoundz.net, plus it doesn't say anything about the content of an htaccess file.

    So . . . I am really stuck here, and could use any ideas you have.

    Thank you.

  9. twriterext
    Member
    Posted 1 year ago #

    OK, I finally managed to connect via ftp.

    Yes, there is an index.php file in the root directory, but no htaccess or .htaccess file. I don't know why.

    A search found this:

    /wp-content/plugins/akismet/.htaccess

    It looks like this:

    Order Deny,Allow
    Deny from all

    <FilesMatch "^akismet\.(css|js)$">
    Allow from all
    </FilesMatch>

    Which looks nothing like this(from http://codex.wordpress.org/Using_Permalinks):

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    But neither htaccess file seems to reference uploading anything, let alone images. But then, my knowledge of this type of code is virtually non-existent (which must be obvious to you).

    Can you recommend the next step?

    Thanks for your help.

  10. Jorge
    Member
    Posted 1 year ago #

    You can upload an htaccess.txt file with the permalink set up (ignore the akismet htaccess file) then rename it to ".htaccess" - with the dot at the beginning. You may get a warning about changing the file extention - for removing the .txt.

  11. twriterext
    Member
    Posted 1 year ago #

    Regarding this statement:

    "You can upload an htaccess.txt file with the permalink set up . . . ."

    Are you referring to Settings/Permalinks?

    All I see in this window is:

    Common Settings
    Optional (Category base/Tag base)

    I see no reference to htaccess, or for that matter, uploading any file.

    So, perhaps, once again, I have missed something very fundamental.

    Thank your for your help . . . and your patience

  12. twriterext
    Member
    Posted 12 months ago #

    I use Fire FTP (Firefox add-on), and under Tools/Options I enabled "Show hidden files"

    There is no .htaccess file in the root directory. There is no wp-content/uploads folder.

    There are these files in the /wp-admin folder:

    custom-background.php
    custom-header.php

    And these files in the /wp-admin/js folder:

    custom-background.js
    custom-header.js

    But when I right click on Properties for these files and try to change the permissions, I receive this error message:

    500 'SITE CHMOD 0600 custom-header.js': command not understood
    : /wp-admin/js/0600 custom-header.js

    (equivalent error message for other files)

    I just updated to Word Press v. 3.5.2 to see if, perhaps, the prior version did not properly install. No change, either in ability to upload images or find .htaccess file(s) (if, in fact, that's the problem).

    I don't know what the content of the .htaccess.txt file needs to be. Should I create a .htacces file with the content described in my earlier post and upload it using ftp?

Topic Closed

This topic has been closed to new replies.

About this Topic