WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Can't Upload Custom Header Image in TwentyTen (7 posts)

  1. billcanty
    Member
    Posted 3 years ago #

    Hi there,

    Sorry, I haven't searched anywhere for an answer to this - after spending about 5 hours on the Famous 5-Minute Install I'm getting REALLY tired of the massive struggle it takes to do ANYthing in WordPress. So, can someone please restore some of my faith by answering this question?

    I'm trying to upload a custom header image in TwentyTen. I made a 940 x 198 jpg so there'd be no cropping. Selected the file, pressed "Upload" and keep getting the message: Unable to create directory /home/www/billcant/wp/wp-content/uploads/2011/03. Is its parent directory writable by the server?

    Is there an easy way to fix this? (Please, be gentle...) Any tech specs you need to know first?

    Cheers, Bill

  2. Chip Bennett
    Theme Review Admin
    Posted 3 years ago #

    Have you checked your file permissions for the uploads directory? (The easiest way is usually via FTP.)

  3. billcanty
    Member
    Posted 3 years ago #

    Hi Chris, and thanks for your response.

    I'm far from being an expert on permissions, so I simply had a look at some of the directories on my site, including directories that I regularly upload to, and including "wp". They all have permissions of: rwxr-xr-x (755)

    So I made the appropriate folders manually, and now when I try to upload my custom header image I get: The uploaded file could not be moved to /home/www/billcant/wp/wp-content/uploads/2011/03

    Any other suggestions most gratefully accepted!

    Cheers, Bill

    PS: I just created the folders "uploads", "2011" and "03" manually, then uploaded the image via FTP. Is there a way to get WordPress to find it and use it?

  4. Chip Bennett
    Theme Review Admin
    Posted 3 years ago #

    WordPress will automatically create the Year and Month subdirectories in the Uploads directory, if it has write access. You shouldn't need to create them manually (and doing so doesn't help you, if WordPress, for whatever reason, does not have write access).

    Try setting \wp-content\uploads to "777". (It is safe to do so for this directory.)

    If that doesn't fix it, we've got some other problem; but at least we can rule this one out.

  5. billcanty
    Member
    Posted 3 years ago #

    Thanks Chip - that fixed it! :-)

    It's probably patently obvious that web design is *not* one of my areas of expertise, so thanks for not treating me like an idiot. Although, I WAS enough of an idiot to get your name wrong in my first reply. Sorry 'bout that!

    Cheers, Bill

  6. Chip Bennett
    Theme Review Admin
    Posted 3 years ago #

    No worries. :) Glad you got it fixed!

    (p.s. please mark this topic as "Resolved" to facilitate others finding a solution to similar issues.)

  7. emidesigns
    Member
    Posted 3 years ago #

    Chip Bennett you're the man

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.