WordPress.org

Ready to get started?Download WordPress

Forums

Can't upload 10mb audio file, php.ini set to 32mb (20 posts)

  1. steelerdirtfreak
    Member
    Posted 5 years ago #

    I can not seem to upload a 10 mb audio file. I keep getting this error message:

    This file is too big. Your php.ini upload_max_filesize is 32M.

    I've checked with my server tech support and they have assured me this is not a server problem as the php.ini file is definitely set to 32mb

    I also sent them a copy of the audio file and they verified that it is indeed a 10mb file, well within the upload limit.

    I have also tried two complete re-installs of 2.6 to make sure I have a complete and clean install.

    So why is my WP install unable to upload this file, and why is it display this incorrect error message?

  2. Anonymous
    Unregistered
    Posted 5 years ago #

    this site will let you upload a 10mb audio file and they'll give you an audio player you can embed http://www.entertonement.com

  3. umlzappy
    Member
    Posted 5 years ago #

    Have you looked at the post_max_size value? The uploaded didn't give an error message to this, but I noticed a pattern when I couldn't load relatively large (~21MB) files. The value was changed and it seemed to resolve the issue. Hope this helps!

  4. Katie B
    Member
    Posted 5 years ago #

    Hi,
    I'm having the same trouble but I changed my max size to 10M and I could get slightly larger files uploaded but not a file size of 8.5m. ? ?
    So then I changed it to 18M (Not really knowing what I'm doing but I figured I'd give it a shot - still getting the same error message of file too large.

    I'll try looking around for this post max size, thanks.

  5. @mercime
    Volunteer Moderator
    Posted 5 years ago #

    Trick would be to create an audio folder in root and FTP the audio file to the folder. Then call the file with URL http://example.com/audio/file.mp3 e.g.

  6. eric.schlange
    Member
    Posted 5 years ago #

    I'm having the same issue as the users above. I want to allow authors to upload large files (200 Megabytes +). First I increased the upload_max_filesize to 20M and the post_max_size to 20M in the php.ini file. This allowed me to upload file sizes up to 20M. I then increased both of these value to 1G. I attempt to upload a file about 47M in size and the flash uploader gives the error: "This file is too big. Your php.ini upload_max_filesize is 1G." I also attempted to change the .htaccess file at the root of WP but this did not help either. I can't seem to track the problem in the code either, the 'file_exceeds_size_limit' string associated with the error seems absent from the remainder of code.

  7. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    Both upload_max_filesize and post_max_size control how big a file you can upload. The smaller wins. WordPress doesn't tell you about post_max_size (it's a minor oversight that will be fixed eventually). So be sure to check them both.

    @eric.schlange: Make a new phpinfo.php file, inside it put this line:
    <?php phpinfo(); ?>
    Load it up in a browser. Look for the sizes there. When your hosting company allows local PHP.INI files like you're describing, then they may have also put limitations on it as well. In other words, they may have the post_max_size set lower in their own PHP.INI file, and that takes precedence over your local settings. The phpinfo.php trick will tell you what the settings actually are and where they are set.

  8. eric.schlange
    Member
    Posted 5 years ago #

    Thanks for the quick response Otto42! It looks as though the post_max_size = 1G in my php.ini file is being overwritten by their post_max_size = 8M. I'll have to figure out a different way around this problem.

  9. redhans
    Member
    Posted 5 years ago #

    I am also having the same problem. I tried the phpinfo file trick and found out...as expected, but not as hoped...that both the post_max_size and the upload_max_filesize are set to 50MB for both the Local Value and the Master Value. I'm trying to upload a 7MB mp3 file.

  10. madhousewife
    Member
    Posted 5 years ago #

    Re: audio plug-in, it finds the song OK, but does not show the plug-in; instead it directs me to a blank page with an audio bar.

    Here is the code that is in. Can someone tell me what is wrong? Thx

    name_of_song
  11. madhousewife
    Member
    Posted 5 years ago #

    Sorry, it is not putting code in. I am trying again....

    Re: audio plug-in, it finds the song OK, but does not show the plug-in; instead it directs me to a blank page with an audio bar.

    Here is the code that is in. Can someone tell me what is wrong? Thx

    madmentheme
  12. madhousewife
    Member
    Posted 5 years ago #

    This is ridiculous. How can I show you what the page says. I will try again:

    OK, basically, discounting the URL location of file, all that is before it is this:

    attachment wp-att-238

  13. dataplus
    Member
    Posted 5 years ago #

    Thank you Otto42 - I have been struggling with this for quite some time!

  14. amberrosie
    Member
    Posted 5 years ago #

    I am desperate here! I really need to upload some 8mb PDF files to my site ASAP and I keep getting this ridiculous error.

    I don't know how to make a .php file or how to change upload_max_filesize and post_max_size. I started using WordPress to try and avoid dealing with all that moonspeak.

    So can someone please tell me how to fix this issue in plain English?

    Thank you!

  15. wmassingham
    Member
    Posted 5 years ago #

    Only problem with uploading outside of WordPress (e.g. via FTP) is that it won't appear in your media library.

    Workaround: upload a small file with the same filename via WordPress (that's under post_max_size and upload_max_filesize), then access your server (e.g. via FTP) and swap out the real file for the small one.

  16. archangelgabriel
    Member
    Posted 5 years ago #

    I'm new to wordpress and I'm having the same problem, wanted to try changing the max_file value as Katie B mentioned, how do i do this?

  17. smokinjoe
    Member
    Posted 5 years ago #

    How about if both your UPLOAD and POST _MAX_SIZEs are set at 50MB and I still can't upload a 20MB audio file?

    I've used the flash uploader as well as the browser uploader and the browser uploader would respond that the operation had timed out, and the flash uploader I get an HTTP error.

    I'd use brute-force and just upload via an FTP program but my boss wants to be able to do it from the comfort of his own bed (so-to-speak) so anything outside of the wordpress UI won't work for me.

  18. WebTechGlobal
    Member
    Posted 4 years ago #

    I think this may work...

    define('WP_MEMORY_LIMIT', '64M');

    Putting that in wp-config.php is something I done before.

    Any further help on this I may write an article. Let me know if anyone else is stuck and contact me here http://www.webtechglobal.co.uk

  19. WebTechGlobal
    Member
    Posted 4 years ago #

    http://simplercomputing.net/2009/02/13/fix-php-max-upload-size-wordpress/

    Actually it might have been something more like this I done. Just to check it on WP 2.8 I tried changing and printing my new INI settings and it had no effect but this is the way to do it I reckon. Just don't know why it doesnt work in 2.8 and it did for me previously

  20. wm2008
    Member
    Posted 4 years ago #

    Hi,
    I also do have the same problem with version 2.33. {have not tried it with newer version as yet since I'm a getting a headache.}
    I've done all the three changes [max file size, etc. as well adding the line from 'webTechGlobal' as well as installing the above plugin, for good measure. But Nil so far, niet, nothing.
    {I am just thinking of a server reboot now...}
    What happens is the max is set to 50M and file size is about 8.5meg. It tries to do the uploading...progress bar and so on. But it just behaves as if the file is uploaded. But it does not appear in the Browse listing. It is not on the srver as well when checked manually. [obviously]

    Any help/advice would be greatly appreciated, as I do need to replicate a solution as per SmokinJoe since the boss is going to do the file-uploading from within the application itself.
    Thank you in advance.

Topic Closed

This topic has been closed to new replies.

About this Topic