WordPress.org

Ready to get started?Download WordPress

Forums

Can't update permalink structure (24 posts)

  1. Andreas Beer
    Member
    Posted 8 years ago #

    I used /index.php/%year%/%monthnum%/%day%/%postname%/ before I updated to 2.0. Having the brand new thing up and running I chanced on of the other permalink options. The result was a 403 on admin-panel and frontend. Only way to get back in is to upload a new empty .htaccess but the the permalinks are still set to the new option (%year%/%monthnum%/%day%/%postname%/). Any klick on a headline still leads to a 403.

    Any idea what the f*** is going on and how to stop that?

  2. Kahil
    Member
    Posted 8 years ago #

    i updated mine to 2.0 and it worked fine just like you had it...

    then all of sudden soemtime last night it didn't...

    then, just as suddenly they started to work again...

    you might try deleting your .htaccess file....wait a lil bit, then update...i've heard that helps...

    good luck...

  3. moshu
    Member
    Posted 8 years ago #

    sauerland,
    If you needed the "index.php" in the previous version it was because your host/server doesn't support mod_rewrite.
    If you are on the same host you'll need the "index.php" even for the new version.

  4. Mazalien
    Member
    Posted 8 years ago #

    Hi guys

    have a look at here....

  5. Andreas Beer
    Member
    Posted 8 years ago #

    I've deleted .htaccess for roughly 16 times now - or rather, I uploaded an empty .htaccess since I can't see that stupid file on my ftp-thing.

    Trouble is, the permalinks still work with index.php at the beginning only the links on the headlines do not feature that essential "index.php".

  6. Mazalien
    Member
    Posted 8 years ago #

    Sauerland I cannot acces your website so I think there is no .htaccess file present.

  7. Andreas Beer
    Member
    Posted 8 years ago #

    Everytime I try to revert to the /index.php/%year%/%monthnum%/%day%/%postname%/ -scheme the entire site disappears. It only shows up again, if I upload a new empty .htaccess. But then the permalink-issue is still unresolved. And I can't say whether there is a .htaccess even after I uploded it, since the ftp-thing doesn't show it.

    I think I go and bang my head on the wall for a while and return to ink and paper.

  8. Mazalien
    Member
    Posted 8 years ago #

    Sauerland, Ryan Boren send me this little plugin. It bypasses the pemalinkhandeling by wordpress and stores the permalinks directly into .htaccess.
    http://www.mazalien.nl/blog/rewrite.txt

    save it as rewrite.php and activate it as a plugin. It worked for me.
    Untill there is no solution you might want to used it.

  9. Andreas Beer
    Member
    Posted 8 years ago #

    Thanks Mazalien, but that doesn't solve anything.

    Every time I upload a new empty .htaccess, the front page reappears. But all permalinks are set to the option /%year%/%monthnum%/%day%/%postname%/ - and they always result in an error 403.

    When I change the permalinks to /index.php/%year%/%monthnum%/%day%/%postname%/ the entire site including the admin-panel disappears in a 403 and stays there until I upload a new empty .htaccess.

    And then everything starts from the beginning.

    The .htaccess-file disappears as soon as it is uploaded. What ever software I use - it stays hidden or deleted or whatever.

    The really frustrating thing is: Everything worked fine until I gave the other permalink option a try after updating to version 2.0.

  10. Mazalien
    Member
    Posted 8 years ago #

    Sauerland, then you might want to have look at this reply from Ryan Boren :
    http://wordpress.org/support/topic/53273#post-291783
    And I quote:
    "Plugins that used the mod_rewrite_rules filter need to use the generate_rewrite_rules action instead. generate_rewrite_rules has been the preferred method for some time, but Codex was still referencing mod_rewrite_rules."
    Perhaps you shold deactivate your plugins one by one. Its a lot of work. I know.... :)-

    Or assist Ryan As he suggested over here about the same problem :
    http://wordpress.org/support/topic/53244#post-291884

  11. Andreas Beer
    Member
    Posted 8 years ago #

    I really appreciate your help, Mazalien. But now the entire thing is dead. Even the trick with the new .htaccess doesn't work anymore. Perhaps my provider went berserk with the server.

  12. Andreas Beer
    Member
    Posted 8 years ago #

    Would it help if I just reinstalled version 1.5.2?

  13. Mazalien
    Member
    Posted 8 years ago #

    Well I did the same thing to test it out. Then the permalinks
    are working correctly. What I also did was that I set up a complete new blog in a seperate database with a fresh out of the box install of wp 2.0. with some dummy posts an pages. And even then the permalinks don't work. If you wander around through this forum than you will notice that a lot of people have the same kind of problem. Ryan Boren said in a mail to me that he want to investigate the problem. So perhaps you should wait a while with your upgrade untill there is a solution. For me rewrite.php works. So I leave the install of 2.0 for a while as it is utill Ryan comes with a solution.

  14. Andreas Beer
    Member
    Posted 8 years ago #

    Found it ! Deactivated the plugin "german-permalinks" and everything is fine again.

  15. Mazalien
    Member
    Posted 8 years ago #

    So it is a plugin afterall that causes the trouble... those damned things.

  16. Andreas Beer
    Member
    Posted 8 years ago #

    Autometa version 0.4b is from the empire of evil as well.

  17. DavidMeade
    Member
    Posted 8 years ago #

    I dunno, I have a fresh install of 2.0 and the permalink/category-based-url thing isn't working ... and I have no plugins activated.

    I have WP2.0 installed to /blog/
    When I have the category based url set to 'tags' such that a link should be http://www.myserver.com/blog/tags/category .... only categories that do not contain the string 'blog' seem to work ... all others get a 404.

    Also the .htaccess file never changes ... some blank lines get appended when ever wordpress would likely be altering it, but the file remains always with just:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php
    </IfModule>

    # END WordPress

    ???

  18. greatbananas
    Member
    Posted 8 years ago #

    I have a very similar problem. It does not work with custom: /%post_id%/%postname%/ . All the other options work fine. I upgraded it to 2.0 from 1.5.2. I have no plugins activated.

  19. FofR
    Member
    Posted 8 years ago #

    I had mine working but I have just recently changed the URL of the site (no files have changed, just a new domain points at the file and I changed the URL of the main blog) but now the permalinks refuse to work. Im not using any plugins.

    See:
    http://indiecult.trivialbeing.net/2005/12/29/venetian-snares/
    http://www.indiecult.com/2005/12/29/venetian-snares/

    Indiecult.com points to the indiecult.trivialbeing.net subdomain and they share apache.

  20. moshu
    Member
    Posted 8 years ago #

    It never works with this kind of redirects.

  21. FofR
    Member
    Posted 8 years ago #

    Care to offer an explanation as to why? The two domains equally share the same hosting/database. And all the admin stuff functions correctly from the domain.

  22. moshu
    Member
    Posted 8 years ago #

    I am afraid I cannot give you the proper technical explanation... since I don't know it :)
    However, based on the experience of months spent here - I remember many cases like yours when the permalinks didn't work.
    I guess the "virtual path" of the permalinks are built based on the physical location of the WP install, though don't quote me on this.

  23. FofR
    Member
    Posted 8 years ago #

    I managed to get it to work by circumventing the mod_rewrite

  24. creditlovers
    Member
    Posted 8 years ago #

    I contacted my hosting provider and they solved the problem for me. My WP was installd in a subdomain. Here is an excerpt of the conversation that i had with the CSR.

    Dave: In order for .htaccess files to be parsed in the subdomain, AllowOverride <option> has to be set in your apache configuration for that directory:
    Dave: <VirtualHost *>
    Dave: ServerName subdomain.example.com
    Dave: ServerAlias http://www.subdomain.example.com
    Dave: DocumentRoot /var/www/subdomain.example.com
    Dave: <Directory "/var/www/subdomain.example.com">
    Dave: Options FollowSymLinks MultiViews Includes ExecCGI
    Dave: AllowOverride All
    Dave: AddHandler cgi-script .cgi .pl .py .sh
    Dave: </Directory>
    Dave: . I have added it for you and restarted apache.

    My real domain isn't example.com btw, it's just a sample. Hope this helps.

    jonathan.radande.com

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags