WordPress.org

Ready to get started?Download WordPress

Forums

Can't turn off visual rich editor (5 posts)

  1. herzogbr
    Member
    Posted 7 years ago #

    I'm having trouble turning off the visual rich editor (which I'm taking to mean the wysiwyg editor). I've unchecked the "Users should use the visual rich editor by default" box under Options > Writing in my Admin account, as well in the use account. When I log in as Admin, I see the normal, non-wysiwyg editor, but all other users see the wysiwyg editor. How can I get the users to use the non-wysiwyg editor? Thanks.

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    That setting is a per-user thing. If they don't want to see it, tell them to turn it off for them.

  3. herzogbr
    Member
    Posted 7 years ago #

    I thought it was, but I feel like I'm missing something. I am un-checking the box at the user-level, but it is not going away. Is there another checkbox somehere, other than the Options > Writing one and the one at the bottom of the Users page?

  4. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    No, I think you misunderstand. It's a Per-User setting. Meaning each and every user can turn it on or off for themselves and not affect anybody else. If you turn it off while you're the admin user, then it's off only for the admin user. If you are logged in as "Bob", then turn it off, then it's off for "Bob" and only for "Bob". That won't affect the same setting for "Carl" or "David". They can set it how they please.

  5. herzogbr
    Member
    Posted 7 years ago #

    Thanks for your help. I did understand what you meant, it just wasn't working. I unchecked the box as Admin, and then went into each user account and also unchecked the boxes. But, the visual rich editor was still appearing.

    Later in the day I thought maybe it had to do with caching or cookies or who knows what, so I rebooted and tried it again - and this time it worked perfectly. I don't know why the settings weren't taking effect the first time around, but it certainly accounts for my frustration. Thanks again for your help - sometimes you just need to hear than what you're doing is correct, just so you try something else. Take care.

Topic Closed

This topic has been closed to new replies.

About this Topic