WordPress.org

Ready to get started?Download WordPress

Forums

Can't turn off moderation of comments (24 posts)

  1. dherren
    Member
    Posted 9 years ago #

    Even though I have unchecked An administrator must approve the comment (regardless of any matches below), all comments seem to go into the moderation queue--including my own as admin.
    I've tried toggling the setting on and off to no avail.

  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Try putting a single word into the spam moderation box, and see if that helps ?
    Could you post back the result please ?

  3. dherren
    Member
    Posted 9 years ago #

    This particular blog is for my high school students in spanish, and I had already put a list of 12 obscenities in the list before my initial question. Shall I try removing my list instead?

  4. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Make sure there is not a blank line in there, usually at the bottom. That could cause this too.

  5. dherren
    Member
    Posted 9 years ago #

    That appears to have been the problem. Deleting the last line fixed it. Thanks!

  6. loid
    Member
    Posted 9 years ago #

    Hi folks, I'm having the same problem as dherren, and I too had a blank last line at the bottom. However, having deleted it, I still cannot get comment moderation to turn off.
    I'm running WP 1.2.1. This has been going on for some time, both before and since I installed Blacklist (2.6.1). I have tried it with even the box unchecked for requiring a name and email. No joy.
    I've searched the forums and the web and seen a couple others with the same problem, but so far I haven't found a solution.
    Any help would be greatly appreciated.
    Loid

  7. Tek
    Member
    Posted 9 years ago #

    Seems like I am not the only one. =(

  8. Anonymous
    Unregistered
    Posted 9 years ago #

    same problem here

  9. loid
    Member
    Posted 9 years ago #

    I guess I'll have to assume this is a known WP bug. If any work-around exists that any of you know of, please post it in a reply. I'd be extremely grateful.
    IMO it's a pretty serious issue because moderating comments drives away would-be participants in a blog.
    Thanks for any help and ideas.
    Loid

  10. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Are you absolutely certain you have checked your spam words list ?
    http://wordpress.org/support/3/16168

  11. loid
    Member
    Posted 9 years ago #

    Yes, I've checked it numerous times. The first time there *was* a blank line at the end. I removed it, but comment moderation remained on. I have since removed all words but one on the list and made sure there are no blanks. Comment moderation still is stuck.
    I've seen posts from a few others in the same boat, which leads me to conclude there's a bug at play.

  12. Paolo
    Member
    Posted 9 years ago #

    I am having the same issue. I also found a blank space in the keyword area, yet having deleted it caused no visible effect. I'm still getting tons of notifications.

    The irony is, that as of yesterday I've implemented a new plug-in that stops comment spam completely. It requires users to match icons before submitting a comment. While no spam gets through, I'm still being notified. Furthermore, nothing ever ends up in the queue because nothing gets past the spam block. [sigh]

    The bottom line is, I just want that when I leave the box for notifications unchecked that I don't get notifications. Essentially, I've stopped spammers but I'm being spammed by my own blog. Ugh!

  13. eetdcob
    Member
    Posted 9 years ago #

    Same issue here. Using WordPress 1.2.2 on OSX (server version, 10.3.7), PHP 4.3.2.
    I liked the ease of installation very very much.
    I wish there were more systematic documentation.
    Have checked "allow to post" and unchecked comment moderation, but postings still do not appear on the blog, and only by logging in as Admin and going to the Edit tab do I see the postings waiting for approval.
    My spam word list has no blank lines.

  14. Does your blacklist have any / characters of single letters?

  15. gmosesx
    Member
    Posted 9 years ago #

    same problem with my site: "usual settings" and "email me whenever" options unchecked with some "poker" related comment moderation words, with no blank lines or single characters, and an inbox where I receive spam from myself!

  16. gmosesx
    Member
    Posted 9 years ago #

    deleted my email address from the "General Options" page. crude tactic, but it seems to be working.

  17. Paolo
    Member
    Posted 9 years ago #

    I'm tempted to do the same as you, gmosesx. But unfortunately, now comments ARE being stuck in the comment moderation queue and I have to aprove them. And AGAIN, I haven't checked off that feature. It shouldn't be happening.

    For the record, I'm running WP 1.2.1. I'm tempted to upgrade to 1.2.2 but with another release around the corner, I'm not sure how worth it that would be or if there would be any change to my problem.

  18. eetdcob
    Member
    Posted 9 years ago #

    "Does your blacklist have any / characters of single letters?"

    I'm not sure I understand this, but there are no "/" in the list, or single-letter items. It's the built-in list plus words I added. It's not a plug-in, if I understand the distinction. It came with WP.

    I don't remember if I had this comment moderation problem before I started using the blacklist. I wonder if the blacklist is the issue. I will just have to study the scripts.

    I'm really doing this for my boss. He's the one who will have to approve posts, which I think he will get tired of fast, although he will want to be able to edit or delete them after the fact. Does anyone know what level of user I should make him, to be able to publish and immediately see his posts, and to have edit/delete power over others? I don't want to give him admin level.

  19. eetdcob
    Member
    Posted 9 years ago #

    p.s. to above, yes I am reading the docs - they are sketchy though.

  20. bestfoot
    Member
    Posted 9 years ago #

    Same issue on our site. We are using the method that presents an image of a random code and they have to enter it into a form field to post to avoid spam. I don't know if something about that could be causeing the problem. But others are using different methods. I suspect it is a WP bug myself. This is annoying so it would be nice to find the solution.

  21. eetdcob
    Member
    Posted 9 years ago #

    I installed WP on a separate Mac, this time with no spam words, at the suggestion of someone posting on a different topic here.

    Same result: comment moderation is toggled off, and set it up so anyone could post but comments go into the moderation queue. I enabled any registered user to post without moderation, registered myself as a separate user, same result.

    WordPress Wizards, I'm sure that in many organizational setups, the head blogger will want to pre-approve certain co-bloggers to post without moderation. So this is an issue worth addressing.

  22. beernuts
    Member
    Posted 9 years ago #

    As I was having the same problem, I did a little poking around. I started with the forum suggestions - I added a single word to my spamwords. No joy. I removed them entirely (ensuring there wasn't a blank link. No joy. So, I started to look in the code. In wp-comments-post.php, where check_comment is called:


    if(check_comment($author, $email, $url, $comment, $user_ip)){
    $approved = 1;
    } else {
    $approved = 0;
    }

    $approved is always '0'. So, I started adding 'die(__("Test"));' after each of the checks in the check_comment function to see what was going on. What I've found is that:


    if ( (count(explode('http:', $comment)) - 1) >= get_settings('comment_max_lin
    ks') )

    always returned false. I've edited this parameter in the interface before(Options->Discussion->Comment Moderation->"Hold a comment.."), most recently to set it to nothing when I thought I had authImage working. I set it to a non-null value (3), and everything is working as expected. Hopefully this will help someone else.

  23. NTheory
    Member
    Posted 9 years ago #

    Also if you dont care who posts, or what they post and you want anything and everything to post, you can also go into and edit wp-comments-post.php goto line that reads:

    if(check_comment($author, $email, $url, $comment, $user_ip)){
    $approved = 1;
    } else {
    $approved = 0;
    }

    and change the 0 to 1

    This will essentially deny the program the disapproved option. The site will approve it or approve it. Go figure.

  24. drienne
    Member
    Posted 8 years ago #

    Hello - This post was started a long time ago, but I'm a new WordPress (1.5) user and I hope my suggestion will help someone.
    Under Options --> Discussion, I have:
    [ ]Admin must approve comment
    [x]Name and email required
    [ ]Only previous commenters allowed

    I have no words or spaces, returns, or anything of the like in my Moderation text block and none in my blacklist box either. I have also tried adding words to either or both of these boxes, and it does not make a difference. All of my comments are still held for moderation. I tried removing my email address so that I would not be emailed. That did not make a difference either.

    My wp-comments-post.php did not have the check_comment function, oddly, so I couldn't modify that.

    WHAT WORKED: I changed the "Hold a comment in the queue if it contains more than __ links". The default was 2 links. After troubleshooting for a week, I realized that the poster's name is linked, and so is the date posted, and so is the "edit" link. Whether this is valid logic or not, I don't know, but once I changed that setting from 2 to 6, I stopped having this problem with turning off moderation.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.