WordPress.org

Ready to get started?Download WordPress

Forums

WP Accessibility
[resolved] Can't turn off longdesc img attribute (3 posts)

  1. Ok Really
    Member
    Posted 3 months ago #

    Excellent plugin!
    But just one thing I don't understand ...

    Whenever I add an image now, it always has a longdesc attribute and return anchor, like this ..

    <img class="alignright size-full wp-image-100" alt=""
    src="http://[MY-DOMAIN]/wp-content/uploads/2014/04/[IMAGE-NAME].jpg"
    width="160" height="160"
    longdesc="http://[MY-DOMAIN]?longdesc=100&referrer=113" />
    <a id="longdesc-return-100"></a>

    I cannot see how to turn off this unwanted behaviour.

    Most of my images are small and purely ornamental. None of them have title, alt text, description or caption — because they are not needed.

    I'm grateful for the opportunity to add an appropriate longdesc, but right now all images have a link to an empty description, unless I edit the image tag manually.

    Have I done something wrong? Have I missed an obvious instruction (very possible - my vision is deteriorating week by week).

    Cheers :-)

    https://wordpress.org/plugins/wp-accessibility/

  2. Joe Dolson
    Member
    Plugin Author

    Posted 3 months ago #

    I'll check this out. There shouldn't be a longdesc attribute if there isn't a description provided.

  3. Joe Dolson
    Member
    Plugin Author

    Posted 3 months ago #

    Bug confirmed and fixed; I'll update a fix shortly.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.