WordPress.org

Ready to get started?Download WordPress

Forums

Can't switch to visual after 3.8 update (7 posts)

  1. Lee Nomedal
    Member
    Posted 4 months ago #

    Looks like several people are having this problem.

    When I go to edit (or create) a new page, I cannot use the visual editor - I have to use the text version. Visual editor does not produce a window that you can type into - just a blank area where the box should be.

    I have reuploaded the WP Includes folder, and also tried reinstalling the update via the Updates tab in the admin window. Saw some suggestions about disabling plugins - going to try that next, but just checking to see if anyone has actually found what is broken in the update to cause this problem on some sites.

    My question is, is it possible to downgrade back to a version of wordpress that works, without destroying the site?

  2. esmi
    Theme Diva & Forum Moderator
    Posted 4 months ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading all files & folders - except the wp-content folder and wp-config.php & root .htaccess files - from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

  3. Lee Nomedal
    Member
    Posted 4 months ago #

    Ok, found the problem. . . IFrame Shortcode Plugin is the culprit... Luckily I only had a couple of plugins installed.

    Turned them back on one at a time and that was the baddie... the two that I have are:

    Responsive Contract Form
    and IFrame Shortcode

    The editor was worling with Responsive Contract Form - but breaks if I use IFrame Shortcode...

    Thanks for the response.

  4. Lee Nomedal
    Member
    Posted 4 months ago #

    Saw there are two versions by the same name.. it is IFrame Shortcode by Flyn San... that is broken.

  5. marcreck
    Member
    Posted 3 months ago #

    Just solved this thanks to a tip from inmotion hosting support (after trying the other suggestions id read of disabling all plugins, reinstalling wordpress manually and changing to a different theme)

    Go to users >> profile, disable the visual editor, click save, then re-enable and click save again. Worked for all of my 5 sites. \o/

  6. marcreck
    Member
    Posted 3 months ago #

    Actually scrub that - still not working :(

  7. JustCreative
    Member
    Posted 3 weeks ago #

    I had the same problem with 3.8.1 version. I simply re-installed the WordPress via dashboard (not manually!!!!) and after that I was able to switch to the visual mode.

    Before, I reinstalled manually but the problem remain.

Reply

You must log in to post.

About this Topic

Tags