WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Can't show full content in the RSS feed (24 posts)

  1. Martyn Chamberlin
    Member
    Posted 2 years ago #

    I'm embarrassed because I'm pretty knowledgable in WordPress and I still can't get this figured out.

    The site is http://devinchughes.com/ and http://devinchughes.com/feed/rss/ is showing excerpts. I want the full content.

    Once I get this working, http://feeds.feedburner.com/devinchughes should show full content too.

    In Reading Settings I've specified full content and not excerpts and it's still not working.

    I'm using WordPress 3.2.1 and the Twenty Eleven theme, version 1.2.

    What's going on? Why won't it work?

  2. Harry
    Member
    Posted 2 years ago #

    The idea of RSS is to only show snippets, and link back to the original content.

  3. Martyn Chamberlin
    Member
    Posted 2 years ago #

    The fact that WordPress gives the option to show either excerpts or full content means it should work.

    You're not being very helpful. :)

  4. Harry
    Member
    Posted 2 years ago #

    Ah yes, the smiley face, that does nothing to offset the rudeness of that comment. I am volunteering my time trying to help you, in fact I give up quite a lot of time trying to help people, I ask for nothing in return but not being deemed unhelpful for my efforts. As WordPress gives the option, I'm not sure your interpretation of the option matches what it's doing in the background.

    However, being the helpful person I am, on looking more closely at your problem, you have indeed specified Full Content in the Feed. The RSS Feed and Feed are not necessarily the same thing. WordPress generates at least 4 URLs for its feeds (see link at very bottom for an explanation of what these do).

    http://devinchughes.com/feed/ - shows your description + content

    http://devinchughes.com/feed/rss/ - shows just your description

    Other than that you could possibly modify the core files are generating the feeds.

    Here's a few helpful links:
    http://codex.wordpress.org/WordPress_Feeds
    http://en.wikipedia.org/wiki/RSS#Example

  5. Martyn Chamberlin
    Member
    Posted 2 years ago #

    Let me get this straight.

    Are you saying my RSS is functioning as it should?

  6. Curtiss Grymala
    Member
    Posted 2 years ago #

    Martyn - More than likely, there is something in your theme that is overriding your RSS settings.

    Yes, full content in RSS feeds is perfectly acceptable and fully supported in WordPress. It should work; and if it isn't, that means something is stopping it from working.

    Can you try switching to the Twenty Eleven default theme to see if that fixes the issue? If it doesn't, then try disabling all of your plugins to see if that fixes the issue.

  7. Martyn Chamberlin
    Member
    Posted 2 years ago #

    Thanks for the tip, Curtiss.

    I actually switched to the Twenty Eleven default theme for a while (yesterday evening till this morning) without success, but I just now reverted to Twenty Eleven and deactivated all the plugins.

    How long should it take for the changes to apply to the RSS?

  8. Harry
    Member
    Posted 2 years ago #

    I think the RSS is generated on the fly. But generally themes don't affect their output.

    I believe that the RSS is being generated correctly. If you use the normal feed, Feedburner can incorporate the full content. That should work for you.

    On the WordPress Feeds link I posted above, there is a link about WordPress and Feeburner.

    http://codex.wordpress.org/Using_FeedBurner
    http://www.google.com/support/feedburner/bin/answer.py?answer=78483
    http://www.wpbeginner.com/beginners-guide/step-by-step-guide-to-setup-feedburner-for-wordpress/

    Hope it works out for you.

  9. Martyn Chamberlin
    Member
    Posted 2 years ago #

    Thanks for the links.

    When you say, "I believe that the RSS is being generated correctly," I'm a bit perplexed. If you subscribe to devinchughes.com in a reader, it only shows an excerpt. I don't think it's a Feedburner issue at all. I think it's closer to home than that. I've specified for WordPress to show the full feed, but it's not doing it.

    For example, over at http://www.medicalmarcom.com/feed/, you can see the full content. You can't see it at http://devinchughes.com/feed/.

    What's going on?

  10. Harry
    Member
    Posted 2 years ago #

    Do you have any feed related plugins?

    I have a vanilla installation of WordPress, albeit 3.1 and I updated my feed settings in the admin and it seemed to work fine.

    Are you using 3.2.1?

    The two feeds were different.

  11. Martyn Chamberlin
    Member
    Posted 2 years ago #

    Yes, I'm using 3.2.1. What are the implications?

  12. Harry
    Member
    Posted 2 years ago #

    I upgraded to 3.2.1.

    In /wp-includes/feed-rss.php, this file generates your RSS feed.

    You'll see the loop uses the_excerpt_rss(). So the Full Content setting it would appear will have no bearing on the RSS feed output. This should be made clearer, as I've never really delved deeper into what the code does before.

    I'm sure there are plugins that change this default functionality, which I'm thinking that sample link you previously passed on might be using, or perhaps they've modified the below code to output the content instead.

    <?php while (have_posts()) : the_post(); ?>
    	<item>
    		<title><?php the_title_rss() ?></title>
    		<description><![CDATA[<?php the_excerpt_rss() ?>]]></description>
    		<link><?php the_permalink_rss() ?></link>
    		<?php do_action('rss_item'); ?>
    	</item>
    <?php endwhile; ?>

    In the above code I changed:

    the_excerpt_rss()

    to:

    the_content_rss()

    A bit of refreshing later, it finally did show the changes. Check this link regarding the_content_rss function, as it warns the function has be deprecated, so in future upgrades if you rely on this it may be removed.

    Hope this finally fixes your problem *fingers crossed*

  13. Martyn Chamberlin
    Member
    Posted 2 years ago #

    Actually, I'm in charge of the medicalmarcom.com site as well. I can testify personally that we've not edited the WordPress feeds or used any plugins to show a full feed.

    I changed my feed-rss.php to "the_content_rss()" and it's still not working. ;(

  14. Harry
    Member
    Posted 2 years ago #

    I suppose the point I tried to make before is, that the following two links are different. Therefore the WordPress setting you're expecting to have take effect isn't in fact actually working on your other site.

    1. http://www.medicalmarcom.com/feed/rss/
    2. http://www.medicalmarcom.com/feed/

    Even on Medical Marcom the RSS (#1) only shows snippets, which is correct. #2 however shows what you'd like to achieve.

    I can't get a look at your raw XML as it keeps redirecting me to Feedburner to see if there are any discrepancies. If you could switch off the Feedburner redirect to see if I can see the difference? As Feedburner may actually just be truncating the output for it's display. The XML might actually be the way you want it.

    Let me know if you can disable it temporarily. Because it may just be taking the RSS feed, and not your WordPress Raw Feed, which is what you'd ideally want.

  15. Martyn Chamberlin
    Member
    Posted 2 years ago #

    Never mind dude! I got it working.

    My best guess is that our WordPress files were somehow corrupted. I did a clean re-upload of WordPress 3.2.1 and everything's working now. The feed's showing the full content. http://feeds.feedburner.com/devinchughes

    Thanks for your help - truly appreciate it!

  16. Harry
    Member
    Posted 2 years ago #

    Could you at least mark this as resolved in the subject line.

  17. Martyn Chamberlin
    Member
    Posted 2 years ago #

    I certainly will, if you tell me how to do it. :)

  18. Harry
    Member
    Posted 2 years ago #

    Under the right sidebar entitled 'About this Topic', there show be a drop down with the status of this thread.

    Change it to resolved. Then click the change, and voila. Resolved.

  19. Martyn Chamberlin
    Member
    Posted 2 years ago #

    Lol. Looks like you've already done that ...

  20. Harry
    Member
    Posted 2 years ago #

    Nope, I don't have sufficient rights to modify that, only mods and the creator of the thread do. So thank you mod!

  21. Martyn Chamberlin
    Member
    Posted 2 years ago #

    That's funny, because it says [resolved] above. I guess a moderator did it for us? Spooky.

  22. esmi
    Forum Moderator
    Posted 2 years ago #

    Us mods can be pretty helpful sometimes. ;-)

  23. Harry
    Member
    Posted 2 years ago #

    In Mod We Trust :)

  24. esmi
    Forum Moderator
    Posted 2 years ago #

    Oh - I like that one! :-)

Topic Closed

This topic has been closed to new replies.

About this Topic