WordPress.org

Ready to get started?Download WordPress

Forums

Whispy
[resolved] Cant show 3 columns (7 posts)

  1. felixzacat
    Member
    Posted 1 year ago #

    I cant get the 3 columns to work. I want to show widgets on the left side too. I drag a few widgets in the the "Primary Left Widget Area", and select "Whispy Options : 3 columns for Post Layout and Post Index page layout". But doing those two things doesnt seem to work.

    Is there anything else that needs to be done?

  2. clashmedia
    Member
    Theme Author

    Posted 1 year ago #

    Are you running the latest version of Whispy? Go here and download it if you aren't. http://wordpress.org/extend/themes/whispy

  3. felixzacat
    Member
    Posted 1 year ago #

    yes i have the latest version.

    It seems to work on 3 colums for post layout. But it never works 3 columns for Index page layout, which is exactly the way i want it. I need to have 3 for index, but 2 for post.

    thanks in advance :)
    website: blue-walrus.com

  4. RoordaTim
    Member
    Posted 1 year ago #

    I just downloaded the latest version of the Whispy theme and I can confirm this problem.

    Here is the solution (for the homepage only!).
    in the directory wp-content/themes/whispy, find and open the file page.php. Add the following code directly after the php opening tag '<?php':

    $whispyOptions = get_option('whispy_theme_settings' );
    
    if( $whispyOptions['colspost-index'] == '3' && is_front_page() ) get_template_part( 'threecolumn-page' );
    
    else
    {

    Now, in the same file, add directly after the php closing tag '?>' the following code:

    }

    Safe the file and your homepage should show 3 columns when this is set in the theme options. Cheers!

  5. clashmedia
    Member
    Theme Author

    Posted 1 year ago #

    Hi Guys,

    Sorry we had fixed this but the latest version took a while to be pushed live to the repository. It has been pushed now and can be found here http://wordpress.org/extend/themes/whispy. Download it and should be fixed.

    Roorda Tim thanks for helping out, we actually used pretty much the same code ourselves.

    Cheers

  6. clashmedia
    Member
    Theme Author

    Posted 1 year ago #

    ok everyone has gone quiet closing this thread.. Open another if you still have problems.

  7. felixzacat
    Member
    Posted 1 year ago #

    Thanks RoordaTim and Clashmedia for the fix!

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags