WordPress.org

Ready to get started?Download WordPress

Forums

Postie
Can't select IMAP SSL in Postie (13 posts)

  1. astima
    Member
    Posted 11 months ago #

    I have PHP – IMAP installed on my server, but I cannot select IMAP SSL in postie. I have tried installing and reinstalling the plug-in. Any other suggestions on how to get it to appear in the pulldown menu?

    http://wordpress.org/plugins/postie/

  2. Wayne Allen
    Member
    Plugin Author

    Posted 11 months ago #

    Postie checks to see if the functions imap_open, imap_delete, imap_expunge, imap_body and imap_fetchheader are defined. If not it will not let you choose the IMAP SSL option.
    You can use a plugin like http://wordpress.org/plugins/wordpress-php-info/ to verify that IMAP is installed and PHP can see it.

  3. astima
    Member
    Posted 11 months ago #

    Under protocols I see IMAP listed. I assume that means it's installed. How do I know if those functions are defined?

  4. Wayne Allen
    Member
    Plugin Author

    Posted 11 months ago #

    I think you are seeing the protocols supported by curl. There should be a separate "imap" section.

  5. astima
    Member
    Posted 11 months ago #

    I am not seeing a separate IMAP section. I guess that means it is not installed. I host my email and my website using two different services, do I contact the service for the website or for the email?

  6. Wayne Allen
    Member
    Plugin Author

    Posted 11 months ago #

    Your website hosting provider needs to enable the PHP imap module.

  7. astima
    Member
    Posted 10 months ago #

    Okay, I've gotten my website hosting provider to enable PHP IMAP and I am able to select it, but now I am getting a warning message when it is trying to login.

    Warning: imap_open(): Couldn't open stream {mail.lknife.com:993/service=imap/ssl/tls/novalidate-cert} in /home/hbco/pos/wp-content/plugins/postie/postieIMAP.php on line 89

    I have double checked the username and password, I've contacted both my web hosting provider and my email provider to make sure that everything is installed properly. Any thoughts on how to fix this?

  8. Wayne Allen
    Member
    Plugin Author

    Posted 10 months ago #

    What are the other mail server settings?

  9. astima
    Member
    Posted 10 months ago #

    Mail Protocol: IMAP-SSL
    TLS: Yes
    Port: 993

    The email is microsoft outlook web app.

  10. Wayne Allen
    Member
    Plugin Author

    Posted 10 months ago #

    Try TLS "no"

  11. astima
    Member
    Posted 10 months ago #

    I still get the same warning message. Someone had suggested "If you have a smart phone or something you can do a test by setting it up via IMAP protocol, that way you can rule out the plugin being the cause. Just a thought.
    " But I have no idea what that means. Or if I should try it.

    I tried all different combinations of the email protocol, TLS and port. No luck.

    Any other thoughts?

  12. astima
    Member
    Posted 10 months ago #

    I would appreciate any help I could get.

  13. Wayne Allen
    Member
    Plugin Author

    Posted 10 months ago #

    Send me a note at postie-help@devzing.com I will need to look at your install.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags