WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Can't seem to get unwanted space removed (6 posts)

  1. Colby Ross
    Member
    Posted 2 years ago #

    So I got the plugin, Special Recent Posts:
    http://wordpress.org/extend/plugins/special-recent-posts/

    I've been playing around with this plugin a bit, and I'm having a bit of difficulty removing unwanted space between the title and the date.

    After lots of work, I'm quite certain that this plugin has nothing to do with the extra space between the title and the date.

    You can see this unwanted space on my website in the sidebar:
    http://www.ios-source.com

    What I want is for it to look like the example below's recent posts sidebar:
    http://www.redmondpie.com

    Their recent posts sidebar has barely any space between each line, I want mine to be like that. So if anybody could tell me what needs to be done, that would be great.

    Thank you!

  2. peredur
    Member
    Posted 2 years ago #

    This is the rule that's creating the margin (that's creating the gap):

    h1, h2, h3, h4, h5, h6 {
      margin: 25px 0 15px;
    }

    Try creating a rule for:

    div.srp-widget-singlepost {
      margin: /* your values here */;
    }

    ... playing with the values until you get something that works for you.

    Of course you should be aware that the only recommended way of making changes to themes is via a child theme.

    HTH

    PAE

  3. Colby Ross
    Member
    Posted 2 years ago #

    This is the rule that I created:

    div.srp-widget-singlepost {
    	padding       : 0px 0px 0px 0px;
    	margin        : -20px -3px -7px -4px;
    	border-bottom : 2px dashed #CCCCCC;
    }

    The margins would be much larger if I hadn't changed these margins in the settings.
    But what these margins don't change is the one line space between the title and the date.

  4. peredur
    Member
    Posted 2 years ago #

    h4.srp-widget-title {
      margin-bottom: 0;
    }

    Works for me.

    Cheers

    PAE

  5. Colby Ross
    Member
    Posted 2 years ago #

    Worked for me too.

    Thanks a lot!

  6. kelemvor
    Member
    Posted 1 year ago #

    Even though mine is in the widget on the side of the screen, I had to use:

    h4.srp-post-title {
    margin-bottom: 0;
    margin-top: 0;
    }

Topic Closed

This topic has been closed to new replies.

About this Topic