WordPress.org

Ready to get started?Download WordPress

Forums

  1. Shr.Khr
    Member
    Posted 1 year ago #

    Hi
    First of all thanks for sharing your work.

    Now, I am having a problem.
    When I type http://www.mywebsite.com?drawHeatMap=true and hit enter, my site URL becomes http://www.mywebsite.com/?drawHeatMap=true and I don't see the heatmap.
    Any idea why this is happening?

    My site URL is: http://www.shahriarnk.com

    I believe my theme supports HTML5 because below is what I see in 'page source':
    <!DOCTYPE html>
    ...

    http://wordpress.org/extend/plugins/hotspots/

  2. dpowney
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Shahriar,

    Thanks for finding an issue. I will take a look and get back to you shortly.

    Daniel.

  3. dpowney
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Shahriar,

    Does your theme have a wp_footer() template tag? All themes should have it. I think this could be the issue.

    If it does not, add the following line just before the end of the body tag </body>:
    <?php wp_footer(); ?>

    Let me know how you go. Thanks.
    Daniel

  4. Shr.Khr
    Member
    Posted 1 year ago #

    Hi Daniel
    In the root of my theme folder, there is file called footer.php.

    This file has the following lines at the very bottom:

    <?php wp_footer(); ?>
    
    </div><!-- container -->
    
    </body>
    </html>

    So, what do you think?

    Also, as FYI, I am using a child theme but my child theme folder only has a style.css file.

  5. dpowney
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Shahriar,

    The problem is that the Javascript is not at the bottom of the page (where it should be). I believe W3 Total Cache is minifying the JavaScript and placing it in the header instead. Can you please configure W3 Total Cache plugin to place the minified JavaScript at the bottom location. There should be an option to be able to do this in the plugin Settings in the JS minify section.

    I found a similar support discussion here: http://wordpress.org/support/topic/plugin-w3-total-cache-minified-javascript-at-bottom-of-page

    Let me know if this fixes the problem. Thank you.

  6. Shr.Khr
    Member
    Posted 1 year ago #

    Hi..
    Really appreciate your reply and the information.

    However, even after I disable the W3 Total Cache plugin (the plugin is enabled now), I get the same issue as described here i.e., the URL becomes: http://www.shahriarnk.com/?drawHeatMap=true

  7. dpowney
    Member
    Plugin Author

    Posted 1 year ago #

    Hey,

    Can you try again and clear your browser cache before testing again? Or leave it disabled temporarily so I can visit and investigate further?

    Daniel.

  8. Shr.Khr
    Member
    Posted 1 year ago #

    Hi Daniel
    I have deactivated the W3TC plugin as requested.

    Thanks again for your help.

  9. dpowney
    Member
    Plugin Author

    Posted 1 year ago #

    Hey Shahriar,

    The canvas is now drawn. But for some reason the mouse clicks and touch screen taps are not saving correctly and no data is returned. What version of PHP do you have? Do you have any mouse click data saved already? Can you refresh and clear the database?

    Thanks,

  10. dpowney
    Member
    Plugin Author

    Posted 1 year ago #

    I will also fix to allow the plugin JavaScript to be at the top. So wait for version 2.2.1 soon.

  11. dpowney
    Member
    Plugin Author

    Posted 1 year ago #

    And deactivate and then reactivate the plugin to ensure database changes are up to date. Try this before clearing the database. Let me know how it goes. Thank you.

  12. Shr.Khr
    Member
    Posted 1 year ago #

    Hi Daniel
    I have updated the plugin to Version 2.2.1 but my URL still changes to http://www.shahriarnk.com/?drawHeatMap=true

  13. dpowney
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Shahriar,

    Since version 2, URL's are now normalized. Could you please tell me if this is causing any issues. Thanks.

  14. dpowney
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Shahriar,

    I am marking this topic as resolved since the heat map is now working on your website. I tested with window width 1881px.

    Thank you.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags