WordPress.org

Ready to get started?Download WordPress

Forums

Can't see text (22 posts)

  1. richgdavid
    Member
    Posted 5 months ago #

    I'm relatively new to WordPress. Having a problem in all of my areas of editing (Visual or HTML editing of "Posts" "Events" etc) - I can't see the text. It's as if the text color got changed to white. The text is there, I just can't see it.

    HOW do I change back to black so I can see what I'm editing - this is a new issue - If I click and highlight the text, it's there (it changes color)

    What can I do to resolve this issue? Cat see text while editing

  2. Evan Herman
    Member
    Posted 5 months ago #

    It shouldn't be defaulting to white. Did you install any plugins recently that may be causing this issue? If not, did you add any styles to your theme or child themes CSS file?

  3. It's a javascript issue. I develop inside the tinymce editor all the time.

    Whenever there is a javascript conflict when initializing the content editor... it will display as a white background with white text. Also, the editor buttons do not load.

    My first step would be to deactivate all, yes ALL, of your plugins.
    Next.. manually empty your browser cache.

    Now, go back to the editor and see if it loads properly.

    Let me know.. and I'll explain the next steps.

  4. Evan Herman
    Member
    Posted 5 months ago #

    Thanks for that but of info Josh. I'm sure one day I'll run into the issue, and now I know how to resolve it.

  5. richgdavid
    Member
    Posted 5 months ago #

    Ok. I'll give it a try. Also, my media links don't seem to be working correctly can that be related?

  6. Evan Herman
    Member
    Posted 5 months ago #

    Yea, that is definitely related to the JavaScript error being thrown.

    Deactivate all your plugins and both should come back to functioning properly.

  7. @Evan,
    My pleasure. Glad to see you here helping, learning, and becoming one of the next WP geniuses ;)

    @richgdavid,
    Yes. If the javascript is rendering an error, it's entirely possible it can prevent other javascript related features from working properly.

    As you have noticed, this includes your media links. It should also affect your 'help tab' for that page. If you go to create/edit a post or page, look at the top-right of the screen. You should see a little tab called "Screen Options". I'm betting if you click that tab... nothing happens.

    They are all related.

  8. richgdavid
    Member
    Posted 5 months ago #

    Well, unless I missed one, I have deactivated all of my plugins, cleared history and cashe. Restarted the browser and still, same results. Text is there, but cant read it unless I highlight it
    I can cut, paste manipulate data:

    Any other thoughts? (I really appreciate both of you helping me out!!)

  9. Evan Herman
    Member
    Posted 5 months ago #

    If that's the case then it's probably a theme JS issue. What theme are you running, if you mind me asking?

    Try switching to a default theme (2012,2013,2014) and see if the problem persists.

  10. Yep.. next step is the theme.

    Are you running the latest version of WP? If yes, then do as @Evan suggested... refresh your browser cache.. and try again.

  11. richgdavid
    Member
    Posted 5 months ago #

    No, I am not running the latest version. I'm risk averse and a bit ignorant to what will happen when I do the upgrade - I don't want my site to crash or something. Are my fears justified or should I just upgrade? How do I do that?

  12. That's your problem ;)

    First hand experience of what happens when you put off the inevitable.

    My advice... upgrade.

    1. Disable ALL plugins.
    2. Switch to the default WP theme.
    3. Upgrade.
    4. Reactivate your theme (hopefully it works)
    5. Update your theme (if available)
    6. Update any plugins (if available)
    7. Reactivate your plugins (one at a time), fully testing to see it's affect on your site. If you are pleased, activate another.

    Bottom line... alway try to stay updated with latest versions. Especially in an open-source world like WP where things are always changing.

  13. richgdavid
    Member
    Posted 5 months ago #

    Great advice Josh. I will work on that today and check in after the upgrade.

    Again, I really appreciate both of you helping me out!!!

  14. richgdavid
    Member
    Posted 5 months ago #

    Uggg! When people to my web site they are getting attacked by some malware or something. Their antivirus software is showing hits from some "Red Exploit Kit Website 2" attack. This seemed to have started when I connected to the Softolicious. I really haven't much of anything else.

    HELP! ANY IDEAS? I'm looking customers.

  15. richgdavid
    Member
    Posted 5 months ago #

    oh, and I'm not sure if its all connected but I haven't' even completed the backup or updated WP yet. As I mentioned before, I'm new to all of this and having some problems getting it all done.

  16. richgdavid
    Member
    Posted 5 months ago #

    I can't edit anything on the site anymore...I think I'm out of my league on this. I'm really afraid that I'm going to screw up my web site all together... How do I get some help - someone to make the changes that need to be made.

  17. kmessinger
    Volunteer Moderator
    Posted 5 months ago #

  18. richgdavid
    Member
    Posted 5 months ago #

    oh boy. Thanks again for your help. I will begin to work through this.

    I'm sure I'll be writing soon.

  19. richgdavid
    Member
    Posted 4 months ago #

    I think I've made some head way , though when going to my site now error is displayed:

    "BlockUI requires jquery V1.2.3 or later, you are using 1.10.2"

    If you hit "OK" you go to the site. Any thoughts?

  20. richgdavid
    Member
    Posted 4 months ago #

    oh, and the search pages are showing my site as being hacked. I'm not sure how to clear that up

  21. richgdavid
    Member
    Posted 4 months ago #

    Did you guys give up on me? Can you help me clear:
    "BlockUI requires jquery V1.2.3 or later, you are using 1.10.2"

  22. kmessinger
    Volunteer Moderator
    Posted 4 months ago #

    You are still hacked.
    http://sitecheck2.sucuri.net/results/goldenlionacademy.com/

    Your first job is to get rid of the hack. Every error you get is or could be caused by the hack. To eliminate that possibility get rid of the hack.

Reply

You must log in to post.

About this Topic