WordPress.org

Ready to get started?Download WordPress

Forums

Can't schedule posts in 2.8 (13 posts)

  1. communicatejesus
    Member
    Posted 4 years ago #

    Since I installed version 2.8 I can't schedule posts, or change the status of posts that have been scheduled.

    The links to 'edit' next to 'status', 'visibility', and 'publish immediately' appear, but when I click on them nothing happens.

    I'm using:

    Firefox 3.1.10
    Mac OSX 10.5.7

  2. communicatejesus
    Member
    Posted 4 years ago #

    I've disabled a number of plug-ins, and it seems that one of these plug-ins was causing the edit functions to break.

  3. JTownend
    Member
    Posted 4 years ago #

    I have the same problem: does anyone know how to fix this?

  4. hereandthereblog
    Member
    Posted 4 years ago #

    i'm having trouble with scheduled posts since upgrading to 2.8 also. namely, the schedules aren't publishing, and from the edit dashboard, those whose scheduled time has passed return a message under the schedule date that says: Schedule missed.

    anyone? anyone?

  5. hereandthereblog
    Member
    Posted 4 years ago #

    @communicatejesus any idea which plugin caused this? and were you able to reactivate them and still schedule posts? we need all of our plugins, but also need to schedule posts.

  6. hlr
    Member
    Posted 4 years ago #

    Hi,
    I'm almsot certain it's not a plugin but WP by itself. After disabling all plugins, systems persist and I can't schedule any post.
    -hlr

  7. Irishcopywriters
    Member
    Posted 4 years ago #

    I'm having a problem even getting my edit (publish) to open up, so I cannot schedule anything. Doesnt matter if I use Firefox or IE. Anyone else having the same problem?

  8. sprmsh
    Member
    Posted 4 years ago #

    Same problem, I can't schedule any post.
    I'm using: Firefox: 3.0.13 or Safari: 4.0.2 on Mac 10.5.8. WordPress 2.8.4. on my server. The time of the post revisions is correct, then I suppose that the time on my server is right. Any suggestion?

  9. JHouse
    Member
    Posted 4 years ago #

    Same issue here, however, if I deactivate all the plugins, it works. I'm using Firefox. I have a ton of plugins, so trial and error would be pretty time consuming. It'd be great to know which plugin is the culprit. Anyone?

  10. esmi
    Theme Diva & Forum Moderator
    Posted 4 years ago #

  11. Marlimant
    Member
    Posted 4 years ago #

    I have solved to the problem of missed scheduled:

    - First I recognized that wordpress 2,8 is much more slow, is a fact.
    - Then I stopped looking for an error of programming. I started to find an excessive delay.
    - Then, reading, I discovered that schedule post was not a problem of WordPress 2,8 it is a symptom of a slow system.
    - Finally I found it the solution here: http://lists.automattic.com/pipermail/wp-trac/2009-January/038071.html and consists of modifying the timeout in wp-includes/cron.php.
    Approximately in the line number 205 I changed
    wp_remote_post ($cron_url, Array (' timeout' => 0.01, ' blocking' => false));

    To 20 seconds:

    wp_remote_post ($cron_url, Array (' timeout' => 20, ' blocking' => false));

    Lamentably I have not get to scheduled post work nex to Hyper Cache (they only works together in WP 2,6) reason why you must to disconnect that plugin to see working scheduled post.
    It's work for me. I hope help you.

  12. craigedmonds
    Member
    Posted 4 years ago #

    Hi communicatejesus,

    I am having exactly the same issue.

    ESMI - your link is great but its nothing to do with the issue we are having. We cannot even access any of the links under the Publish section so cant even schedule anything. The links appear but nothing happens when you click on them. However I did apply the suggestion and nothing changed.

    Marlimant - likewise. We cant even get to the scheduling to actually schedule anything.

    I am running WP 2.8.4 on WAMP.

    Have tried disabling all plugins and the error still persists.

    Kindest Regards
    Craig Edmonds

  13. craigedmonds
    Member
    Posted 4 years ago #

    I can now confirm the issue was with a plugin, namely WP Events Calendar by wp-eventscalendar.com.

    I disabled the plugin and I can now schedule pages again.

    I would suggest that whoever else has this issue, simply deactivates their plugins one by one.

    Kindest Regards
    Craig Edmonds

Topic Closed

This topic has been closed to new replies.

About this Topic