WordPress.org

Ready to get started?Download WordPress

Forums

Can't save posts! Only titles get published... (25 posts)

  1. los1sol
    Member
    Posted 7 years ago #

    I just set up wordpress and everything seemed pretty easy until I realized I can't save or publish any of my posts. All I can do is save and publsih titles. Whether I hit, "save and continue editing", "save" or "publish" I get the same pop-up window that reads:

    "Are you sure you want to navigate away from this page? The changes you made will be lost if you navigate away from this page. Press OK to continue or cancel to stay on the current page."

    Am I doing something wrong here?

  2. steve1959
    Member
    Posted 7 years ago #

    I have the Exact Problem. I set up wordpress using the newest verson and no matter what I seem to do only the the titles are saved.

    Also having the same problems with comments to posts. Only titles or headers are showing up

  3. discolightning
    Member
    Posted 7 years ago #

    I'm having the same problem, and I've found several posts regarding it. The suggested solution is to disable the rich text editor in your profile, but that won't work for me. I'm trying to set up a blog where a few other less computer literate users can post. With this bug, I'm having to wait to train my co-workers. I hope the WP team finds the problem and fixes it soon!

  4. Chris_K
    Member
    Posted 7 years ago #

    Does this problem happen if using the "Default" theme?

  5. discolightning
    Member
    Posted 7 years ago #

    yes. it also seems to be cross-broser and cross-os from reading other posts. and it might have a couple of variations.

    It also happens when editing pages...basically anytime the rich text editor is used

  6. Chris_K
    Member
    Posted 7 years ago #

    What plugins?

  7. discolightning
    Member
    Posted 7 years ago #

    all plugins were disabled at one point, but here's a list anyway:

    Communications by Instinct Entertainment
    Enlarger - Andy Staines
    FireStats - Omry Yadan
    Page Update Notification - Andy Staines
    Random Header - Kamiel Martinet
    Sidebar Widgets - Automattic Inc
    Vril's Transparent PNG Fix - Alex Kot
    Weather Icon - Viper007Bond
    WP Polls - Gamerz
    WP Polls Widget - Gamerz

  8. Chris_K
    Member
    Posted 7 years ago #

    A bunch that I'm not much familiar with.

    Here's where I was headed... do any of those include prototype.js as part of the installation?

    One thing to try would be to re-upload the files in /wp-includes/js to be sure you've got the "right" javascript libraries

    (yeah, I'm guessing, but worth a shot right?)

  9. discolightning
    Member
    Posted 7 years ago #

    thanks. I'll have to dig around when I'm on my own computer.

  10. discolightning
    Member
    Posted 7 years ago #

    These plugins contain prototype.js

    Weather Icon
    Widgets
    Podpress
    Firestats
    Communications

    So, is it safe to assume that any/all of these plugs will break the rich text editor? And if I reinstall the original prototyp.js file, will these plugins break?

    Do i copy the whole js folder or just the prototype.js file?

  11. discolightning
    Member
    Posted 7 years ago #

    okay...that didn't work

  12. steve1959
    Member
    Posted 7 years ago #

    Ok I have a work around (I think)

    Go to users and then your profile

    un-tick Use the visual editor when writing

    and now your posts show up.

    Hope this helps a little. I am sure this is not a perfect fix but it should allow you to post to your blog now

  13. discolightning
    Member
    Posted 7 years ago #

    i've been doing that. the problem is that other contributors are not familiar w/ html code, and I don't really have time to teach it. besides, the editor should work. For now, the best thing is to use Blog Desk. It's still a work-around, though.

  14. Jaybop
    Member
    Posted 7 years ago #

    Just tried this temporary solution and this worked for me too. It appears that when using the Visual Editor, the respective row "wp_posts.post_content" is not updated with the text typed in the editor. I plan to use the plain editor until a fix is released. :-/

  15. Jaybop
    Member
    Posted 7 years ago #

    Fixed: I checked my FTP client's upload settings and it appeared that all javascript files were being uploaded in BINARY, when they should have been uploaded in ASCII. I changed an option to upload all *.JS via ASCII and re-uploaded my entire WP's js directory (./wp-includes/js/). I then reconfigured my profile to use the Visual Editor, and boom, it works.

    Try it.

  16. discolightning
    Member
    Posted 7 years ago #

    need a fix badly...not a work-around. I would look at the javascript files myself, but I'm hardly know any JS.

  17. Jaybop
    Member
    Posted 7 years ago #

    I'm not sure I understand.. my previous post is is a permanent resolution and does not require knowledge of JS.

    When you uploaded the WordPress files to your host, you either uploaded the files via ASCII or BINARY. In your FTP client's settings, there is an option to set either one of the above or AUTO. The "AUTO" setting will try to automatically decide which method of transfer you would like (ie. *.gif sent as BINARY and *.txt sent as ASCII).

    In this case, my FTP client was set to AUTO and transferred all *.js via BINARY. I simply changed a setting in my FTP client to send all *.js as ASCII instead of BINARY. I reuploaded all files and subdirectories in [../wp-includes/js/] and things work fine.

    Does that make sense?

  18. discolightning
    Member
    Posted 7 years ago #

    yeah...i'll try that. the other day i was on another computer and uploading thru windows explorer. I have WiseFTP , though, and I'll see if your solution works.

    thank you.

  19. discolightning
    Member
    Posted 7 years ago #

    it didn't work. uploaded everything again, JS files in ASCII. Still, I can't post using the rich editor.

    and just a sidenote, i didn't see your post about that before the "I don't know JS thing." I was just saying that I would look for conflicts there if I was more knowledgeable.

  20. Jaybop
    Member
    Posted 7 years ago #

    Sorry to hear that. I'm curious, did you upload all files/directories under [../wp-includes/js/] or just the *.js files only? I ask because I remember the hierarchy being rather large and if you manually went through all directories, perhaps ya just missed one. There are so many JS files in:

    [./../js/tinymce/]
    [./../js/tinymce/autosave]
    [./../js/tinymce/wordpress]
    ..etc

    I only say that because we had the exact same symptoms and I was able to fix mine once I read your posts about disabling the visual editor, which enabled me to focus my troubleshooting. Before that information, I was pulling my hair out with that error, heh.

  21. tjconroy
    Member
    Posted 7 years ago #

    Your post regarding turning off the visual effects editor worked for me. Thanks you.

  22. soultrance
    Member
    Posted 6 years ago #

    I'm having the same problem as many other people, apparently.

    I tried re-uploading the entire JS folder in ASCII and it didn't work. Disabling the rich text editor works, but I don't want to hassle with HTML to make a post.

    What's really weird is that everything worked fine up until a few weeks ago (and I didn't make any changes to screw with anything). I just recently installed 2.3.1 and it still didn't fix the issue.

    Also, what really gets me, is my admin account and any new accounts I create can make posts with titles but no content, however, an old account I made for a co-worker on the Author level can use the rich text editor and make posts with titles and content without a problem. What the heck is with that?

    Any other possible fixes to this? I can use HTML for the time being, but this SHOULD be working.

    Cheers

  23. redalderranch
    Member
    Posted 6 years ago #

    wow. and this thread just died out two months ago? was there any resolution that involved keeping the visual editor?

    I just set this up for the first time today and ran into the same problem. I don't care that much about the visual editor, but when I was trying to make the post and switch it over to "code" ( i don't mind writing html) it would not let me switch, staying in the visual editor instead.

    any new news about this? I just posted a new thread before I found this one.

  24. moshu
    Member
    Posted 6 years ago #

    What happens if you turn it off for good (Users > Your profile)?
    Turning off and switching between visual/code is NOT the same thing...

  25. redalderranch
    Member
    Posted 6 years ago #

    I found that I had missed uploading a few plugin items so I fixed that. Now I can switch between editors, but only the code editor actually saves and publishes my posts. The visual editor still makes it all disappear.

    And before I found the missing files, turning off the visual editor at users>your profile did work to get the code editor working.

    is there a fix for this, or something we just work around?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags