WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] can't save or publish edits to posts (6 posts)

  1. johncomic
    Member
    Posted 4 years ago #

    I use the ComicPress theme to publish a comics blog. ComicPress allows me to upload a page of comic art, and I then edit the post with commentary.

    When I went in today to post my latest, I was informed that I had been upgraded to WP3.0 (which I never asked for, BTW, the previous version was working fine for me) and that my database was being refreshed. First thing I did was look at my site (www.spacekidcomics.com) and everything still looked normal, so OK. I uploaded today's drawing - no problem. Then I went in to edit the post and add my commentary, and here's where I hit a snag:

    I can't find the button that will allow me to save or publish my edits.

    I remember where it was in WP2.9.2 cuz it took me a while to locate it then. So I scrolled up and down the editing page very carefully, several times, trying to look everywhere, and I cannot see where the control is now that will allow you to save the text/blog portion of the post. So I end up leaving the page, being warned that my changes will be lost, but I dunno what else to do.

    I have tried deactivating all my plugins (I only use two: ComicPress Manager and Theme Companion, both of which I also updated today to see if that update would solve the problem) and still no Save/Publish button. I have tried using IE instead of Firefox, still no good. I'm sorry if I'm just being really stupid and it's been right in front of me all this time, but right now I cannot find that button. Hope someone can help, please!

  2. johncomic
    Member
    Posted 4 years ago #

    And yes I tried searching the forums first (which is how I knew about the deactivate your plugins trick) but found nothing exactly like what I'm facing here...

  3. esmi
    Forum Moderator
    Posted 4 years ago #

    Try looking in the Screen Options pulldown at the top of the Edit Posts page and ensure that 2 columns is ticked.

  4. johncomic
    Member
    Posted 4 years ago #

    I tried that (last week I was using one-column just fine so that never occurred to me) and here's what happened:

    When I switched to 2 columns, there was a new column displaying (and overlapping the text box) that had a Publish button, so I can see what you're getting at. But I couldn't get at the text box to insert my commentary because the new column was blocking it. So I switched back to 1 column long enough to write my text, then switched back to 2 so I could see the Publish button. Now, however, the new second column is coming up as a transparent rectangle -- I can see where it's supposed to be, but there's nothing in it. I have cleaned my cache, logged out and restarted my browser, and still the second column is coming up transparent and empty -- I never saw anything there except for that very first time I tried it.

  5. johncomic
    Member
    Posted 4 years ago #

    Hey, never mind -- once I looked back on what I said there about the columns overlapping, I thought about it and figured "maybe my screen is too narrow"! So I reset my monitor display settings, went back in, and now the Publish button is showing AND not covering the text box. I now have my post safely edited and all is well. Thanks again for the 2 columns tip!

  6. esmi
    Forum Moderator
    Posted 4 years ago #

    No problems - it's caught a few people out.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags