WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Can't save anything in WYSWIG editing window (3 posts)

  1. chuckbrix
    Member
    Posted 7 years ago #

    I have been trying to get the TinyMCE editor to work in WordPress 2.1. Basically, when I try to edit an existing post, or create a new post, nothing will be saved in the editing window.

    When I hit the "Save" or "Save and continue editing" buttons, I get the following information in a pop-up window:

    ------------------------------------------

    Are you sure you want to navigate away from this page?

    The changes you made will be lost if you navigate away from this page.

    Press OK to continue, or Cancel to stay on the current page.

    ------------------------------------------

    If I turn off the rich text editor, the posting and editing works. But, I would like to be able to work in the rich text editor because it is easier to manipulate the text the way I like.

    There's a lot of posts about this problem, but none of the suggested solutions seems to work. I am using Firefox mostly, but have the same issues in IE.

    Based on this, it seems that tinymce is the main issue. Is there any workaround for this to get the rich text editor to work in WordPress 2.1? I have tried clearing the cache, updating javascript privileges, etc. But nothing seems to work.

    Thanks,
    Chuck

  2. chuckbrix
    Member
    Posted 7 years ago #

    In my case, there was a conflict between WordPress 2.1 and my Lowstream theme. The folks at http://www.lowstream.com quickly figured out what the issue was, and now it is fixed.

    You can find the fix at: http://wp.lowstream.com/

    Basically, since the theme was using prototype.js, and WordPress 2.1 was using prototype.js, there was a conflict. A quick couple of changes in the code, some renamed files, and it works like a champ.

    Good luck!
    Chuck

  3. popsiedaisy
    Member
    Posted 6 years ago #

    The two links listed by chuckbrix didn't work. I still have this problem. Does anyone have an update on a solution?

    I can make changes on my friends Mac, but cannot make any edits or create any new posts on my PC via Safari, Firefox, and/or IE.

    Any assistance that could be offered would be greatly appreciated.

Topic Closed

This topic has been closed to new replies.

About this Topic