WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] can't restore db in phpmyadmin (7 posts)

  1. jmckiernan86
    Member
    Posted 1 year ago #

    i have wp installed on a local wamp server and im trying to restore a database through phpmyadmin using the instructions here:
    http://codex.wordpress.org/Restoring_Your_Database_From_Backup

    but i keep getting error messages such as: 'file too large' or 'no file specified'

    I've tried using zipped and unzipped versions (.sql, .sql.zip, .tar.zip) but I still can't get it to work.

    The db and files are being backed up by the BackWPup Jobs plugin which can save in zip, tar, tarGzip and tarBzip2.

    I'd also like to know how to do the restore through commandline

    any help is appreciated!

  2. andrewmills
    Member
    Posted 1 year ago #

    When I've had .sql files that were too large to import via phpmyadmin, I've been able to sometimes work around the size limit by *carefully* splitting the .sql file into a series of files in a plain text editor.

  3. esmi
    Forum Moderator
    Posted 1 year ago #

  4. jmckiernan86
    Member
    Posted 1 year ago #

    is there any other way to do this without splitting the file

  5. andrewmills
    Member
    Posted 1 year ago #

    Basically, there are four ways to do this. You've ruled out #1 and #3, so that leaves #2 and #4.

    Since you are running on localhost, Option 2 might be "easiest."

  6. jmckiernan86
    Member
    Posted 1 year ago #

    great, solution 2 worked. thanks! now i have another question though but I think it needs its own thread

    thanks again!

  7. cscottb
    Member
    Posted 1 year ago #

    @andrewmills

    Putting the .htaccess in the local phpmyadmin folder worked for me.

    In a WanpServer install, the phpmyadmin folder can be found in the wamp > apps folder.

    Thanks so much.

Topic Closed

This topic has been closed to new replies.

About this Topic