WordPress.org

Ready to get started?Download WordPress

Forums

Can't resolve error with cookies preventing login to admin on second website (9 posts)

  1. chrisquick
    Member
    Posted 8 months ago #

    I created a multisite network through my original blog site, http://christinaquick.com/, installed the WordPress MU Domain Mapping plug in and mapped my second website to its own domain http://umtentrepreneur.com/. The new website is live, but I can't log into the admin panel to add content and make changes. I can still login to christinaquick.com just fine, but when I go to login to umtentrepreneur.com with my existing super admin password, I get the following message:
    ERROR: Cookies are blocked or not supported by your browser. You must enable cookies to use WordPress.

    I have tried loosening the security settings on my cookies, deleting my cookies/history, and logging in with a different browser. None of those things worked. Now I'm stumped as to what to try next. Trolling past forum posts hasn't turned up any clear answers. Can anyone help? Thanks,

  2. Okay, I get that if I put in a fake account.

    Any other plugins running?

    Could you log in before mapping?

  3. chrisquick
    Member
    Posted 8 months ago #

    I have a number of plugins running now on my network, but I did try deactivating them all and then logging in to the umtentrepreneur.com site and I got the same error message. This is my first time setting up the new website/domain. I never tried logging in before mapping it, only after.

  4. I never tried logging in before mapping it, only after.

    So you know what's coming now right? :)

    Turn off mapping. Can you log in?

  5. jkhongusc
    Member
    Posted 8 months ago #

    Do you have COOKIE_DOMAIN defined in your wp-config.php? If so that could be a problem if you are using completely different domains, which you are.

  6. chrisquick
    Member
    Posted 8 months ago #

    I turned off all plugins, including domain mapping, and I still couldn't log in. I looked through the code in my wp-config.php file and there was nothing related to cookies.

  7. jkhongusc
    Member
    Posted 8 months ago #

    If you turned off all of the plugins including domain mapping, you should be able to log in! Are you logging into the right url?

    If your main site is: http://christinaquick.com/wp-admin/
    Then your sub-site login is (subdomain): http://umtentrepreneur.christinaquick.com/wp-admin/
    or (sub-directory): http://christinaquick.com/umtentrepreneur/wp-admin/

  8. connxus
    Member
    Posted 7 months ago #

    This solution to a similar problem worked for me:
    http://wordpress.org/support/topic/cookie-error-site-not-letting-me-log-in

  9. konceptunit
    Member
    Posted 3 months ago #

    Hey!

    this bug was driving me crazy the last couple of days so i thought after fixing it to share with you guys! the problem was when i was trying to login into my wordpress backend i got this annoying cookies error so this is how i fixed it!

    1. Go to your ftp and your domain.
    2. Afterwards go to your wp-contents
    3. Go to your themes folder
    4. Chose the theme that is active
    5. Look for functions.php of your teem and open it
    6. At the ende of the code you should see closing tag p> just remove it clear the spaces also and save it!
    7. Go to your domain.com/wp-login.php
    8. and try to login it should be fixed afterwards you can put the tag back where it was and save it again that was the solution for me this trick also fixes the white page problem in wordpress

    Cheers!

Reply

You must log in to post.

About this Topic