WordPress.org

Ready to get started?Download WordPress

Forums

Facebook Comments
[resolved] Can't remove credit link (24 posts)

  1. Off
    Member
    Posted 1 year ago #

    Hello, I have a problem on my few sites with newest version this plugin. I can't remove the credit link. Wtf? Still have this text Powered by Facebook Comments on post pages even the Credit option in settings is disabled.

    http://wordpress.org/extend/plugins/facebook-comments-plugin/

  2. Baden
    Member
    Posted 1 year ago #

    Same here, the problem is on or around line 123 of class-frontend.php:

    if ($fbcomments[linklove] != "off") {

    should be changed to:

    if (!empty($fbcomments[linklove])) {

    Actually, there where two places these should be changed, just so a search for $fbcomments[linklove] in the class-frontend.php file... or replace the entire class-frontend.php file with the one here: http://pastebin.com/ywBHn802

  3. Carlos Revilla
    Member
    Posted 1 year ago #

    Same here too. I replace the entire file, but -i donĀ“t know why- when trying to do a quick edit in WP Comments triggers a warning.

    Finding the two places in class-frontend.php and doing the change manually, works just fine.

  4. paulhastings0
    Member
    Posted 1 year ago #

    Had the same problem here as well, but it was a quick fix. I would recommend that @pleer and @alexmoss fix this in their next release of the plugin.

  5. Alex Moss
    Member
    Plugin Author

    Posted 1 year ago #

    @baden - this would not work as if the link is not selected then it is set as "off", not simply unset.

    either way this should have been fixed in the latest update available in the repository

  6. wellbeingtips
    Member
    Posted 1 year ago #

    Same here. I disabled the plugin and waiting for update.

  7. Alex Moss
    Member
    Plugin Author

    Posted 1 year ago #

    I have now updated to v2.0.4 to cater for older options that only a handful are experiencing. Please let me know if there's still an issue...

  8. Carlos Revilla
    Member
    Posted 1 year ago #

    With 2.0.4 the problem is back (for me). It was fixed before. I can't remove the credit link.

    Carlos

  9. wellbeingtips
    Member
    Posted 1 year ago #

    Hi Alex. 2.0.4 didn't fix the problem.

  10. Alex Moss
    Member
    Plugin Author

    Posted 1 year ago #

    Is the credit link option unticked in the settings page? I cannot replicate this and see many websites using the plugin where this works.

    The only way if nothing else works is to delete the line altogether. Edit class-frontend.php, search for "powered by" (there should be two instancess) and delete that line or comment it out

  11. Carlos Revilla
    Member
    Posted 1 year ago #

    >Is the credit link option unticked in the settings page?

    I checked twice. For the time being, I switched to class-frontend.php file from 2.03 (only this file) and works ok.

    Regards

    Carlos

  12. hunter44
    Member
    Posted 1 year ago #

    I've got this problem too.

    I've never had this problem before, but I just upgraded to the latest FB Comments today and suddenly I've got the credit even though the Credit box has never been checked.

    So something about the newest upgrade suddenly changed the way the Credit checkbox is being handled internally.

    I had upgraded on Dec. 31st to the previous upgrade (along with upgrading to WP 3.5) and the problem did not appear then, only now.

    I tried checking the Credit checkbox, saving and then unchecking it and saving again to see if that would clear it. No.

  13. Alex Moss
    Member
    Plugin Author

    Posted 1 year ago #

    i am not sure why this is happening to some and not others. i have just updated the plugin again - can you please try again?

    thanks

  14. Off
    Member
    Posted 1 year ago #

    I've just updated plugin on one of my blogs to 2.0.5 and credit link disappeared. So works good for me.
    Now it's time to update on other blogs ;)

  15. wellbeingtips
    Member
    Posted 1 year ago #

    Updated and same again. Also upgraded to 3.5. but same problem existing.
    Im using Genesis.. (can be good info to know what themes people having this problem are using).

  16. Carlos Revilla
    Member
    Posted 1 year ago #

    Alex, I just updated and now works fine, no credit link. So, fot me its ok now. Thanks for yor dedication to a wonderfull plugin.

    Carlos

  17. hunter44
    Member
    Posted 1 year ago #

    Upgraded to 2.0.5 just now. Fixed! Thank you. I use the Twenty Eleven theme.

  18. graphical_force
    Member
    Posted 1 year ago #

    I am using wp 3.5.1 and facebook comments 2.0.5 and was seeing the credit link with it unchecked in the admin section. When I check it, the credits are gone. Am I understanding this or is this reversed on how it should be working?

    Thanks.

  19. raonip
    Member
    Posted 1 year ago #

    Hi,

    Same here as for @ graphical_force

    If i check the "Credit" box the credit is gone. If I uncheck it's there......probably is reversed.
    Using WP 3.5.1 and Facebook Comments 2.0.5
    Thanks!

  20. sc0rpiongirl
    Member
    Posted 1 year ago #

    I just downloaded and activated this plugin tonight, also have problem with turning off the credit link. I read above and have tried both ways, checked and unchecked...nothing works, the credit link is still there :S.

    I am using WordPress 3.5 a fresh installation just 2 days ago. Please could you let me know if there is a fix with it? Thanks!

  21. Alex Moss
    Member
    Plugin Author

    Posted 1 year ago #

    I have installed this on a completely new installation of WordPress both with versions 3.5 and 3.5.1. I have installed nothing but the plugin and stored settings with the credit option ticked and unticked. This works fine.

    I am not sure why this is happening to some as the plugin goes through 3 separate checks to ensure to only display the button if the option is ticked. To manually remove the link look for these lines of code and delete them from the plugin editor:

    NB: Use caution if you're a beginner at PHP

    if ($options['linklove'] != 'no') {
            if ($options['linklove'] != 'off') {
                if (empty($fbcomments[linklove])) {
          $content .= '<p>Powered by <a href="http://3doordigital.com/wordpress/plugins/facebook-comments/">Facebook Comments</a></p>';
        }}}

    This code appears twice in the plugin.

  22. sc0rpiongirl
    Member
    Posted 1 year ago #

    Thanks Alex! I just rated your plug-in 5 stars. Thanks for the great plugin and help! x

  23. threegroup
    Member
    Posted 11 months ago #

    Sorry to revive an old thread, but I think I have a solution because I too had the problem.

    The problem seems to be when you embed the code yourself on a page, versus the plugin automatically adding the code.

    I believe your issue is on lines 84 and 129 of class-frontend.php. Without modification, they read:

    if (empty($fbcomments[linklove])) {

    However, your instructions for linklove say:

    enter "1" to link to the plugin

    If you enter 1, then that configuration setting is no longer empty. Therefore, the modification to lines 84 and 129 should simply be one character:

    if (!empty($fbcomments[linklove])) {

    This resolved all problems for me, hope it does for others - and that if I'm right, Alex can incorporate this fix into the next patch of the plugin.

  24. Alex Moss
    Member
    Plugin Author

    Posted 10 months ago #

    Updated - let me know if it doesn't work for you...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic