WordPress.org

Ready to get started?Download WordPress

Forums

WP Ultimate Recipe
[resolved] Cant preview posts with custom user role. (2 posts)

  1. yo-l1982
    Member
    Posted 4 months ago #

    Hello,
    I encounter a bug when I activate this plugin and then later try to preview a regular post as user with a custom user role.

    When user assigned to this role the preview of a post delivers a 404.

    I am using this code to add the new user role, if you need to reproduce.

    $new_role = get_role('editor');
    $caps = $new_role->capabilities;
    $caps['NextGEN Gallery overview'] = '1';
    $caps['NextGEN Use TinyMCE'] = '1';
    $caps['NextGEN Upload images'] = '1';
    $caps['NextGEN Manage gallery'] = '1';
    $caps['NextGEN Manage tags'] = '1';
    $caps['NextGEN Manage others gallery'] = '1';
    $caps['NextGEN Edit album'] = '1';
    $caps['NextGEN Change style'] = '1';
    $caps['NextGEN Change options'] = '1';
    $caps['manage_polls'] = '1';
    $caps['uninstall_polls'] = '1';
    $caps['edit_theme_options'] = '1';
    $caps['aller_fabriken_edit'] = '1';
    $caps['gform_full_access'] = '1';
    $caps['edit_tribe_event'] = '1';
    $caps['read_tribe_event'] = '1';
    $caps['delete_tribe_event'] = '1';
    $caps['delete_tribe_events'] = '1';
    $caps['edit_tribe_events'] = '1';
    $caps['edit_others_tribe_events'] = '1';
    $caps['delete_others_tribe_events'] = '1';
    $caps['publish_tribe_events'] = '1';
    $caps['edit_published_tribe_events'] = '1';
    $caps['delete_published_tribe_events'] = '1';
    $caps['delete_private_tribe_events'] = '1';
    $caps['edit_private_tribe_events'] = '1';
    $caps['read_private_tribe_events'] = '1';
    $caps['edit_tribe_venue'] = '1';
    $caps['read_tribe_venue'] = '1';
    $caps['delete_tribe_venue'] = '1';
    $caps['delete_tribe_venues'] = '1';
    $caps['edit_tribe_venues'] = '1';
    $caps['edit_others_tribe_venues'] = '1';
    $caps['delete_others_tribe_venues'] = '1';
    $caps['publish_tribe_venues'] = '1';
    $caps['edit_published_tribe_venues'] = '1';
    $caps['delete_published_tribe_venues'] = '1';
    $caps['delete_private_tribe_venues'] = '1';
    $caps['edit_private_tribe_venues'] = '1';
    $caps['read_private_tribe_venues'] = '1';
    $caps['edit_tribe_organizer'] = '1';
    $caps['read_tribe_organizer'] = '1';
    $caps['delete_tribe_organizer'] = '1';
    $caps['delete_tribe_organizers'] = '1';
    $caps['edit_tribe_organizers'] = '1';
    $caps['edit_others_tribe_organizers'] = '1';
    $caps['delete_others_tribe_organizers'] = '1';
    $caps['publish_tribe_organizers'] = '1';
    $caps['edit_published_tribe_organizers'] = '1';
    $caps['delete_published_tribe_organizers'] = '1';
    $caps['delete_private_tribe_organizers'] = '1';
    $caps['edit_private_tribe_organizers'] = '1';
    $caps['read_private_tribe_organizers'] = '1';
    
    $factory_editor = add_role('factory_editor', 'factory_editor', $caps);

    https://wordpress.org/plugins/wp-ultimate-recipe/

  2. BrechtVds
    Member
    Plugin Author

    Posted 4 months ago #

    Hi there,

    I used that code and tried it on my development website but everything seems to be working fine.

    What other plugins have you got activated at the same time?
    Is it possible to deactivate them and test with only my plugin active to see if you still experience the issue then?
    If that works try activating them one by one and testing again so we can see when the problem occurs.

    Kind regards,
    Brecht

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.