WordPress.org

Ready to get started?Download WordPress

Forums

Can't Post Via Email (6 posts)

  1. rickfla
    Member
    Posted 7 years ago #

    Hello

    I have just started a new wp blog, (my first) and I tried setting up the post via email option.

    I set up a dedicated pop email address for this and included the login and password info in the admin area.

    I've tried sending an email to the address, but they just sit on the email server, they don't get posted to the blog.

    This would be a great function to have to be able to post to the blog while traveling from a wireless device without having to access the admin to post.

    What am I doing wrong?

    Thanks for any suggestions!

  2. drmike
    Member
    Posted 7 years ago #

    For reference:

    Blog_by_Email

    My guess is the missing cron job as you don't mention that you've done one.

    Hope this helps,
    -drmike

  3. Joe Hall
    Member
    Posted 7 years ago #

    I am having this same problem. And atlas! I find the solution here! But heres another issue. For the site that I want to use this feature on, it is hosted with a company that does not provide cron! (GoDaddy) I do have another hosting account over at HostGator that does support cron. Would setting up a cron to preform this task at my hostgator account work even if I am hosting the blog at Godaddy? It seems as if it shouldn't be a problem as long as I use complete URL pathes. What are your thoughts?

  4. pikey
    Member
    Posted 7 years ago #

    I didn't set up a cron job but instead used the iframes method (pasting the code into the footer) as described on the same page
    here

    Worked for me.

  5. thejena6
    Member
    Posted 6 years ago #

    Okay, so how do you set up a cron job for this? What is the UNIX command line to do this? Because it didn't mention adding a cron job when requesting fields such as pop3 server, username, password, etc.

  6. thejena6
    Member
    Posted 6 years ago #

    Well I figured out the cron job stuff (e.g. posting every minute is as follows): (if hosting on typical cPanel web hosting service, like http://www.toneeecom
    * * * * * /usr/local/bin/php -q /home/name_of_user/public_html/wp-mail.php

    So it's collecting the mail, but NOT posting the body of the emails, only the subjects. This is horrible! What do you think is the problem?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags