WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] can't modify headers - comments-template.php & pluggable.php (9 posts)

  1. stephenrusselcrane@yahoo.com
    Member
    Posted 2 years ago #

    I recently tried logging in to my site backstage and got this message

    Warning: Cannot modify header information - headers already sent by (output started at .../wp-includes/comment-template.php:1552) in .../wp-includes/pluggable.php on line 866

    today it wont let me on the site itself & it is giving me the same message. What happened and how do i fix it?

  2. stephenrusselcrane@yahoo.com
    Member
    Posted 2 years ago #

    Thx! I looked it over but still can't get it sorted. I replaced my comment-template.php file with a fresh file from a new wordpress download but i still get the message.

  3. stephenrusselcrane@yahoo.com
    Member
    Posted 2 years ago #

    I also checked to see if there was extra space at the beginning and end of my comment-template.php file but to my knowledge there isn't.

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.

  5. stephenrusselcrane@yahoo.com
    Member
    Posted 2 years ago #

    okay so i backuped my pluggins folder and deleted the pluggins in it. then i reuploaded them one at a time and found that simple facebook connect was giving me the issues. I can finally login to my dashboard now but the pluggins page is giving me issues. I reinstalled the pluggins that i was using but the page isn't displaying them. Any thoughts?

  6. bobbieg
    Member
    Posted 2 years ago #

    I'm having this same issue with every one of my wordpress sites. It started happening two days ago. So far I've upgraded all my WP sites to the current version. I removed almost all the plugins. Right now I'm removing old themes.

    I primarily use OptimizedPress and StudioPress themes, but had a bunch old ones just hanging in there.

    My errors look like this:
    Warning: Cannot modify header information - headers already sent by (output started at /usr/lib/php/ini:49) in /home/authorst/public_html/wp-includes/pluggable.php on line 866

    Some of my WP sites look fine on the fronted and on the backend the admin is either not reading the style css or it's throwing this type of blank space error. The ones throwing the error... I can't do anything with. There's no content displayed.

    Some of my WP sites are throwing the error on the fronted too. It's weird.

    Any ideas or thoughts... and especially a fix are welcomed!

  7. bobbieg
    Member
    Posted 2 years ago #

    Also, I read through How_do_I_solve_the_Headers_already_sent_warning_problem > FAQ Troubleshooting « WordPress Codex as linked up above. None of that helped, but I did notice that the new wp-config doesn't have a closing ?> tag, but the older wp-config files do. Has there been any issues with that? Any issues that require redoing all the wp-config files?

  8. kitchin
    Member
    Posted 2 years ago #

    The closing ?> is not needed.

    Any chance you have WP_DEBUG true in wp-config.php? Often the output is started by PHP notices of deprecated functions and other non-fatal stuff.

    Normally I would say to try http://www.php.net/manual/en/function.debug-print-backtrace.php at the code starting the output, but the message says "output started at /usr/lib/php/ini" which makes me think it is some PHP caching or buffering gone haywire. In other words, something beyond WordPress. Just a guess.

Topic Closed

This topic has been closed to new replies.

About this Topic