WordPress.org

Ready to get started?Download WordPress

Forums

can't moderate new comments? (8 posts)

  1. GaryKing
    Member
    Posted 9 years ago #

    I have, in 'Comment Moderation', "1 link only", and all the items in the 'spam words' list in there.
    BUT people keep on posting comments that have 3 links in them, and this is pissing me off :(
    It seems like the moderation is broken here somewhere, what should I do?
    Their comments look like this:
    ============
    1549 http://www.I'm a stupid spammer.com
    ============
    [Moderated - Links removed]

  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    I'd suggest some more robust spam protection:
    Current listing of what's what:
    http://www.tamba2.org.uk/wordpress/spam/

  3. Joshua Sigar
    Member
    Posted 9 years ago #

    But why the built-in filter fails to catch a comment with exceeding number of links, though?

  4. There seems to be a way around that filter, but there are plenty of other options.

  5. carthik
    Member
    Posted 9 years ago #

    GaryKing,
    If that's happening, it might be something about your setup, or perhaps, the comments. Is there anything special about the links in the spam comments?
    Could you try spamming yourself? :) and then you could post a link to that comment which got thru WP, so everyone could see and find what's wrong?
    Please also check your settings, I am sure you have already, but it's good to be sure...

  6. 2fargon, it's not a problem with the settings. A number of us are experiencing the same thing. I think the spammers have found a way to bypass the built-in link moderation. They aren't getting around the built-in keyword blacklist though.

  7. midori
    Member
    Posted 9 years ago #

    Spam completly stopped for me. Has anyone here tried to do so:
    my wp-post.php and all other parts involved in comments I renamed, giving them (french-speaking) names with no relation with the original. Then I modified all files calling a require() to the new names, and corrected other links to them.
    I removed the ancient files, and set the new ones ... And finally I did lower the authorised link quantity to 2.
    It seems it did the trick...
    Somehow, you could also raise the time to wait between two comments, I think it could help.

  8. I renamed my comment posting file as well and it has knocked out about 98% of my SPAM. The setting for how much time is allowed between comments can be found inside the file that is or used to be wp-comments-post.php . BTW, if you're using the built-in blacklist, I recommend using this small hack to. It notifies users when their post has been blacklisted and to please wait for approval: http://txfx.net/2004/10/29/wordpress-hack-notify-users-of-moderation/

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.