WordPress.org

Ready to get started?Download WordPress

Forums

Can't Make New Static Pages (42 posts)

  1. thepete
    Member
    Posted 9 years ago #

    Well, I did search the forum for this problem, but since I upgraded to 1.5.1.1 I haven't been able to create new static pages. Theys how up in the "manage pages" area, but when I try to view them, they don't actually exist. I get the "Page Not Found" thing.

    Is this an .htaccess thing? I'm thinking it is if only because I don't see any htaccess files on my server despite setting my FTP client to display hidden/invisible files.

    Any help would be appreciated! Thanks!

  2. Your .htaccess file is not properly regenerating (WP should be able to add a new rewrite rule for each created page). See this: http://codex.wordpress.org/Using_Permalinks#Fixing_.28.htaccess.29_Generation_Issues

  3. thepete
    Member
    Posted 9 years ago #

    Thanks for the link and I thought that worked, but it ended up not working. In fact, the situation is so screwy I can't figure out what the hell's going on.

    I can create pages with the title "test" but can't seem to create pages with any other kind of titles. I'm quite baffled as to what's going on. I can't seem to find anything stable about this beyond that calling a page "test" will work but anything else is zilch.

    I just tried to create a page called "flumox" and it didn't work. Very strange, indeed.

  4. This is a random though, but try adding more to your permalink structure, like add a date structure. For example, use this:

    /%year%/%monthnum%/%day%/%postname%/

    You can always change back if you need to, this is just for test purposes.

  5. josalmon
    Member
    Posted 9 years ago #

    Hi, I'm having a similar problem - using WP 1.5.1.1 I can create new pages (called anything I like) but when I try to view them they don't exist.

    I suspect it's the .htaccess file but I don't know what to put in it to correct the problem

    Jo

  6. josalmon, did you follow the instructions that were mentioned in the second post of this thread for fixing the .htaccess generation issue?

  7. thepete
    Member
    Posted 9 years ago #

    Thanks for the suggestion MacmanX, but that didn't work. I still get the "Not Found" message when I create a new page. I can still edit the thing inside of the WP admin.

    Oh wait--actually, I just noticed that the new permalink structure didn't take. I checked the permalinks page and it says my htaccess page isn't writable, yet, I know it is--CHMOD'ed to 666. The htaccess file needs to go into the root directory? Or the WP directory? Right now, it's in my root.

  8. Mark (podz)
    Support Maven
    Posted 9 years ago #

    The wp directory

  9. thepete
    Member
    Posted 9 years ago #

    I put the htaccess file into the WP directory with the same code that the WP admin permalinks page suggested but the new structure still didn't take. Still can't make new static pages.

  10. thepete
    Member
    Posted 9 years ago #

    K, got the permalink structure to take, but still can't create new static pages. Instead of getting the "not found" page I get my site's 404 page. Not sure if that's significant or not.

  11. josalmon
    Member
    Posted 9 years ago #

    macmanx, I did a few weeks ago when I was having trouble with permalinks (which I eventually sorted) but I still can't make new pages. It just goes straight to my 404 page (like thepete)

    Not sure what the problem is or where to start.

    Is there a special code that goes in the .htaccess file?

  12. thepete
    Member
    Posted 9 years ago #

    That's my question, too. I used to be able to create new pages and I do have my old htaccess file in my site archives--but which part of it do I copy over to the new htaccess file without screwing everything else up?

  13. moshu
    Member
    Posted 9 years ago #

    It worth to give it a try: whenever something is messed up with the .htaccess fil,. I just delete it, upload an empty file named .htaccess in the WP directory (+chmod accordingly; not all servers are the same!), then I go to the Options > Permalinks and regenerate the rewrite rules.

    Edit. And in order to see your Pages the ,htaccess file has to be writable all the time otherwise WP isn't able to write the rules for every Page title...

  14. thepete
    Member
    Posted 9 years ago #

    Right, I've set it to be writable, but WP still says it isn't. So... I think something else on my server is screwing things up. Again, I'll try to old htaccess file with my fingers crossed and see what happens but since WP claims it's not writable, even though I've tried CHMODing it to both 666 and 777. Now the htaccess file in question *does* need to go in the WP directory, right? Because my index is in my server's root directory and not the WP directory.

  15. thepete
    Member
    Posted 9 years ago #

    Man, I am baffled!

    So, I upload the old htaccess file from 1.5 (not 1.5.1.1) when I was still able to create pages and WP lets me create one page. I try again and no go. This is SO frustrating because the behavior is so inconsistent.

    I really think this is all because WP can't see that my htaccess file is writable. I know it is writable because I've set it to 666 myself and checked to make sure it was still set at that.

    Any help would be *greatly* appreciated!

  16. moshu
    Member
    Posted 9 years ago #

    Usually after an upgrade you do NOT use the old htaccess file, that's what I've tried to tell you.

  17. thepete
    Member
    Posted 9 years ago #

    Well, I tried a blank file like you suggested, made sure it was CHMODed to 666 and had a go. Still with the 404.

    Thanks anyway, though.

  18. moshu
    Member
    Posted 9 years ago #

    Did WP write the new rules in the file, or were the rules displayed below the permalinks settings on the page?

  19. thepete
    Member
    Posted 9 years ago #

    They were displayed below the permalinks settings.

  20. moshu
    Member
    Posted 9 years ago #

    Then you .htaccess file wasn't written. Take the rules from there and copy/paste them into a simple text file. Upload it and name it .htaccess.

  21. thepete
    Member
    Posted 9 years ago #

    Done, still no go.

    Thanks for trying to help Moshu, I really do appreciate it. I'm beginning to think I'm just SOL on this. I suppose I could try setting up another install of WP just to see if a clean, untweaked-by-me-version will let me create new pages. Yeesh, I really don't want to do that...

  22. josalmon
    Member
    Posted 9 years ago #

    Is there any additional code that needs to go into the .htaccess file to enable you to create static pages?

    Every time I create a new Page, WP tells me it's been created, but when I click "view page" I go straight to a 404 page - I understand that I need to update the htaccess but I don't know what goes in it. That's where I'm stuck. This version of WP has never done my htaccess files for me.

  23. thepete
    Member
    Posted 9 years ago #

    Yeah, I think there must be, but I've looked around and can't find it. I'm truly puzzled/annoyed as to why this is happening. I just wish someone in the know would let us know for sure if there is something we should be adding ourselves into the htaccess file. Sure, the permalinks page tells us what to put in there, but isn't that just for taking care of the permalinks and not for the creation of new pages?

  24. speechpoet
    Member
    Posted 9 years ago #

    I've read a few threads on this. Do I understand correctly that, to create new pages, the best bet is to 1) make htaccess writeable, 2) add the pages, and then 3) make htaccess unwriteable again for security reasons?

  25. moshu
    Member
    Posted 9 years ago #

    If you are using "nice permalinks", i.e. mysite.com/mypage instead of mysite.com/?page_id=34 WP needs to re_write the rules in your .htaccess file whenever you create a new Page. The Page's slug ("mypage" above) has to be written in the .htaccess.
    So, speechpoet, yes, you understood correctly.
    If you don't use the nice permalinks, you don't have to do anything.

  26. josalmon
    Member
    Posted 9 years ago #

    Moshu, for some reason, WP 1.5.1.1 won't do my .htaccess files so I need to do it myself, which is a bit of a problem as I don't know how!

    I use the "nice permalinks" (and have no desire to lose them), so when you say "The Page's slug ("mypage" above) has to be written in the .htaccess", what do you mean? What do I write? Can someone who can make Pages copy and paste it here please? I am well and truly stuck!

    Thanks, Jo

  27. Olney
    Member
    Posted 9 years ago #

    I installed a fresh installation of the latest WP & tried to make .htacces writable & can't get this to work either...

    Our server generally runs everything & we have access all the way to the root. Usually anything with a .htaccess file runs fine..

  28. speechpoet
    Member
    Posted 9 years ago #

    Gotcha. Thanks, Moshu!

  29. moshu
    Member
    Posted 9 years ago #

    @josalmon,
    when you say "The Page's slug ("mypage" above) has to be written in the .htaccess", what do you mean? What do I write?...
    I meant WP has to write the "rules" into the .htaccess, so when I click on a link mysite.com/mypage it won't display a big 404, because - based on the rules written in the .htaccess - WP and the server will know exactly that in fact they have to show me the Page with the id# 34 (in the example above).

    Actually YOU - as the owner of the blog - don't write anything. And to be honest till now I've never took a look at my .htaccess file. Simply I didn't need it. If I want to write a Page I just chmod the .htaccess file 666 and then Create New Page. Done.
    On this test I also run 1.5.1.1.. A few minutes ago I've created a new Page, called "Newest Page": http://www.transycan.net/blogtest/ - check out in the sidebar's list.
    A note. When a .htaccess file is screwed up several times by N number of trials, I always say: delete it, reset/update your permalinks options to empty fields, then upload a new empty .htaccess file and start a new life with it :)

  30. josalmon
    Member
    Posted 9 years ago #

    I get your point that WP is meant to write my.htaccess file for me but that fact is that it never has.

    When I did my permalinks I had to do it myself using the code provided by WP.

    So based on that experience, I was assuming that if WP didn't write your htaccess for you, then there was a code you could put in it yourself.

    I've tried chmoding .htaccess to 66

    I've tried deleting it and starting over.

    I've been trying that for days - hence my first post on this topic asking how to do it myself.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.