WordPress.org

Ready to get started?Download WordPress

Forums

Can't Make Comments On Pages (11 posts)

  1. euladorblog
    Member
    Posted 3 years ago #

    The 'Allow Comment' setting is checked for each page and in the Discussion panel. Post comments are working correctly.

    Yet, when I click on the comment button for any page (for example - the ))FAQ Guestbook ) no text area is displayed in which to make a comment. The url changes to the respond page where the text area should be presented.

    Can someone help, please? This problem seems to be intermittent.

    Pat

  2. Tara
    Member
    Posted 3 years ago #

    have you checked "anyone posts a comment" in Admin - Settings -Discussion

  3. euladorblog
    Member
    Posted 3 years ago #

    Thanks for responding, t-p.
    Yes, in 'Admin-->Settings-->Discussions-->Email me whenever' I have 'anyone posts a comment' set. I also allow people to post comments on new articles where I understand articles to mean either posts or pages. The comment author is required to fill out their email and name and before a comment appears the comment author must have a previously approved comment - none of these settings should, in my understanding, prohibit a comment text area box from being displayed.

    Is there some comment template tag requirement or setting required? I tend to think something has been overlooked because no page comment button when clicked generated a comment text box.

  4. Tara
    Member
    Posted 3 years ago #

    -check (in your theme's templates) if your theme allows comment. For example, in the default Twenty Ten theme (loop.php,single.php), you can see this code: <?php comments_template( '', true ); ?>

    -if it does, then try these steps to troubleshoot:

    -deactivating ALL plugins temporarily to narrow down and possibly fix the problem. If the problem goes away, activate them individually (one-by-one) to find the culprit.

    -switching to the default theme ("twentyten") for a moment by renaming your current theme's folder in wp-content/themes. The idea is to force WordPress to fall back to the default theme to rule out any theme-specific issue.

  5. euladorblog
    Member
    Posted 3 years ago #

    Thanks for giving me some direction, t-p; in terms of how to check whether my template accepts comments. I will do that next. I deactivated all my plug-ins prior to posting the problem and I still did not get a text area for comments when the comment button was clicked. So, I have a comfort level that the plug-ins are not affecting the issue.

    I truly appreciate your help; thank you! If after searching for my files I determine that,
    <?php comments_template( '', true ); ?>
    is not being called; I will try including the php code in the files in which that code is called in the default template, twentyten.

  6. Sjeng
    Member
    Posted 3 years ago #

    Hi!

    I'm using the safe_flight_wp template by Wrangler (http://www.free-wordpress-theme.net/)
    And I can comment on posts, but it seems I can't comment on pages...
    I'm no php wizard, so could anyone check this theme to see if it's possible to comment on pages in this theme, and if not, what I should do to enable comments on pages.
    I really love this theme, so I'd hate to go search for a new one...

  7. euladorblog
    Member
    Posted 3 years ago #

    I have the same problem, Sjeng - where I can not comment on pages; but I can do so on posts. I have submitted a ticket - like a problem report - to Template_Help.com (site at TemplateMonsters.com) who created . WordPress Theme 1066 2.9 which I am using to see if they can provide some assistance. I did this last night and hope to have something from them today. I will share the information if I get a helpful response.

    I really love the theme I chose as well and so do others with whom I'm working ... I am compelled to find a solution. Please, if anyone has a solution; let us know.

  8. Sjeng
    Member
    Posted 3 years ago #

    I hope you'll get a solution. I don't know why a theme would not have the option to comment on pages, as you can always turn that option off in wordpress, but by editing the php files a solution should be possible, I just don't know how.

  9. alchymyth
    The Sweeper & Moderator
    Posted 3 years ago #

    compare single.php and page.php of your theme -
    and then copy the part of single.php which refers to the comments:

    <?php comments_template(); ?>

    to the same position in page.php;

    just before the line:

    <?php endwhile; endif; ?>
  10. euladorblog
    Member
    Posted 3 years ago #

    Thanks, alchymyth. I will try that and let you know if it works.

  11. Sjeng
    Member
    Posted 3 years ago #

    It worked! thank you SO much!!! That was so simple even I could do it lol ;)

Topic Closed

This topic has been closed to new replies.

About this Topic