WordPress.org

Ready to get started?Download WordPress

Forums

Responsive
Can't make a "posts page" (25 posts)

  1. Noz03
    Member
    Posted 1 year ago #

    Maybe I am just doing something wrong. But I chose a static page as my "posts page" in the options, and this page just shows as a kind of home page. I want it to be a simple page listing my posts from most recent first.

    How can I do this???

  2. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Posts don't show up on a static page. If you want posts on the home page, first go to theme options > home page and make sure the "custom home page" is unchecked.

    Then go to Settings > reading and select posts for the home page.

  3. Noz03
    Member
    Posted 1 year ago #

    Hmm, well first of all there is no tickbox like this under options > home page. Also even if I choose not to use a static page (choosing "front page displays: your latest posts"). The front page also does not show the posts, just a large content box that can be changed in theme options, and 3 widgets under it. Any idea what's going on here?

    Btw the site url is http://www.thestupidforeigner.com

  4. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Do you not have this under Theme Options > Home Page?

    http://img835.imageshack.us/img835/979/6mkb.jpg

    Are you using the current version of the theme?

  5. Noz03
    Member
    Posted 1 year ago #

    No I dont have this tickbox, I guess because my theme is a little bit older? Im on 1.8.4.

    Although I am starting to think that this theme does not allow a standard blog page. I read another article that i can just use a blog page template which is included on the theme and now it shows the posts but it looks absolutely horrible, no titles, dates, author, anything. Just the main text :/
    http://themeid.com/demo/blog-layout/files/2012/06/page-atributes.png

    Actually I am perfectly happy to use the detault responsive homepage as long as i can have another page to show my blog posts.

  6. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Yes, the theme was changed in the last update - why are you using an outdated version? Not generally a good idea.

    I don't know how it used to be set up...you may want to ask on the theme's dedicated forums -

    http://cyberchimps.com/forum/free/responsive/

  7. Noz03
    Member
    Posted 1 year ago #

    Actually I just updated but it didn't really help. From what I can see it is not possible to show posts in a list on responsive theme. Many of the posts I've read also seem to have the same problem :(

  8. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    I just tried it on my test site - unchecked that option under Home Page - then under Settings > Reading selected Your latest posts. Then I do get the "plain blog" posts on the home page.

  9. Noz03
    Member
    Posted 1 year ago #

    Also for some weird reason after updating it is now putting the page titles in between the header and the main navigation menu... any ideas how to fix this? I havent got a clue why it would even be doing that...

  10. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Caching may be part of your problems -

    <!-- Dynamic page generated in 0.302 seconds. -->
    <!-- Cached page generated by WP-Super-Cache on 2013-06-20 21:35:09 -->
    
    <!-- Compression = gzip -->

    I'm not sure what you mean about the page titles - I don't see that on your site.

    Make sure you're clearing your browser cache as well.

  11. Noz03
    Member
    Posted 1 year ago #

    Ok I just triple checked. The new tickbox "Enable Custom Front Page" is unchecked. And under settings > reading, "your latest posts" is checked (not static page). This is what I get > http://www.thestupidforeigner.com :(

  12. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Have you turned off SuperCache?

  13. Noz03
    Member
    Posted 1 year ago #

    The page title thing means you see the page title under the header image but above the site navigation bar. It wasnt there before.

  14. Noz03
    Member
    Posted 1 year ago #

    super cache is a plugin right? i dont have it installed.

  15. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    It's active on your site :/ - this is from your site -

    <!-- Dynamic page generated in 0.302 seconds. -->
    <!-- Cached page generated by WP-Super-Cache on 2013-06-20 21:35:09 -->
    
    <!-- Compression = gzip -->

    Look under plugins. Some hosting companies may have it installed.

  16. Noz03
    Member
    Posted 1 year ago #

    Omg actually I did have it... thats strange. But even more strange it says it is not active right now. Just googled about my host (hostgator) and says they are not using it either.

  17. Noz03
    Member
    Posted 1 year ago #

    Is your test site online? Maybe I could take a look at what exactly you are getting.

  18. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    But your site is still showing a cached page.

    Let's try this - deactivate all plugins and switch to Responsive (parent) - as right now you are using a child theme - actually I wonder if that's part of the problem here...

  19. Noz03
    Member
    Posted 1 year ago #

    Ok I just found something rather interesting... I click on live preview for the original theme (I'm using a child theme right now) and not only does the page title disappear from the weird place it shows on the child theme but also it shows the blog posts exactly as i want it to! So does that mean there is something wrong with my child?

    I've barely edited anything in my child theme though to be honest. Only added the following as a style.css

    /*
    Theme Name: Responsive - child
    Author: Noz
    Description: Child of Responsive
    Template: responsive
    */
    
    @import url("../responsive/style.css");
    
    .wp-caption {
        background: none repeat scroll 0 0 #FFFFFF;
        border: 1px solid #F0F0F0;
        max-width: 96%;
        padding: 5px 3px 0;
        text-align: center;
    }
    
    .wp-caption .wp-caption-text, .gallery-caption {
        font-size: 11px;
        line-height: 17px;
        margin: 0;
        padding: 0 4px 0;
    }
    
    .wp-caption-text span {display:block; text-align:right;}
  20. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Try actually switching to the parent.

  21. Noz03
    Member
    Posted 1 year ago #

    Not sure what I did but suddenly both the problems just seemed to fix themselves! Dont even know what I did! I guess something to do with the update and that check box which did it. Anyway thanks so much for all your help! I just hope it'll still be like this in the morning :)

  22. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Servers are just weird sometimes...glad it's working though :).

  23. Noz03
    Member
    Posted 1 year ago #

    Actually one last small question. Is it possible to use the responsive custom home page as a home page and use the standard wordpress posts page at the same time? if so that would be perfect for me.

  24. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    I would think so - if nothing else, set up a "blog" category page in the custom menu - and assign that category to all posts.

    There might be a "better" way to do it - I'm not that familiar with the theme - but you could ask or look around on the the theme forums -

    http://cyberchimps.com/forum/free/responsive/

  25. Noz03
    Member
    Posted 1 year ago #

    Ok thanks will do!

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags