WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] can't login with domain (4 posts)

  1. qqinca
    Member
    Posted 7 months ago #

    Recently I installed workpress and start to learn this nice tool. I installed on my home computer and also registered a domain to play with. However, things went to fine only with IP address as url.

    situation: domain is mapped to http://IP/wordpress.
    problem: I can use http://domain.com to view the front-page, however, when I clicked "log in", nothing happens. I wouldn't go to log in page.

    If I clicked "log in" by open a new window, it will work, and the address will become "IP/wp-login.php", as I mentioned, using IP will work all the time. Although I know there is a way to let it always open in a new windows, why it has to be IP? I must miss sth.

    I played with siteurl without luck. It only works for viewing when set as follows but not for log in anyway.
    define('WP_SITEURL','http://ip/wordpress');
    define('WP_HOME','http://domain.com') or the site as siterul.

    Please advice!

  2. OriginalEXE
    Member
    Posted 7 months ago #

    Hi there, try this:

    Login to your site using IP, go to Settings -> General and make sure that WordPress Address (URL) and Site Address (URL) are both set up to use your domain instead of an IP.

    Once saved, you should be logged out and redirected to a login via your domain, which you should then be able to use normally.

  3. qqinca
    Member
    Posted 7 months ago #

    Thanks.
    Finally I figured out what's the problem. I am using domain forwarding instead A record initially. Therefore, when I tried to set both WordPress Address (URL) and Site Address (URL) as domain.com, it won't allow me to access the website anymore.

    Now I changed the forwarding into A record in godaddy, and set both url as domain name, it works!

    I guess domain fowarding only forwards once and doesn't do more job after?

  4. OriginalEXE
    Member
    Posted 7 months ago #

    You have probably set up a forwarding in such way that only main directory was redirected.

    A records are a proper way of doing it, glad you got it resolved.

Reply

You must log in to post.

About this Topic