WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Can't login to localhost (22 posts)

  1. FlourishRT
    Member
    Posted 6 months ago #

    Working on a site on localhost and MAMP. All working fine until I downloaded a new wordpress site, renamed it as its another site and stored in htdocs folder.

    Went back to other site and now get a 404 error. MAMP is still running, still pointing to correct wordpress folder just wont work?

    I have deleted other wordpress folder but no difference. All files are still there, database in phpmyadmin still there....just won't load.

    Yes my internet is working ;-) and I have tried turning it off and on again.

    Please help

  2. liton1980
    Member
    Posted 6 months ago #

    Have you read Installing WordPress Locally on Your Mac With MAMP? Maybe something was wrong with your installation.

  3. FlourishRT
    Member
    Posted 6 months ago #

    This is the guide I use but I had it running fine with one install, added a new install and suddenly its all gone pete tong. Gone back to where I was but no luck.

    The MAMP preferences did change but I changed them back.

  4. FlourishRT
    Member
    Posted 6 months ago #

    On phpmyadmin under wp_users the user_pass is a very long random password which is very different to the password I used in the database and the wp-config file. I have tried changing this to my chosen password and saved but makes no difference???

  5. esmi
    Theme Diva & Forum Moderator
    Posted 6 months ago #

    I think you need to review Resetting_Your_Password.

  6. FlourishRT
    Member
    Posted 6 months ago #

    Thanks esmi but see above?

  7. esmi
    Theme Diva & Forum Moderator
    Posted 6 months ago #

    I did. Please review the page at the link I posted above.

  8. FlourishRT
    Member
    Posted 6 months ago #

    I carried out these instructions in phpmyadmin but if I select MD5 then enter password and save it doesn't save it? I have granted all permissions for the user

  9. esmi
    Theme Diva & Forum Moderator
    Posted 6 months ago #

    Then there must be an issue with your database. You must enter the new password using MD5.

  10. FlourishRT
    Member
    Posted 6 months ago #

    Any bright ideas? I have tried setting table specific privileges for wp-users to no avail. Am I going to have to create a new database then import my tables?

  11. esmi
    Theme Diva & Forum Moderator
    Posted 6 months ago #

    This has absolutely nothing to do with permissions for wp-users. You are, presumably, trying to edit this table as root, yes?

  12. FlourishRT
    Member
    Posted 6 months ago #

    No im editing it under my user I created

  13. esmi
    Theme Diva & Forum Moderator
    Posted 6 months ago #

    Why? Just edit the table as root.

  14. FlourishRT
    Member
    Posted 6 months ago #

    I'm really sorry but you have lost me here.
    How do I do this?
    I created a database, created a user and installed wordpress which has all been working perfectly.
    If I click on privileges I have my user and root as a user, do I need to edit privileges on root?

  15. esmi
    Theme Diva & Forum Moderator
    Posted 6 months ago #

    Root has full, god-like, privileges.

  16. FlourishRT
    Member
    Posted 6 months ago #

    When I click on wp_users in the table then browse as it says in the how-to I just have one option, the user I created. Is this right as I have no root here to edit?

  17. FlourishRT
    Member
    Posted 6 months ago #

    the password on there is an MD5 hash of my password???

  18. esmi
    Theme Diva & Forum Moderator
    Posted 6 months ago #

    In the db table? Yes.

  19. FlourishRT
    Member
    Posted 6 months ago #

    I have no idea what id happening. Password is correct as checked it on MD5 hash creator. For testing purposes I created a new database and user, added a new site, pointed MAMP Apache to the new root and I get the same,

    Not Found

    The requested URL /wordpress/ was not found on this server

    Think I need to look at it with fresh eyes tomorrow....

  20. esmi
    Theme Diva & Forum Moderator
    Posted 6 months ago #

    the requested URL /wordpress/ was not found on this server

    That has absolutely nothing to do with your WordPress login.

  21. FlourishRT
    Member
    Posted 6 months ago #

    Well im stumped then.
    It all happened when I tried to create a new wordpress site.
    All I did was add the folder to htdocs then skipped back to my other site to check something. First the images and CSS changed then got that error.
    MAMP servers working ok and pointing to right folder, database still there all present and correct but I get nothing?

  22. FlourishRT
    Member
    Posted 6 months ago #

    okay, somehow im back in business. I changed the root back to http://localhost:8888/ and the site came up sans CSS. Changed it in MAMP to /Applications/MAMP/htdocs/ and it asked me to choose the instance et voila.

    Sorry for wasting your time esmi and many thanks for your help and patience.

Reply

You must log in to post.

About this Topic