WordPress.org

Ready to get started?Download WordPress

Forums

Can't login to admin after weird Warning messages (3 posts)

  1. thebradmiskell
    Member
    Posted 4 years ago #

    Suddenly can't log in to site admin.

    I was working with some php code that called tweets--got it working--when weirdness started. I would UPDATE a php file in APPEARANCES/EDITOR in my site admin, and started getting the message:

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/s/o/l/soldiersadmin/html/wordpress/wp-content/themes/Cirque/functions.php:22) in /home/content/s/o/l/soldiersadmin/html/wordpress/wp-admin/theme-editor.php on line 75

    It was intermittent at first. I tried removing what I had done but started getting message anytime I tried to UPDATE any file. Meanwhile, the site (build version at http://soldierstothesummit.org/wordpress) works fine.

    I thought maybe my computer was just sending weird code so rebooted and now get the above message when trying to log in to admin. I can't login now.

    Help, please...

    Brad Miskell

  2. Kim09
    Member
    Posted 4 years ago #

    Hi,

    That happened to me too, disable plugins, and delete the Cirque themes in your cpanel.
    I hope that will help, let me know.

  3. Shane G.
    Member
    Posted 4 years ago #

    Hi,

    It is usually due to spaces, new lines, or other garbage at opening/closing PHP file <?php tag or after a closing ?> tag in wp-config.php. It can be other file too so need to check error message as it may list file name where the error occurred.

    You can either upload error file from the backup or edit erroneous file. To edit the file one need to check below mentioned points:

    1. Download the file mentioned in the error message.

    2. Open that file in a plain text editor

    3. Check that the very first characters are <?php

    4. Check that the very last characters are ?>

    5. Place the cursor between the ? and >

    6. Now press the DELETE key on your computer and keep that key pressed for at least 15 seconds.

    7. Now type > and

    8. Save without pressing any other key at all.

    That’s it!

    Thanks,

    Shane G.

Topic Closed

This topic has been closed to new replies.

About this Topic