WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Can't login - just redirects to login screen (8 posts)

  1. CyberMama
    Member
    Posted 10 months ago #

    Hi - tried to login to my WordPress site this morning only to find that when I log in as usual, it simply redirected me to the login screen but not ever the admin backend.

    This also happened with an install in a subdirectory of the same domain, except in this case, logging in caused it to default to a search page on the root domain, saying there is no such page.

    I have tried the following this morning:
    - disabling plugins
    - clearing caches
    - re-uploading from fresh install
    - deleting .htaccess (this caused complete breakdown of site)
    - investigating database
    and many other things as well.

    My hosts are apparently looking into it but always use the 'wordpress is a 3rd party application' to get around actual support.

    If anyone has any fresh ideas, I'd be most appreciative as at the moment I can't access my admin area at all. Thanks

  2. esmi
    Forum Moderator
    Posted 10 months ago #

    Many hosts experienced problems due to mass attacks recently and may have limited access to wp-admin and/or wp-login.php as a result. Your hosts may be one of them. Try contacting them about it.

  3. CyberMama
    Member
    Posted 10 months ago #

    Hi esmi,

    Have checked with hosts. They say no, nothing, nada wrong at their end.

    Fact that site loads from front end and works properly suggests no database issue... just thing login thing???

  4. esmi
    Forum Moderator
    Posted 10 months ago #

    No - it could still be a database issue. Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading all files & folders - except the wp-content folder and wp-config.php & root .htaccess files - from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

  5. CyberMama
    Member
    Posted 10 months ago #

    Have done ALL the above.

    Plugins deactivated by FTP - renamed folder pluginsxx.

    Re-uploaded all files from freshly downloaded version of WordPress after deleting existing (as if performing an upgrade manually).

    I have another WP site that is on an addon domain for this site. I can still access that one fine...

  6. Justin
    Member
    Posted 10 months ago #

    I would elsewhere other than your site. I would start with the little things first. Check to make sure your cookies are enabled. I can recreated a login page redirect simply by disabling my browser cookies.

    If you have a top notch antivirus I would also make sure that it is not hijacking your browser and blocking cookies as well.

  7. CyberMama
    Member
    Posted 10 months ago #

    Hi Justin - thanks. I've cleared the cache of 2 different browsers (safari and firefox) and the problem still occurs.

    I'm on a mac so no antivirus as such...

  8. CyberMama
    Member
    Posted 10 months ago #

    Fixed (so far so good)... after spending hours yesterday trying *everything* and telling the hosting co to check their server etc. it *mysteriously* all came back to life...

    So, my thinking - was the host after all - probably server firewall blacklist or similar. Unbelievable.

    Subsequently, backing up now with a view to moving hosts! ;)

    Thanks to everyone who posted a suggestion.

Reply

You must log in to post.

About this Topic