WordPress.org

Ready to get started?Download WordPress

Forums

Can't login after upgrade WP 3.4 (21 posts)

  1. sir mao mao
    Member
    Posted 2 years ago #

    Hello~

    I just upgrade my 2 sites and 1 of the site have no problem but the important one has.

    After I update WP 3.4 version through WP, it brought me to another page said:

    Database Update Required

    WordPress has been updated! Before we send you on your way, we have to update your database to the newest version.

    The update process may take a little while, so please be patient.

    So I click the icon but the page don't refresh.
    I've followed other suggestion...put all pluging on "hold", reupload WP-admin and wp-include still can't get to my dashboard.

    Please help me... :( I use my site everyday for my small business, can someone suggest what should I do? plss.....

    Thank you

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    Try:
    - switching to the Twenty Eleven theme by renaming your current theme's folder inside wp-content/themes and adding "-old" to the end of the folder name using FTP or whatever file management application your host provides.

    - resetting the plugins folder by FTP or phpMyAdmin.

    - re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress.

    - running the upgrade manually via wp-admin/upgrade.php

  3. sir mao mao
    Member
    Posted 2 years ago #

    Tried...it still not working.
    The page still showing the same message; asking me to update WP database but nothing loaded after I click the "update" icon.

    I have an IT guy helping me do all suggestion..but seems like WordPress is having database issue.

    Any other solution? -_-

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    Have you tried repairing your database? Do you have a recent database backup that you could restore?

  5. sir mao mao
    Member
    Posted 2 years ago #

    Yes, I am restoring atm... Im afraid to upgrade to 3.4 now... -_-

    Strangely, my other site (which under same domain) has no problem at all.

    So, if I want to update to 3.4, should I do it manually? Just like the procedure you mentioned 9upload all files except wp-content?
    thanks~

  6. esmi
    Forum Moderator
    Posted 2 years ago #

    my other site (which under same domain) has no problem at all.

    I'm afraid that doesn't really mean a thing. It could still be a database issue. Or a theme, plugin or server issue. Any or all of these could create your current problem.

    should I do it manually?

    You can certainly try. See http://codex.wordpress.org/Updating_WordPress#Manual_Update for the full instructions

  7. sir mao mao
    Member
    Posted 2 years ago #

    Tried....*sigh* Still not working.

    My other site : http://www.ruruvictoria.com is under same server, I have no problem with automate update.

    My other http://www.sirmaomao.com has problem. Both sites has same theme, same plugins same settings. Both are actually identical but I don't know why I can't complete the 2nd site.

    BTW, I disabled all plugins before I upgrade, but still seeing "Database Update Required" message and nothing loads after I click it.

    Please help... I've been restoring my site for 5 times now...lol

  8. esmi
    Forum Moderator
    Posted 2 years ago #

    Did you try repairing your database?

  9. sir mao mao
    Member
    Posted 2 years ago #

    No, There is no error message displaying database error.
    I am having the same problem with few other members in the forum, WP 3.4 couldn't update database after installation.

    My other blog was under same server, same ftp domain folder had no problem. Every time I do restore, I had to upgrade the other site (ruruvictoria.com) again. At least I did 5 times of automatic upgrade to 3.4...no problem whatsoever.

    :(

  10. esmi
    Forum Moderator
    Posted 2 years ago #

    Then you have confirmed that this is site specific.

  11. starapple
    Member
    Posted 2 years ago #

    This member had the same database issue while upgrading on GoDaddy server. http://wordpress.org/support/topic/upgrade-will-made-you-upset?replies=39

    Does WP 3.4 require a specific version of MySQL?

  12. esmi
    Forum Moderator
    Posted 2 years ago #

    @starapple: It is impolite and contrary to forum policy to interrupt another poster's ongoing thread with a question of your own. Please post your own topic.

  13. sir mao mao
    Member
    Posted 2 years ago #

    Hmm... not sure.. but I will take a look which plugin is preventing WP database upgrading.

  14. MatWitts
    Member
    Posted 2 years ago #

    GO HERE:-

    http://www.clickonf5.org/2247/solution-database-upgrade-required/

    if that doesn't work also check your memory_limit in your hosting PHP config.

  15. starapple
    Member
    Posted 2 years ago #

    @esmi, I appreciate your help to me and others. I think that there is more impoliteness in your rushing sometimes to determine what is appropriate. I have not introduced any new topic but having been following the various threads of the apparent problems related to the 3.4 upgrade have just noted that someone else had a similar experience and wondered - in seeking solutions - whether there is a connection to the version of MySQL being used. Unless of course you think that there is only one way to approach what appears a widespread issue.

    Now, I note that more than one GoDaddy-hosted person has issues. Would it be impolite to query whether the fact that different versions of MySQL my be in use, even by two sites on the same physical server, could be a contributing factor? GoDaddy seems not to host MySQL on the same servers as the sites, meaning creating to DBs within two minutes of each other could mean different circumstances. The suggestion in the help so far is that there is no problem with the new WP code but with other environmental issues.

    I won't be doing the upgrade until there seems to be some stability.

  16. tomsavoca
    Member
    Posted 2 years ago #

    We had this problem and just solved it! Open the PHP file version.php which is located in wp-include folder of your wordpress blog, and check the field $wp_db_version. It should be equal to the db_version of WP_Options table. For more detail, read http://www.clickonf5.org/2247/solution-database-upgrade-required/

  17. sir mao mao
    Member
    Posted 2 years ago #

    I don't know how to find out the version from WP-option, I read at least 10 times from the link that someone posted, but since I'm not an IT person, it's really hard for me to determine which line is which and where should I add in WP Database.php page.

    Will WP Team going to release some update for WP-Database anytime soon?

    Thank you~

  18. TheRealBTRusher
    Member
    Posted 2 years ago #

    The solution solved my problem with the updating databases but my whole site is still broken. My backend is empty and pages aren't showing after removing the .maintenance file so my update must have stopped somewhere halfway. I am about to restore a backup of my site and attempt to update mannually. I suggest you do the same.

    With regards to the solution. What you do is (I'm assuming you found WP-options) search for "db_version" under the option_name column (use <ctrl><F>) and look at the option_value value. I am assuming it will be 19470 (this is the 3.3.2 version number). The co to wp-content, version.php and change the db_version value to 19470 from 20596 (3.4).

  19. TheRealBTRusher
    Member
    Posted 2 years ago #

    I also recommend running the automatic update for the Twenty Eleven Theme and then the other plugins (after!!!). Do not even try to install the WP update automatically again.

    I don't know what to do if you don't have a backup. There seems to be so many strange changes to the files to the files in our FTPs. Luckily the database seems untouched because the version stayed the same.

    WordPress please come up with a solution to this...

  20. TheRealBTRusher
    Member
    Posted 2 years ago #

    Looks like the manual update should have been fine based on how it is done...

  21. zodiax
    Member
    Posted 2 years ago #

    at the new version there is no wp-register.php. upload it from the old version to the new versions home directory.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags