WordPress.org

Ready to get started?Download WordPress

Forums

Can't login after upgrade to 2.3 ERROR; WordPress requires Cookies but ... (113 posts)

  1. DeadRobot
    Member
    Posted 6 years ago #

    Basix fixed worked for me. I had changed the directory folder name and wasn't able to log in. Thanks!

  2. funkster
    Member
    Posted 6 years ago #

    I've just downloaded the latest version of 2.3 and have these problems too. Tried all the suggestions but to no avail. I'm amazed WP still haven't fixed it.

    Where can I get an older more stable version of WP from?

  3. Milo
    Member
    Posted 6 years ago #

    I've had the same problem on a clients site, solved it with removing the permalink option in the htaccess file.

  4. mike
    Member
    Posted 6 years ago #

    I had this problem and had to delete the wp-contact-form plugin, log-in and then re-install. What could a plugin do to break this login system?

  5. detted
    Member
    Posted 6 years ago #

    So far nothing has worked for me. I tried every trick that I can find on the web. One of recipe I tired worked for one night. It didn't work the next morning. It has nothing to do browsers. I tired the latest IE, FireFox and Opera. I have two WP blogs on the same host. They both have been working well for a long time. I upgraded one to 2.31 which is not working now. The other one is running fine with the old 2.1. Since there isn't any change made, the configuration doesn't play a role here.

    With a "www" or not before the web address makes different to the 2.3.1 not working site. With 2.1, with or w/o "www" both works fine. Thus it points to the issue with WP 2.3.1. Will really appreciate if anyone can help.

    There has been so many sites with the issue. Have a look at search:

    http://search.yahoo.com/search;_ylt=A0geu9jiIaFHm3MByJml87UF?p=WordPress+requires+Cookies+but+your+browser+does+not+support+them+or+they+are+blocked.&ei=UTF-8&iscqry=&fr=sfp

  6. logicalemotions
    Member
    Posted 6 years ago #

    POSSIBLE SOLUTION. Whenever I see this error now, I have a plugin that is conflicting somehow. This process works for me every time and hasn't let me down:

    1. FTP or file manager to /wp-content
    2. rename /plugins to /pluginX (or whatever)
    3. goto http://www.blogname.com/wp-admin/ in browser
    4. login (you should be able to now)
    5. rename /pluginX (or whatever) back to /plugins
    6. in browser, goto PLUGINS via admin
    7. select DEACTIVATE ALL PLUGINS at bottom of plugins list
    8. begin activating plugins one at a time to see what errors out
    9. when a plugin errors out either delete it via FTP, or find an upgrade if available - if no upgrade, leave deleted and see if blog functions correctly without it

    Really, once you've identified the plugin that is causing the error you either have to upgrade it or leave it off the blog. Sux I know and I've been through this with every damned update so far (just had to do it to discover WP.com Stats plugin when I upgraded to 2.3.3...).

    Tully
    http://www.tully.ca

  7. sandrapan
    Member
    Posted 6 years ago #

    I am having the same issue everyone is having. I've tried the patch, i've tried commenting out the 24,313,314 lines and nothing seems to be working for me. The frustrating part is i don't know what caused this. I last recall in my control panel changing some wording for the blog (that wasn't going to affect my server or anything major) and next thing it is not working. So i have reinstalled my wordpress 2.3.1. Then went to the http://example.com/blog/wp-admin/install.php site to activate. It says i already have a DB. I am afraid of deleting my DB, afraid i'll lose my comments. Right now i've lost my pictures because of the install, my comments look like they are still there though. This is quite frustrating because the more i try and fix it, the more i break it.

  8. sandrapan
    Member
    Posted 6 years ago #

    hey everyone, soon after i posted, i got my site working again!!
    I used the wp-login.php that ryan suggested, i put the patch , sitecookie.diff in the directory right under blog (blog is in subdirectory) and it's working!!

  9. davec00lman
    Member
    Posted 6 years ago #

  10. bbowen55
    Member
    Posted 6 years ago #

    I've tried everything in here. Im still haveing this cookie problem as well. I originally had it installed in a subdirectory, so I deleted the database and all wpmu files and did a fresh installed in root. I even tried the one about posting a comment on the first post. Problem still there.

    Installing to a local ubuntu 6.06.2 server. WPMU 1.3.3

    No firewalls on this side of the LAN between me and the server.

  11. bbowen55
    Member
    Posted 6 years ago #

    Ok, so I've done all sorts of things.. differant names for the subdirectory... chown to www-data on everything and chmod 777 on everything... thinking maybe it was a rights thing. Nope.

    What finally worked was during the setup, I put in the IP address of the server instead of the DNS name. When i first put in the DNS name everything seemed to work fine... except of course the inability to login to wp-admin because of cookies. Switching to the IP address fixed the problem.

    So I can still use the DNS name in a link to the site because it resolves correctly to the IP. But then WordPress changes the URL from the DNS name to the IP. This works for me because its an intranet site and not available to the public.

    Hope that helps someone else out there.

    EDIT: Oh yeah, one other tid bit. Before I reinstalled with just the IP in the server name. I COULD login to wp-admin without a cookie error using Konqueror on the actual webserver.

  12. johanbenjaminsson
    Member
    Posted 6 years ago #

    I had the same problem and just wanted to share my solution. My text editor set all documents to UTF8 by default and for some reason wordpress din't like that. when i changed backed every single F-ing document to ANSI all worked like a charm. To change the encoding format for a document, look in your text/html -editor for fomat and set it to ANSI.

  13. LanceGrigsby
    Member
    Posted 6 years ago #

    WP folks, what's the status on this??? This seems like a big deal. I'll add my name to the list of users who got burned by the update. I tried many of the suggested fixes listed in this forum but with no success. I finally had to restore via backup with all my old 2.2 files ... I have to say this is the only negative experience I've had with WP, so I hope we can resolve this one.

    Interestingly, a colleague of mine who updated her own personal WP site to 2.3 had no problems, but she updated hers using her host's WordPress "wizard" to install the files automatically. Sounds like most folks in this forum who've had problems installed the update directly via FTP.

  14. aldp
    Member
    Posted 6 years ago #

    Just installed WordPress for the first time - latest 'stable' version per the download page (2.3.3?).

    I can log in using a Safari browser to Admin account or other test user accounts. But I can't do this via Internet Explorer - i'm getting the error that many are seeing on this thread 'ERROR: WordPress requires Cookies but your browser does not support them or they are blocked.'

    I find it very strange that IE has this problem but not Safari - any ideas?

    Thanks in advance.

  15. aldp
    Member
    Posted 6 years ago #

    Just thought I would try Firefox too - this works with no problems.

    Should have said that I have also found the whitespace problem mentioned in this thread i.e. an extra line at the end of the php file. I have deleted that and re-uploaded that file. Again - not working.

    So frustrating......

  16. pepijndevos
    Member
    Posted 6 years ago #

    hi, i had a problem like this to.
    my solution was to go to phpMyAdmin, and go to option, and check your site adres an blog home are correct.
    mine had index.php appended, also my stylesheet was linked to http://example.com/index.php/wp-admin/wp-admin.css?version=2.3.3 and cookie path was /index.php/

    i am sure this whole problem has something to do with the coockie path...

  17. PetiteMenagerie
    Member
    Posted 6 years ago #

    Editing siteurl and home with phpMyAdmin worked for me too, when all of the various other fixes did not.

    WP had appended /wordpress to the end of my url and homepage, maybe because I had it in a subdomain.

    Good luck, folks.

  18. corpvid
    Member
    Posted 6 years ago #

    You are all talking programming code, and I do not understand it. I'm not a computer programmer and would be very uncomfortable adding or removing code from a file. I know how to change text in a text editor for my website, but that is about it. I need some really basic step by step assistance.

  19. TaoGem
    Member
    Posted 6 years ago #

    I was having this problem and used logicalemotions method in above post that talks about renaming plugins etc...

    1. FTP or file manager to /wp-content
    2. rename /plugins to /pluginX (or whatever)
    3. goto http://www.blogname.com/wp-admin/ in browser
    4. login (you should be able to now)
    5. rename /pluginX (or whatever) back to /plugins
    6. in browser, goto PLUGINS via admin
    7. select DEACTIVATE ALL PLUGINS at bottom of plugins list
    8. begin activating plugins one at a time to see what errors out
    9. when a plugin errors out either delete it via FTP, or find an upgrade if available - if no upgrade, leave deleted and see if blog functions correctly without it

    I did get to log in but the plug ins all seem fine after running through his steps.

    Not sure as of yet if all is well, but did get to log in!

    Now on to all the other problems with the blog today!

  20. TaoGem
    Member
    Posted 6 years ago #

    Can someone comment on what it might mean that I have to use the above steps that call for renaming my wordpress ecommerce plugin each and every time that I now want to log into my wordpress admin panel? It gets me in, but not completely fixing the cookies issue.

    I am thinking about removing the ecommerce plug in completely and upload it again from scratch.

    My concern is if it will effect my products and product categories that I have in there now?

    Help?

  21. TaoGem
    Member
    Posted 6 years ago #

    This was a final fix for me.

  22. aldp
    Member
    Posted 6 years ago #

    After upgrading to WP2.5 - still had the same problem.

    Tried the database table edit described above (using the phpAdmin interface).

    The editing of the database variable 'siteurl' - did not stop the issue.

    The editing of the database variable 'home' stopped my blog working (i.e. loading at all in a browser).

  23. Michael Goitein
    Member
    Posted 6 years ago #

    Please forgive me if this is an uninformed post; I'm focusing more on the white screen of death on the admin than on anything else. Not sure if it comes down to cookies or not, although this is how I was able to track this down and fix it. It appears to have something to do with whether you have PHP 4 or 5 installed.

    Following the instructions here to the letter:

    http://michaeldoig.net/4/installing-mamp-and-wordpress.htm

    I got this to work fine.

    When I tried to follow different directions (although also quite good):

    http://www.bleikamp.com/2006/11/16/wordpress-on-a-mac/

    I got the white screen of death. The only difference in the installation was choosing PHP 4 or 5 (you have to choose 4 as of this writing).

    Hopefully, for those of you for whom the "final fix" above did not work, this will work fo you & help avoid the hours of frustration you may have run into.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags