WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Can't Login after PHP & MySQL update (17 posts)

  1. verbob
    Member
    Posted 7 months ago #

    WordPress v3.7.1

    My host recently updated PHP and MySql to:
    PHP - 5.4.22
    MySQL - 5.5.32

    Website works fine, but getting a white screen after clicking "Log in" on the wp-login page

    When I view the 'source' code of the white screen, its a single character - a period "."

    I have tried renaming all but the default theme. result - ENTIRE site is a white screen.

    I tried renaming all the plugin folders. No help.

    Any other suggestions? Would the changed versions of PHP/MySQL be the cause of this?

  2. Sandeep
    Member
    Posted 7 months ago #

    Renaming won't work. WordPress looks at the files inside the folder. For themes it looks at style.css, for plugins it looks at pluginname.php

    Make the plugins folder not readable, chmod to 000

    Check if the login page comes up

    If not, go to themes, make your default theme folder not readable, chmod 000 the directory of your current theme. This will make WP revert to the default theme.

    Try setting debug mode as true for wordpress and see what comes in your debug log file.

    http://codex.wordpress.org/Debugging_in_WordPress

  3. quickbeforeitmelts
    Member
    Posted 7 months ago #

    I am having the exact same issue, although I'm no where near as tech savvy to understand how to make this fix work.

    After updating the database through my host, I can no longer log in through the admin page; once I do I get a blank white screen. I can get into some of the admin section by clicking the Edit button on one of my blog posts, but the second I try to make a change (like disable all plug-ins), I get the blank white screen again.

    I am afraid of making a bigger mess of this than it already is.

    Any help??

  4. WPyogi
    Volunteer Moderator
    Posted 7 months ago #

    You need to use FTP or Cpanel to deactivate your plugins and possibly the theme - find the files on the server and rename them:

    wp-content
         plugins.HOLD

    If that does not work, rename your active theme:

    wp-content
         themes
            your theme currently in use.HOLD
  5. quickbeforeitmelts
    Member
    Posted 7 months ago #

    I renamed the plug-ins folder as was able to log in. Found another support article that suggests copying the plug-ins one by one to a new folder and see which is causing the issue. That sound like a good plan of action?

  6. WPyogi
    Volunteer Moderator
    Posted 7 months ago #

    Yep, excellent plan :)!

  7. quickbeforeitmelts
    Member
    Posted 7 months ago #

    I've found a php file in my original plug-ins folder that's named index.php; when I open it with Espresso to read it, the only gthing in it is:

    <?php
    // Silence is golden.
    ?>

    It's date is 3/8/2012.

    This seems a little sketchy to me.

  8. esmi
    Forum Moderator
    Posted 7 months ago #

    That's perfectly OK.

  9. quickbeforeitmelts
    Member
    Posted 7 months ago #

    I've just finished importing each plug-in one by one to the new folder, and everything is still working fine. Thanks for your support and help through this!

    I hope this helps others navigate this upgrade, too.

  10. verbob
    Member
    Posted 7 months ago #

    Glad you got it resolved. And thanks for hijacking my thread LOL.

  11. verbob
    Member
    Posted 7 months ago #

    Ok...

    Disabled all plugins - no change
    Disabled active theme - got white screen on main site as well

    Enabled Debug mode - only showed a deprecated function (something about sidebar on main site, which irrelevant on admin panel. no errors/warning about admin panel)

    And by the way, I DO get the login page, just goes to white screen when I enter credentials and click "log in"

  12. Michael Mann
    Member
    Posted 7 months ago #

    Have you checked your theme's functions.php file to make sure there are no empty spaces at the top or bottom of that file? Check wp-config.php in the main WP folder as well.

  13. verbob
    Member
    Posted 7 months ago #

    Ok, just did that. No spaces there in the themes functions.php

    HOWEVER - in the WP-Config file, there is no "?>" at the end... (to note: there isn't one in the 'sample' config file either, is that normal?)

    added it, but no difference

  14. WPyogi
    Volunteer Moderator
    Posted 7 months ago #

    Disabled active theme - got white screen on main site as well

    Do you have a default theme in the themes folder? You should always have the current default theme (unmodified).

  15. verbob
    Member
    Posted 7 months ago #

    Yes. I even re-uploaded that entire theme folder from a fresh download of 3.7.1

  16. WPyogi
    Volunteer Moderator
    Posted 7 months ago #

    Have you tried replacing all files and folder EXCEPT wp-content, wp-config and .htaccess from a fresh download of WP. Be sure to delete the old versions before replacing with the new ones.

  17. verbob
    Member
    Posted 7 months ago #

    I tried that. Didn't work...

    BUT - put in a support ticket with hosting, turns out the recent PHP/MySQL upgrade had caused similar problems server-wide, so they made some adjustments on their end and all is well.

    Thanks to all for the help and suggestions

Reply

You must log in to post.

About this Topic

Tags

No tags yet.