WordPress.org

Ready to get started?Download WordPress

Forums

Can't login after Multisite install, maybe I don't need it? (21 posts)

  1. tkjaros
    Member
    Posted 2 years ago #

    Get ready for a long description of my problem. At the end will be a clarification of my desire for Multisite, but perhaps I don't need it if someone could tell me a better way to get what I want.

    Here's the short of it: I can't log into my site after I enable multisite.

    Here's the long of it:
    I have previously installed Multisite, but played chicken with it and reverted back to the regular way. Instead of uninstalling I restored from a backup. Now I'm ready to try again because I want users to have their own blogs--preferably in conjunction with their buddypress profiles (which I could use some help also figuring out).
    I've followed all of the standard procedures.

    1. define('WP_ALLOW_MULTISITE', true);

    2a. Go back to Settings>Network

    2b. (Initially there was a warning description that said "warning: an existing wordpress network was detected." However, I think I solved that problem by deleting this (from the wp_db file in FTP under wp-includes):

    * List of Multisite global tables
    	 *
    	 * @since 3.0.0
    	 * @access private
    	 * @see wpdb::tables()
    	 * @var array
    	 */
    	var $ms_global_tables = array( 'blogs', 'signups', 'site', 'sitemeta',
    		'sitecategories', 'registration_log', 'blog_versions' );
    
    	/**
    	 * Multisite Blogs table
    	 *
    	 * @since 3.0.0
    	 * @access public
    	 * @var string
    	 */
    	var $blogs;
    
    	/**
    	 * Multisite Blog Versions table
    	 *
    	 * @since 3.0.0
    	 * @access public
    	 * @var string
    	 */
    	var $blog_versions;
    
    	/**
    	 * Multisite Registration Log table
    	 *
    	 * @since 3.0.0
    	 * @access public
    	 * @var string
    	 */
    	var $registration_log;
    
    	/**
    	 * Multisite Signups table
    	 *
    	 * @since 3.0.0
    	 * @access public
    	 * @var string
    	 */
    	var $signups;
    
    	/**
    	 * Multisite Sites table
    	 *
    	 * @since 3.0.0
    	 * @access public
    	 * @var string
    	 */
    	var $site;
    
    	/**
    	 * Multisite Site Metadata table
    	 *
    	 * @since 3.0.0
    	 * @access public
    	 * @var string
    	 */
    	var $sitemeta;
    
    /*
    	 * Global and Multisite tables
    	 */

    That is to say, once I deleted this, the red warning was gone.

    3. I turned off all my plugins.

    4. The Multisite setup said I must use subdomains, since the install isn't new. However, I want subdirectories (so I figured I'll do an override after the install works).

    5. I choose against the WordPress recommendation to take out the "www" from the site url.

    6. I created the blogs.dir folder in wp-content.

    7. I placed this in configure.php, right below 'multisite allow, true' line:

    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'www.realclearapologetics.com' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );

    8. In the .htaccess file I placed:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]

    9. I saved all the files and go to click "Once you complete these steps, your network is enabled and configured. You will have to log in again. Log In"

    10. I am taken to "http://www.realclearapologetics.com/wp-signup.php?new=www.realclearapologetics.com"

    I've tried clearing the cookies and cache. I don't have any sites that are redirected.

    So, I'm not sure if the problem is caused by the prior installation or something new. I tried to figure out the prior installation with all the forum talk on database and deleting tables that were brought in by Multisite, but I'm not sure if I did it correctly. I could really use a detailed step-by-step answer (i.e., tell me the name of the file in my FTP and what to look for in that file).

    To recap: I tried installing and received this url: http://www.realclearapologetics.com/wp-signup.php?new=www.realclearapologetics.com

    It doesn't even give me the option to login, so there is no place to put my username or password.

    End goal: The purpose for me trying to figure this out is so that on BuddyPress users can have their own blog. As it currently stands, users can post from the frontend of the site (which I like). However, they can't edit posts and they don't really have their own page, just a collection of their posts at http://www.realclearapologetics.com/blog/username .

    Also, the only way I could get everybody to have the nice permalink of .com/blog/username is be sacrificing the way I want permalinks to look for the other non-social networking sections of the site when an admin posts. This is why I figured Multisite would be good. Am I wrong for thinking this or is Multisite exactly what I need? If I do Multisite, I figured I'd have two sites, the main site where I place my own content and can do my own thing, and then the second site would be just the social network where people can blog and debate worldviews (www.realclearapologetics.com/citygates). But perhaps multisite isn't the way to do this.

    [Edited for readability - Mods.]

  2. It's probably a missmatch in settings.

    Undo Multisite.

    Before you add it back in, go to Settings > General Settings.

    Change both your home and site URLs to be http://realclearapologetics.com (no www, there's a reason, it can often cause the problem you're seeing).

    Now try Multisite again.

  3. tkjaros
    Member
    Posted 2 years ago #

    Negatory.

    Received this URL (same as before but without the www.):

    http://realclearapologetics.com/wp-signup.php?new=realclearapologetics.com

    Also, when I undid the configure.php and .htaccess codes, changed the URLs, and redid the first step for allowing multsite as true, the Network Settings page had that same red Warning: "warning: an existing wordpress network was detected." So I had to go back into the wp-db file and delete the same stuff I did before so the red warning would go away. Am I doing that correctly?

  4. Yes, you did that correctly :)

    realclearapologetics.com loads as expected... if really slow.

    realclearapologetics.com/wp-admin also loads, correctly redirecting to realclearapologetics.com/wp-login.php

    Are you only getting the error after logging in?

  5. tkjaros
    Member
    Posted 2 years ago #

    I can't re-login once I install multisite.

    The site loaded faster when it was at the www. URL

  6. The site loaded faster when it was at the www. URL

    Unlikely (seriously, unless your server's screwed up, there's no difference).

    I can't re-login once I install multisite.

    I need a little more clarification :)

    I can get to the pages. So I'm assuming you mean "When I try to log in, it gives me that error after I click 'log in' instead of taking me to wp-admin."

    Is that right?

  7. tkjaros
    Member
    Posted 2 years ago #

    First, thanks for your willingness to help me. haha

    Second,
    "I need a little more clarification :)
    I can get to the pages."

    You can only get to the pages because when the relogin doesn't work, I delete/uninstall Multisite from configure.php and .htaccess to revert back to normal. Then I reactivate all the plugins and I'm back to the way it was.

    More clarification: So, after I install multisite (which appears to work given that the red warning shows up when I try again), I click the button to re-login (since that is required according to the instructions from the network settings page (which I did not refresh but just left open while I did the code changing).
    So once I click to relogin it sends me to that signup page. However, there is nothing there. My browser tells me it is a page that will never load.

    Would you like me to install multisite so you can see how the site is completely down (since I deactivate my plugins, because I use buddypress as my theme)?

  8. Ah, okay, that helps.

    Do you know how to edit your database?

    I'm thinking we should look at wp_sites and wp_sitemeta to see how your site URL is saved there.

  9. tkjaros
    Member
    Posted 2 years ago #

    So, I'm not exactly sure where the database is located. When I was doing research on these forums I just started searching through my public_html file in bluehost. I came across the wp-db file in wp-includes. I saw in wp-db the names that Andrea Rennick suggested (to some other user) in another thread to delete. So I went through and deleted that long list of code in my first comment here.

    Maybe I'm in the wrong place for the database?

  10. tkjaros
    Member
    Posted 2 years ago #

    Short answer: No, I don't know how to edit the database. haha

  11. wp_bh_fan
    Member
    Posted 2 years ago #

    On Bluehost or any other cPanel host, you can use phpMyAdmin. You click the icon and then select the database on the left. Then the database tables appear and you can select which one to look at. However, don't go changing things unless you absolutely know what you're doing, as this can cause larger issues than you want/need. This might help: http://www.siteground.com/tutorials/phpmyadmin/ I just found it on a quick google search, which you might do to find out more about phpmyadmin. Good luck!

  12. . I came across the wp-db file in wp-includes. I saw in wp-db the names that Andrea Rennick suggested (to some other user) in another thread to delete.

    Yeah that was the wrong way to delete them :)

    You probably never fully deleted it. Go in via phpMyAdmin and delete the tables Andrea mentioned. Then reinstall WP cause editing anything in your WP install is a bad idea ;)

  13. tkjaros
    Member
    Posted 2 years ago #

    Okay, so I deleted the database through the phpMyAdmin feature.

    I tried redoing everything and the same problem came up.

    This URL is from the devil: http://realclearapologetics.com/wp-signup.php?new=realclearapologetics.com

    It says, "The page isn't redirecting properly
    Firefox has detected that the server is redirecting the request for this address in a way that will never complete."

    Again, to my knowledge, I don't have any websites redirecting here.

    So, why is it that realclearapologetics.com/wp-login.php is redirecting to that other URL?

    Mika, how would I do a reinstall of WP? (Sorry, I'm very beginngerish.)

  14. tkjaros
    Member
    Posted 2 years ago #

    Now this is interesting:

    When I change
    define( 'SUBDOMAIN_INSTALL', true );
    to
    define( 'SUBDOMAIN_INSTALL', false );

    (which is what I want to ultimately do)

    it reads, "Error establishing database connection."

    I don't know if that means anything.

  15. tkjaros
    Member
    Posted 2 years ago #

    Mika, in phpMyAdmin, it seems I have two databases. Is that standard?

    realcle2_wrd1
    realcle2_wrd2

    Or is that perhaps because I previously installed multisite as subdirectories and hence, why I received this non-highlighted comment: "Because your install is not new, the sites in your WordPress network must use sub-domains. The main site in a sub-directory install will need to use a modified permalink structure, potentially breaking existing links." ?

    If I had to make a guess, it looks like #2 is a bunch of plugin stuff.

    Also, #1 was where the tables were that Andrea suggested to delete (and I deleted them and haven't had the red warning pop back up).

    Thanks for your help, guys!

    small UPDATE: I found how to reinstall WordPress from Bluehosts's C-panel. However, I want to be sure I won't lose any of my content. I've already got 30 people signed up for buddypress on my site and I'd hate to have to redo all the content I put up. Any way to reinstall without losing the content and users?

  16. Do not. Use. Bluehost's. Tool.

    (Nothing against bluehost, but you're running multisite, you need to roll up your sleeves and get into the files).

    Okay.

    You should only have one database. Go into your wp-config.php, and figure out which one you're actually using.

    If #1 is where you deleted the tables, then that's probably the one you're using.

    Get yourself back to square one, where all you have is a single install, okay? Are we there?

  17. tkjaros
    Member
    Posted 2 years ago #

    #1 it is! I can see it in the config file.

    We're on a single install. And my plugins are currently all deactivated.

    What's next?

    (Btw, the next instructions are on how to do a clean, new install of WP, right? Cause I still don't know how to do that and I fear that me doing something will royally screw up my site, haha.)

  18. If you don't know how to do an install, on your own, of WordPress, you're going to be in a world of hurt with Multisite. Multisite is WP on steroids. It's bigger, stronger, and harder. You have to master how to edit files and your DB before you do this stuff. It's like trying to high-dive before you learn how to swim in the deep end.

    Okay.

    Add define('WP_ALLOW_MULTISITE', true); into your wp-config again.

  19. tkjaros
    Member
    Posted 2 years ago #

    Done. I've never had a problem with that.

    (Again, shouldn't I do a clean install of standard WordPress before trying to install Multisite again?)

  20. @mercime
    Volunteer Moderator
    Posted 2 years ago #

    Yup. Do a manual installation i.e., not using a webhost script.

  21. tudec1
    Member
    Posted 1 year ago #

    Did you get the problem fixed?

    I ran into the same issue. Here's what worked for me:

    I went into wp-config.php and changed SUBDOMAIN_INSTALL from "false" to "true" (without quotes, obviously).

    For some reason, this let me login to my /wp-admin/ again. But then I could only add new sites as subdomains, and I want subdirectories. So I went back to my wp-config.php file, changed SUBDOMAIN_INSTALL back to "false" again, re-logged in, and magically -- everything now works.

Topic Closed

This topic has been closed to new replies.

About this Topic