WordPress.org

Ready to get started?Download WordPress

Forums

Rename wp-login.php
[resolved] Can't login (18 posts)

  1. mbnocx
    Member
    Posted 12 months ago #

    I installed this plugin last night while on my home PC. I was able to rename wp-login.php to something else. I then tested and was successfully able to login and out using that new file path. Now today I am on my work computer and even when I go to the new login path I get a "403 Forbidden" error message. Everything worked fine yesterday. Is there any way I can disable the plugin to get back into my WP admin screen?

    http://wordpress.org/plugins/rename-wp-login/

  2. Janneke Van Dorpe
    Member
    Plugin Author

    Posted 12 months ago #

    What's the new login path? And what's the website?

  3. Janneke Van Dorpe
    Member
    Plugin Author

    Posted 12 months ago #

    If you're really stuck you can deactivate the plugin by removing the folder 'rename-wp-login' from 'wp-content' > 'plugins'. But I'd really like to know what went wrong, so I'd appreciate if I could get some more information. Thanks!

  4. mbnocx
    Member
    Posted 12 months ago #

    The site is markblair.net and the new file name is loginsecure. I haven't disabled anything yet in case you can figure this out first - as I'd like to still use the plugin. :)

  5. mbnocx
    Member
    Posted 12 months ago #

    The interesting part is when I first go to markblair.net/loginsecure I get the WP login window. I then enter my information and it is after that point that it goes to the following error:

    403 Forbidden
    Access to this resource on the server is denied!

  6. Janneke Van Dorpe
    Member
    Plugin Author

    Posted 12 months ago #

    Okay, so when I go to http://www.markblair.net/loginsecure I get the login screen. You get that too right? And then you try to login and you get 403 Forbidden? Is that right?

  7. mbnocx
    Member
    Posted 12 months ago #

    Yes that is right.
    If you type any username and password into the WP login window (it doesn't have to be valid) you will see the error that I am seeing when logging in.

  8. Janneke Van Dorpe
    Member
    Plugin Author

    Posted 12 months ago #

    So I enter test as username and test as password and I get a normal error message... Have you tried emptying your browser cache or a different browser?

  9. Janneke Van Dorpe
    Member
    Plugin Author

    Posted 12 months ago #

    Can you also try it again at home where it did work before?

  10. mbnocx
    Member
    Posted 12 months ago #

    I have tried both IE and Firefox and I just cleared the cache and still no go. I went to the browser on my phone which is through AT&T and I have the same problem.

    On a side note, I recently switched hosting companies and I had to change my DNS with my domain registrar. It took an abnormal amount of time (~5 days) before I could get to my sites at the new host when I'm at work. I mention this because I wonder if that is related. Although my phone is getting the same error which is not connected to my work Internet connection. :/

  11. mbnocx
    Member
    Posted 12 months ago #

    Another thing to point out, when I go to wp-login.php from my work computer I get a 404 page, which would tell me that my work Internet is seeing the change I made last night.

    I will try again from home later but this is definitely an odd issue. :)

  12. Janneke Van Dorpe
    Member
    Plugin Author

    Posted 12 months ago #

    That might be your problem, though DNS changes usually propagate within a day.
    Everything seems to be fine when I try it, I would just see what happens tomorrow.
    I think it's a server issue though. Can you keep me updated? :)

  13. mbnocx
    Member
    Posted 12 months ago #

    Thanks for the help yesterday. I am able to login without any problems when at home using the updated link created by this plugin. For some reason I still cannot login using that same link from my work computer. I also still cannot from my smartphone which is not connected in any way to my Internet access at work.

    I don't doubt that something at work is causing the problem. I just find it odd since this has nothing to do with DNS changes and if I FTP into my site and change a file right now it can be seen instantaneously from both work and home. I'll give this a few more days and try again.

  14. Janneke Van Dorpe
    Member
    Plugin Author

    Posted 12 months ago #

    That's weird. What happens if you deactivate the plugin at home and try to access wp-login.php from your smartphone or work?
    What other plugins do you have installed?

  15. Janneke Van Dorpe
    Member
    Plugin Author

    Posted 12 months ago #

    Aha!
    I just tried accessing http://www.markblair.net/loginsecure and I get 403 Forbidden (before trying to log in). Trying to access anything on your website however gives me the same status code. I get 403 Fordbidden for http://www.markblair.net as well.
    Seems like it's a server issue... I'd contact your host about it.

  16. Janneke Van Dorpe
    Member
    Plugin Author

    Posted 12 months ago #

    Seems like DNS changes aren't propagating properly (these are different from file changes btw). I'm going to resolve this ticket for now since it doesn't have anything to do with this plugin. Feel free to keep me updated or ask anything though!

  17. mbnocx
    Member
    Posted 12 months ago #

    I disabled this plugin via FTP which allows me into wp-admin and is likely why you got the 403 error when going to loginsecure (since that's not valid at this time). :)

    But, the rest of the site should work fine and I can see it now. Weird. No worries on marking this as resolved as I also agree this is very unlikely a plugin issue. If I have other questions about this plugin I will definitely ask them here. Thanks again!

  18. Janneke Van Dorpe
    Member
    Plugin Author

    Posted 12 months ago #

    Ok, but then it should return a 404 not found, not 403 forbidden. And the rest of the website gave the same response, but now it works again.

    So now the standard login page works fine again? I would try to install this plugin again in a few days or a week, when you're sure the rest of your website doesn't return any 403's anymore.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.