WordPress.org

Ready to get started?Download WordPress

Forums

Can't log into dashboard (26 posts)

  1. markf1
    Member
    Posted 1 year ago #

    I have a wordpress site that is on my localhost. I uploaded/copied all of the files for the site into a folder on my account at fatcow. i also created and imported the database for the site using phpMyAdmin from the cp at fatcow. The site appears and functions exactly as it should:
    http://www.openrangeimaging.com/Test/helitrax/

    The problem is I cannot log into the WordPress dashboard. I have tried resetting the password and still no luck. I keep getting the following error message:
    You do not have sufficient permissions to access this page.
    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, cgiadmin@yourhostingaccount.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Can anyone advise me on what might be the problem? Should I have dome a new wordpress install versus copying all the files from my local host?. Like I said the site appears and functions perfectly, just can't get logged into the dashboard. Any help much appreciated.

    Thank you.

  2. ricardusexa
    Member
    Posted 1 year ago #

  3. markf1
    Member
    Posted 1 year ago #

    Hi,

    I think you mis-understand my question/problem. If I wanted to log into the the wp dashboard for the site in question I wold use
    http://www.openrangeimaging.com/Test/helitrax/wp-admin.

    I know how to log in. The problem I'm having is that the log in does not work. See my first post above.

    But thanks for trying to help.

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    Try:
    - switching to the Twenty Eleven theme by renaming your current theme's folder inside wp-content/themes and adding "-old" to the end of the folder name using FTP or whatever file management application your host provides.

    - resetting the plugins folder by FTP or phpMyAdmin.

  5. markf1
    Member
    Posted 1 year ago #

    Hi esmi,
    Thanks for those trouble shooting suggestions.
    I tried renaming the current-theme to -old and I tried renaming the plugins folder to -old.
    Unfortunately no luck with that.
    Renaming the current theme folder made the site not appear at all.
    Renaming the plugins folder results in getting the same server error as before.

    still can't log into dashboard but site works fine otherwise. Stumped.

  6. esmi
    Forum Moderator
    Posted 1 year ago #

    Re-upload a fresh, unpacked, copy of the Twenty Eleven folder to wp-content/themes using FTP or whatever file management application your host provides.
    http://wordpress.org/extend/themes/twentyeleven

  7. racer x
    Member
    Posted 1 year ago #

    still can't log into dashboard but site works fine otherwise.

    I am not seeing what you are seeing then. I get a page with a zero when I go to your link?

  8. markf1
    Member
    Posted 1 year ago #

    ok I'm trying what esmi is suggesting.

    racer x - I'm working on a variety of replacing folders, re-installing etc so the site is temporarily returning the zero.I'll post here after I've tried these various things.

    thanks!

  9. markf1
    Member
    Posted 1 year ago #

    Hi,

    Unfortunately I am still stuck. I tried doing a complete new install of wordpress. I was able to log in to the dashboard of the new wordpress install. Next I replaced the wp-content folder with the wp-content folder form the localhost version I have. Next I imported the SQL database from my localhost.

    Same result. The site loads and functions correctly. I even have the wp-admin bar at the top of the screen and it has my user name displayed on the right hand side and shows me as logged in.

    Not sure if this provides any clue but. The admin bar also shows the site name on the left hand side, but under the site name I only have Dashboard as an option. The Themes, Customize, Widgets,Menus choices are not there. Also the Edit Page and +New links are missing from the admin bar.

    I just can't figure out whats wrong. Seems like some little glitch somewhere but ....where? Thanks for your ongoing help!

  10. esmi
    Forum Moderator
    Posted 1 year ago #

    Using Phpmyadmin (or another MySQL management tool), first backup your database. Then navigate to your wp_usermeta table and locate the meta_key called "wp_capabilities" for your user_id. Change the meta-value for this record to:

    a:1:{s:13:"administrator";s:1:"1";}

  11. markf1
    Member
    Posted 1 year ago #

    Hi esmi,

    I tried your suggestion. Sorry, but I'm still getting the same reults and error message.

    I very much appreciate your help!

  12. esmi
    Forum Moderator
    Posted 1 year ago #

    How many admin users do you have in your database?

  13. markf1
    Member
    Posted 1 year ago #

    there are 4 admin users.

    wild guess on my part. this is copied from the wp-config. Could this have something to do with this?

    Another wild guess is some kind of htaccess issue with the host (fatcow)?

    thanks again for your ongoing effort to help!

  14. markf1
    Member
    Posted 1 year ago #

    oops , I meant to include the code from the wp-config. here it is in reference to my first wild guess above

    deleted code per advice from racer x

  15. racer x
    Member
    Posted 1 year ago #

    Be careful with what you display from wp-config.php.

    Can you try logging in as any of the other admins? It looks like you are logged in as a subscriber.

  16. markf1
    Member
    Posted 1 year ago #

    I tried logging in as one of the other admins. Same result/error message.

    Thanks for your ongo9ing effort to help!

  17. racer x
    Member
    Posted 1 year ago #

    Since I can't think of anything else, you can try to create a new user as an administrator programmatically.

    Add this to your functions.php file:

    wp_insert_user( array ( 'user_pass' => 'password2', 'user_login' => 'test', 'role' => 'administrator' ) ) ;

    You can use anything for user_pass(the password) and user_login(the login name).

    Click any new page, link, etc. only ONE time, then remove the code from your functions.php file. (It will try to create a new user on every page load otherwise.)

    Then, try logging in as this new user and see if you have all permissions.

  18. markf1
    Member
    Posted 1 year ago #

    OMG! that worked and I was able to log in to the dashboard. I see my original username as well as the other 3 users, but the role I have assigned to me is "None". In fact the other 3 users also have a role of "None"
    I tried changing my role to "Administrator" and saving the change but it won't stick. keeps reverting back to role "none"

    Not sure what to do now but this was a good step forward. Thanks!

  19. racer x
    Member
    Posted 1 year ago #

    I am truly stumped now. I have always been able to edit a user role as long as I was an administrator.

    Are you using any type of user role management plugin by any chance?

    Nice looking site BTW.

  20. markf1
    Member
    Posted 1 year ago #

    no I am not using any such plug in. I was able to delete my original user name and etc. then re created it and gave myself the admin role. that worked. still when logged in as Admin I cannot change the other user roles from "none" back to admin or even subscriber.

    weird. I would like to know what is causing this so I could avoid it in the future. meanwhile thanks very much for getting me to this point!!

  21. esmi
    Forum Moderator
    Posted 1 year ago #

    Do you have a recent database backup?

  22. markf1
    Member
    Posted 1 year ago #

    yes I do have a recent db back up.

  23. esmi
    Forum Moderator
    Posted 1 year ago #

    Then you might want to try using that backup to populate a new database and then edit your wp-config.php file to point to the new database.

  24. markf1
    Member
    Posted 1 year ago #

    thank you for your reply. that is what I have been doing all along. taking the db from my local install and populating the new/copy install in my Test folder at fatcow.

    thanks again for your help.

  25. esmi
    Forum Moderator
    Posted 1 year ago #

    taking the db from my local install

    Ah - that's not as straightforward as you might think. You'd need to have a look at Moving_WordPress.

  26. markf1
    Member
    Posted 1 year ago #

    Thank you . I had read that as well as some other tutorial type stuff that I got thru google search.

    Because the site appears and functions exactly as it should I think I'm basically doing it right. why it changed the role of the 4 registered users from "admin" to "none" and then wouldn't allow me to edit my user info and restate my role as admin, I don't know.

    I'm pretty sure I followed the correct procedure and have even tried a couple of different ways.

    One I just copied all of the site files and folders form local host to the new host. then did the database install.

    I also tried just doing a clean install of wordpress and then replacing the wp-contents folder and re-populating the database.

    Not sure if one method is better that the other. They both produced the same result. The site appeared and it worked perfectly. Just could not log into dashboard.

    Thanks for your help!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.